FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian User

 
 
LinkBack Thread Tools
 
Old 08-25-2011, 09:34 PM
sppmg
 
Default grub error message:symbol not found.....

(I use debian testing , Bootloader is grub2.)

I upgrade debian (testing to testing) by apt yesterday.
When it done, I reboot,and get this message:

symbol not found: 'grub_dirmod64_full'

and it goes to "grub rescue>"
---------------------------
solution:
I use other grub (from my usb) to boot HDD OS.
(enter command and type:

linux (hd1,6)/vmlinuz-3.0.0-1-amd64 root=/dev/sda5
initrd (hd1,6)/initrd.img-3.0.0-1-amd64
boot


# note:
# my / is sda5 or (hd1,5)
# my boot is sda6 or (hd1,6)
)
And reinstall grub to MBR:
# grub-install /dev/sda
and update grub
# update-grub
-----------------------------
ok,it's solution.easy.

I google "grub_dirmod64_full",but not found anything.
So,I share to this.


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Archive: 4E56BFE0.6010204@gmail.com">http://lists.debian.org/4E56BFE0.6010204@gmail.com
 

Thread Tools




All times are GMT. The time now is 06:37 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org