FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian User

 
 
LinkBack Thread Tools
 
Old 08-23-2011, 11:02 AM
Ralf Jung
 
Default Pixel garbage when opening context menus

Hi list,

since upgrading from Kubuntu (10.10) to Debian testing, I am noticing that a
context-menu, directly after right-clicking, contains pixel garbage that is
then overdrawn with the actual content. I often recognize the garbage as
content from some window. This also applies to other menus, like the K-Menu,
and sometimes (especially when the system is under load) even for whole
windows. When clicking the logout/shutdown button, the background around the
dialogue where I have to confirm my choice also shows garbage. I do not
remember anything like that from back when I used Kubuntu.

I am using Debian testing and KDE. The issue is present both on my laptop (AMD
Radeon HD 3200, I tried both the open-source and the closed-source driver) and
my desktop (NVidia GeForce 8500, closed-source driver). It does not matter
whether compositing is enabled or disabled (except for the logout/shutdown
dialogue problem, which appears only with composite disabled).

Now I wonder, which package do I have to report the bug against? It can hardly
be the driver, but it could be everything else in the graphics stack, as far
as I can tell. I also wonder whether anyone else is having the same problem.

Kind regards,
Ralf


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 201108231302.57951.ralfjung-e@gmx.de">http://lists.debian.org/201108231302.57951.ralfjung-e@gmx.de
 
Old 08-30-2011, 10:49 AM
Camaleón
 
Default Pixel garbage when opening context menus

On Tue, 23 Aug 2011 13:02:57 +0200, Ralf Jung wrote:

(...)

> Now I wonder, which package do I have to report the bug against? It can
> hardly be the driver, but it could be everything else in the graphics
> stack, as far as I can tell. I also wonder whether anyone else is having
> the same problem.

I would run some tests, for instance, run a Debian LiveCD with GNOME
+radeon driver (to discard the DE) or even try with another VGA card (to
discard a hardware issue) and see how it goes.

If GNOME does not expose the same behaviour, I would open a bug against
KDE base libs. If GNOME does show the same thing, open the bug against
radeon drivers (the bug needs to be open against open source drivers).

Greetings,

--
Camaleón


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: pan.2011.08.30.10.49.49@gmail.com">http://lists.debian.org/pan.2011.08.30.10.49.49@gmail.com
 
Old 08-30-2011, 04:48 PM
Steve B
 
Default Pixel garbage when opening context menus

On Tuesday 30 August 2011 12:49:49 Camaleón wrote:
> On Tue, 23 Aug 2011 13:02:57 +0200, Ralf Jung wrote:
>
> (...)
>
> > Now I wonder, which package do I have to report the bug against? It can
> > hardly be the driver, but it could be everything else in the graphics
> > stack, as far as I can tell. I also wonder whether anyone else is having
> > the same problem.
>
> I would run some tests, for instance, run a Debian LiveCD with GNOME
> +radeon driver (to discard the DE) or even try with another VGA card (to
> discard a hardware issue) and see how it goes.
>
> If GNOME does not expose the same behaviour, I would open a bug against
> KDE base libs. If GNOME does show the same thing, open the bug against
> radeon drivers (the bug needs to be open against open source drivers).
>
> Greetings,

Hi,

Same problem here on a desktop with IGP (Radeon HD 4200).
I don't remember when it appears but it's recent.

I just noticed that it only occurs on QT based applications, i.e. the "pixel
garbage" appears on right-click with KDE apps and VLC but not with Iceweasel.

System: Debian wheezy 32bits, KDE, no compositing, all effects disabled, only
xserver-xorg-video-radeon installed.

I ran a LiveCD recently (for other purposes) without noticing any bug wathever
the DE was (Gnome, KDE, LXDE, XFCE) but the LiveCD is not Debian based
(Hybryde NirvanOS).


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 201108301848.26355.b.steve@gmx.com">http://lists.debian.org/201108301848.26355.b.steve@gmx.com
 
Old 08-30-2011, 05:13 PM
Camaleón
 
Default Pixel garbage when opening context menus

On Tue, 30 Aug 2011 18:48:26 +0200, Steve B wrote:

> On Tuesday 30 August 2011 12:49:49 Camaleón wrote:
>> On Tue, 23 Aug 2011 13:02:57 +0200, Ralf Jung wrote:
>>
>> (...)
>>
>> > Now I wonder, which package do I have to report the bug against? It
>> > can hardly be the driver, but it could be everything else in the
>> > graphics stack, as far as I can tell. I also wonder whether anyone
>> > else is having the same problem.
>>
>> I would run some tests, for instance, run a Debian LiveCD with GNOME
>> +radeon driver (to discard the DE) or even try with another VGA card
>> (to discard a hardware issue) and see how it goes.
>>
>> If GNOME does not expose the same behaviour, I would open a bug against
>> KDE base libs. If GNOME does show the same thing, open the bug against
>> radeon drivers (the bug needs to be open against open source drivers).
>
> Same problem here on a desktop with IGP (Radeon HD 4200). I don't
> remember when it appears but it's recent.
>
> I just noticed that it only occurs on QT based applications, i.e. the
> "pixel garbage" appears on right-click with KDE apps and VLC but not
> with Iceweasel.

I'd say that's a very good catch :-), if it's limited to the Qt stack
then you've done half of the debugging work.

> System: Debian wheezy 32bits, KDE, no compositing, all effects disabled,
> only xserver-xorg-video-radeon installed.
>
> I ran a LiveCD recently (for other purposes) without noticing any bug
> wathever the DE was (Gnome, KDE, LXDE, XFCE) but the LiveCD is not
> Debian based (Hybryde NirvanOS).

Have you both considered in opening a bug report at Debian BTS for
this? :-?

Greetings,

--
Camaleón


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: pan.2011.08.30.17.13.38@gmail.com">http://lists.debian.org/pan.2011.08.30.17.13.38@gmail.com
 
Old 08-30-2011, 08:15 PM
Steve B
 
Default Pixel garbage when opening context menus

On Tuesday 30 August 2011 19:13:40 Camaleón wrote:
>
> Have you both considered in opening a bug report at Debian BTS for
> this? :-?
>

I checked if a bug report had already been filed in the Debian or KDE BTS.
I found nothing therefore opened this one :
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=639845

I filed the bug report against kde-window-manager (KWin) but it could be Qt or
another.

Please feel free, Ralf or anybody, to complete my description.

--
Steve


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 201108302215.48776.b.steve@gmx.com">http://lists.debian.org/201108302215.48776.b.steve@gmx.com
 
Old 08-31-2011, 09:13 AM
Ralf Jung
 
Default Pixel garbage when opening context menus

Hi,

I don't have another VGA card available, but as I said this is already
happening on two (counting Steve, three) completely independent machines, so
I'd say we can rule the hardware out ;-)
Indeed I can not see the garbage in Firefox, but I will have to test again
when the system is under load.

I am not surprised that a Ubuntu LiveCD does not show the issue, it was not
present when I used Kubuntu as my main system either.

Thanks for opening a bugreport, I'll subscribe to it!

Kind regards,
Ralf

On Tuesday 30 August 2011 22:15:48 Steve B wrote:
> On Tuesday 30 August 2011 19:13:40 Camaleón wrote:
> > Have you both considered in opening a bug report at Debian BTS for
> > this? :-?
>
> I checked if a bug report had already been filed in the Debian or KDE BTS.
> I found nothing therefore opened this one :
> http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=639845
>
> I filed the bug report against kde-window-manager (KWin) but it could be Qt
> or another.
>
> Please feel free, Ralf or anybody, to complete my description.
>
> --
> Steve


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 201108311113.49297.ralfjung-e@gmx.de">http://lists.debian.org/201108311113.49297.ralfjung-e@gmx.de
 

Thread Tools




All times are GMT. The time now is 01:45 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org