FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian User

 
 
LinkBack Thread Tools
 
Old 06-16-2011, 05:37 PM
David Baron
 
Default WARNING: Stay off Sid /lib upgrades!, more

On Wednesday 13 Sivan 5771 17:55:56 you wrote:

> Since this is now a mixed-up system (until Sid's maintainers get stuff

> together, completely, responsibly (posting defective /lib upgrades is

> inexcusable because of the mess made for us Debian Sid users!), there may

> still be problems, i.e. another package or two to downgrade.

>

> Problem 1: Trying a normal synaptic upgrade of some programs, I got errors

> that UTF8 could not be converted to latin1... and it aborted. Apt-get does

> work (in a non-X terminal) because I did that with the KDE stuff. So what

> package needs be up/down-graded to fix the character conversions?

>

> Hint: reportbug-ng yields messages like:

> QIconvCodec::convertFromUnicode: using Latin-1 for conversion, iconv failed

> for BOM: Bad file descriptor QIconvCodec::convertFromUnicode: using

> Latin-1 for conversion, iconv_open failed QIconvCodec::convertToUnicode:

> using Latin-1 for conversion, iconv_open failed




So I do not know. Not having synaptic working is not nice but I guess there are alternative including (yipes!) CLI.




Also, no man pages will display!




These errors are confusing, however. The iconv stuff comes from libc6. The gconv conversion .so's are from testing to sid are ... identical. All of them.




So what am I missing here?
 
Old 06-16-2011, 09:25 PM
Heddle Weaver
 
Default WARNING: Stay off Sid /lib upgrades!, more

On 17 June 2011 03:37, David Baron <d_baron@012.net.il> wrote:



On Wednesday 13 Sivan 5771 17:55:56 you wrote:

> Since this is now a mixed-up system (until Sid's maintainers get stuff

> together, completely, responsibly (posting defective /lib upgrades is

> inexcusable because of the mess made for us Debian Sid users!), there may

> still be problems, i.e. another package or two to downgrade.

>

> Problem 1: Trying a normal synaptic upgrade of some programs, I got errors

> that UTF8 could not be converted to latin1... and it aborted. Apt-get does

> work (in a non-X terminal) because I did that with the KDE stuff. So what

> package needs be up/down-graded to fix the character conversions?

>

> Hint: reportbug-ng yields messages like:

> QIconvCodec::convertFromUnicode: using Latin-1 for conversion, iconv failed

> for BOM: Bad file descriptor QIconvCodec::convertFromUnicode: using

> Latin-1 for conversion, iconv_open failed QIconvCodec::convertToUnicode:

> using Latin-1 for conversion, iconv_open failed




So I do not know. Not having synaptic working is not nice but I guess there are alternative including (yipes!) CLI.




Also, no man pages will display!




These errors are confusing, however. The iconv stuff comes from libc6. The gconv conversion .so's are from testing to sid are ... identical. All of them.




So what am I missing here?

Going to the aptitude cli or ncurses interface might yield something profitable.
There is an app or x-term that doesn't accept unicode gracefully, but I can't remember which.

I'd check the /etc/apt/sources.list for discrepancies there also, if you've recently, or even not so recently jumped a distribution.
The read-outs at the bottom of the aptitude ncurses interface are useful in resolving incompatibilities I've found.

Regards,

Weaver.
--

Religion is regarded by the common people as true,
by the wise as false,
and by the rulers as useful.

— Lucius Annæus Seneca.

Terrorism, the new religion.
 

Thread Tools




All times are GMT. The time now is 08:33 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org