FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian User

 
 
LinkBack Thread Tools
 
Old 06-10-2011, 08:13 PM
Nicolas Bercher
 
Default icedove/yahoo imap: messages marked as read & filters not run on inbox

Hi,

I recently set up my yahoo.fr account (this one) as an *imap* mailbox under thunderbird.
I've waited a long time for this to happen and with the success of smart phones, it seems
that yahoo enabled an imap server, but didn't communicate that much for regular users (the
one who got their accounts without smart phones).


However, I have two issues that might concern many people here that uses icedove and have
yahoo mailboxes:


1. Near every messages that arrive into inbox and are marked as read, but not all of
them. This seems to be an imap side-problem: my account was freshly set up and I never
saw this before with account from other imap providers (and of course I've check icedove
config many times).


2. Mail filters I defined (on the icedove side) doesn't work automatically (again, I've
check configuration many times) and I have to run "alt-t r" to manually apply the filters
on inbox.


So, do you (smart people) see anything special here, have experience with yahoo imap and
so on?


Thank a lot,

Nicolas


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Archive: 4DF27AE0.2030304@yahoo.fr">http://lists.debian.org/4DF27AE0.2030304@yahoo.fr
 
Old 06-10-2011, 08:55 PM
PaulNM
 
Default icedove/yahoo imap: messages marked as read & filters not run on inbox

On 06/10/2011 04:13 PM, Nicolas Bercher wrote:
> Hi,
>

snip

>
> 1. Near every messages that arrive into inbox and are marked as read,
> but not all of them. This seems to be an imap side-problem: my account
> was freshly set up and I never saw this before with account from other
> imap providers (and of course I've check icedove config many times).
>

Are you sure nothing else is reading the messages? I don't have yahoo
imap, but I know that if I read the messages on my phone, they'll show
up as read the next time I check in Thunderbird.


> 2. Mail filters I defined (on the icedove side) doesn't work
> automatically (again, I've check configuration many times) and I have to
> run "alt-t r" to manually apply the filters on inbox.
>

Solving number 1 will solve this. Thunderbird (and Icedove) only
automatically apply filters to new messages. Any messages I read
through my phone and/or webmail will not be filtered automatically. I
need to run filters to do that.

snip

> Thank a lot,
>
> Nicolas
>

Thanks for the filter shortcut, I've been meaning to look that up.

PaulNM


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 4DF284B4.1020809@paulscrap.com">http://lists.debian.org/4DF284B4.1020809@paulscrap.com
 
Old 06-10-2011, 08:57 PM
PaulNM
 
Default icedove/yahoo imap: messages marked as read & filters not run on inbox

To clarify, I was talking about my experiences with multiple other imap
accounts. I do have a yahoo account that I don't really use, but it is pop3.

PaulNM


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 4DF28557.6000907@paulscrap.com">http://lists.debian.org/4DF28557.6000907@paulscrap.com
 
Old 06-11-2011, 01:35 PM
Camaleón
 
Default icedove/yahoo imap: messages marked as read & filters not run on inbox

On Fri, 10 Jun 2011 22:13:20 +0200, Nicolas Bercher wrote:

(...)

> However, I have two issues that might concern many people here that uses
> icedove and have yahoo mailboxes:
>
> 1. Near every messages that arrive into inbox and are marked as read,
> but not all of
> them. This seems to be an imap side-problem: my account was freshly set
> up and I never saw this before with account from other imap providers
> (and of course I've check icedove config many times).

According to Wikipedia¹, it seems that Yahoo! provides a non-standard
imap service so it can be hard to know what they are doing in the
backstage. And AFAIK, message status (read, deleted, unread...) is stored
on the server.

I would first try to configure your imap account with another MUA to see
if you get a different behaviour than with Icedove.

> 2. Mail filters I defined (on the icedove side) doesn't work
> automatically (again, I've
> check configuration many times) and I have to run "alt-t r" to manually
> apply the filters on inbox.
>
> So, do you (smart people) see anything special here, have experience
> with yahoo imap and so on?

What kind of filters have you setup? Maybe they're what make the messages
to be marked as read. The more specific you be, the better :-)

¹http://en.wikipedia.org/wiki/Yahoo!_Mail#Free_IMAP_and_SMTPs_access

Greetings,

--
Camaleón


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: pan.2011.06.11.13.35.34@gmail.com">http://lists.debian.org/pan.2011.06.11.13.35.34@gmail.com
 
Old 06-11-2011, 04:37 PM
Nicolas Bercher
 
Default icedove/yahoo imap: messages marked as read & filters not run on inbox

On 10/06/2011 22:55, PaulNM wrote:

On 06/10/2011 04:13 PM, Nicolas Bercher wrote:

Hi,
1. Near every messages that arrive into inbox and are marked as read,
but not all of them. This seems to be an imap side-problem: my account
was freshly set up and I never saw this before with account from other
imap providers (and of course I've check icedove config many times).



Are you sure nothing else is reading the messages? I don't have yahoo
imap, but I know that if I read the messages on my phone, they'll show
up as read the next time I check in Thunderbird.


OK, maybe you point out something interesting here: since I have the strong feeling that
yahoo imap status is between alpha and beta (somehow confirmed by Camaleón on this
thread), I used to keep alive the pop3 access for the same yahoo account on the same
icedove profile. Maybe the pop3 side config in fetching e-mails, leaving them on the
server, etc. has an effect on the imap side.


Nicolas


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Archive: 4DF399B5.8000505@yahoo.fr">http://lists.debian.org/4DF399B5.8000505@yahoo.fr
 
Old 06-11-2011, 04:43 PM
Nicolas Bercher
 
Default icedove/yahoo imap: messages marked as read & filters not run on inbox

On 11/06/2011 15:35, Camaleón wrote:

On Fri, 10 Jun 2011 22:13:20 +0200, Nicolas Bercher wrote:

(...)


However, I have two issues that might concern many people here that uses
icedove and have yahoo mailboxes:

1. Near every messages that arrive into inbox and are marked as read,
but not all of
them. This seems to be an imap side-problem: my account was freshly set
up and I never saw this before with account from other imap providers
(and of course I've check icedove config many times).


According to Wikipedia¹, it seems that Yahoo! provides a non-standard
imap service so it can be hard to know what they are doing in the
backstage. And AFAIK, message status (read, deleted, unread...) is stored
on the server.
I will try another MUA, right after disabling pop3 access on this same account under the
same icedove profile (see my other mail in this thread).



What kind of filters have you setup? Maybe they're what make the messages
to be marked as read. The more specific you be, the better :-)
I basically use filters for mailing lists sorting. So the filters are of the form "if
from, to, cc or bcc equals debian-user@lists.debian.org then move message to folder
debian-user".


The tests I have to do will maybe span a few hours/days in order to verify if all is ok or
not. Stay tuned eventually.


Thanks,
Nicolas


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Archive: 4DF39B30.10902@yahoo.fr">http://lists.debian.org/4DF39B30.10902@yahoo.fr
 
Old 06-12-2011, 02:02 PM
Chris Davies
 
Default icedove/yahoo imap: messages marked as read & filters not run on inbox

Nicolas Bercher <nbercher@yahoo.fr> wrote:
> Maybe the pop3 side config in fetching e-mails, leaving them on the
> server, etc. has an effect on the imap side.

I should expect that reading a message with POP would indeed mark it as
read for the IMAP presentation. IMO this would be correct behaviour, and
the corollary is that you shouldn't mix and match your email protocols.

Chris


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 3gtec8xhhd.ln2@news.roaima.co.uk">http://lists.debian.org/3gtec8xhhd.ln2@news.roaima.co.uk
 
Old 06-12-2011, 03:14 PM
Nicolas Bercher
 
Default icedove/yahoo imap: messages marked as read & filters not run on inbox

On 12/06/2011 16:02, Chris Davies wrote:

Nicolas Bercher<nbercher@yahoo.fr> wrote:

Maybe the pop3 side config in fetching e-mails, leaving them on the
server, etc. has an effect on the imap side.


I should expect that reading a message with POP would indeed mark it as
read for the IMAP presentation. IMO this would be correct behaviour, and
the corollary is that you shouldn't mix and match your email protocols.


I'm trying many things at the moment.

First, I disabled the pop3 account in icedove, but this had no effect at all.

Second, I visited the yahoo webmail interface in order to turn off the pop3 access option.
Then, I sent dummy mails to my account and yes, they arrived as "unread messages", so
"issue 1" seems solved...


...but, the tricky thing is that I can't turn off the pop3 option WITHOUT setting up a
mail transfert...! This is really stupid: it is impossible to disable the two options at
the same time!
In order to continue my investigations, I created another yahoo mail account to receive
these mail transfers and see what happens. This is really annoying.


Nicolas


Note: the mail account that initially have issues is an old yahoo account (created in
1999) and is maybe not supported like the recent ones.
The new account I created today (and of course access via imap) seems to receive messages
as expected (i.e. "marked as unread") but server-side filters (i.e. defined via the
webmail interface) do not work when accessed via imap (it seems they work only with
webmail/pop3 "accesses").



--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Archive: 4DF4D7BF.5040403@yahoo.fr">http://lists.debian.org/4DF4D7BF.5040403@yahoo.fr
 
Old 06-12-2011, 03:14 PM
Nicolas Bercher
 
Default icedove/yahoo imap: messages marked as read & filters not run on inbox

On 12/06/2011 16:02, Chris Davies wrote:

Nicolas Bercher<nbercher@yahoo.fr> wrote:

Maybe the pop3 side config in fetching e-mails, leaving them on the
server, etc. has an effect on the imap side.


I should expect that reading a message with POP would indeed mark it as
read for the IMAP presentation. IMO this would be correct behaviour, and
the corollary is that you shouldn't mix and match your email protocols.


I'm trying many things at the moment.

First, I disabled the pop3 account in icedove, but this had no effect at all.

Second, I visited the yahoo webmail interface in order to turn off the pop3 access option.
Then, I sent dummy mails to my account and yes, they arrived as "unread messages", so
"issue 1" seems solved...


...but, the tricky thing is that I can't turn off the pop3 option WITHOUT setting up a
mail transfert...! This is really stupid: it is impossible to disable the two options at
the same time!
In order to continue my investigations, I created another yahoo mail account to receive
these mail transfers and see what happens. This is really annoying.


Nicolas


Note: the mail account that initially have issues is an old yahoo account (created in
1999) and is maybe not supported like the recent ones.
The new account I created today (and of course access via imap) seems to receive messages
as expected (i.e. "marked as unread") but server-side filters (i.e. defined via the
webmail interface) do not work when accessed via imap (it seems they work only with
webmail/pop3 "accesses").



--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Archive: 4DF4D7CF.7070304@yahoo.fr">http://lists.debian.org/4DF4D7CF.7070304@yahoo.fr
 
Old 06-12-2011, 07:44 PM
Nicolas Bercher
 
Default icedove/yahoo imap: messages marked as read & filters not run on inbox

On 12/06/2011 17:14, Nicolas Bercher wrote:

...but, the tricky thing is that I can't turn off the pop3 option
WITHOUT setting up a mail transfert...! This is really stupid: it is
impossible to disable the two options at the same time!
In order to continue my investigations, I created another yahoo mail
account to receive these mail transfers and see what happens. This is
really annoying.
I solved this by editing html code with iceweasel/firebug and sending to the server a
response with no button checked. During my googling time, I found a message of 2002
relating the same stupid situation in the webmail interface. It's crazy to see how old
this issue is.


Now, I think I solved all of the problems with yahoo imap and my account.

Thanks to you all.

Nicolas


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Archive: 4DF51737.6070806@yahoo.fr">http://lists.debian.org/4DF51737.6070806@yahoo.fr
 

Thread Tools




All times are GMT. The time now is 12:35 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org