FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian User

 
 
LinkBack Thread Tools
 
Old 06-10-2011, 02:49 PM
"tv.debian@googlemail.com"
 
Default How to install with encrypted root?

10/06/2011 15:25, Christian Jaeger wrote:
> Hi
>
> I'm trying to install squeeze with "/" being a partition dmcrypt'ed
> with luks. Is Debian supposed to support that or not? For me the
> debian installer failed to do it, so I sent mail to debian-boot about
> it [1] and then since I didn't get a reply reported a bug against
> initramfs-tools [2], where Maximilian Attems told me to get support
> here.
>
> [1] http://lists.debian.org/debian-boot/2011/06/msg00068.html
> [2] http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=629985
>
> So please tell me what I'm doing it wrong, whether it works for you,
> or whether that's in fact a result of bug(s) and ideally to which
> package(s) it(they) should be reported.
>
> Thanks,
> Christian.
>
>

Hi, I can confirm that it works, my main system is fully on Luks ( To be
precise it is luks on raid1, and /home is decrypted with pam, swap with
decrypt_derived.).
I set up a similar system from a wheezy netinstall amd64 (2011-05-12)
ISO. I did it in expert mode (don't know if it matters), I didn't go the
"Debian way" (one lvm on luks) but I manually created luks containers
(/, swap and /home), a separate /boot, then went forward with the
installation and it worked flawlessly.

I can't explain why it doesn't work in your case, you could try to add
the required modules to /etc/initramfs-tools/modules, or check in
/etc/initramfs-tools/initramfs.conf that you have MODULES=most and
BUSYBOX=yes.
Maybe cp the /usr/share/initramfs-tools/hooks/cryptroot hook script to
/etc/initramfs-tools/hooks/, this shouldn't be necessary though.

Do you have a /etc/crypttab file, is it accurate ? Is the fstab too ?
Tried reinstalling cryptsetup from the chroot ?


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 4DF22EF7.7090700@googlemail.com">http://lists.debian.org/4DF22EF7.7090700@googlemail.com
 

Thread Tools




All times are GMT. The time now is 09:56 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org