FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian User

 
 
LinkBack Thread Tools
 
Old 04-28-2011, 04:39 PM
Brad Alexander
 
Default Need help with post-squeeze problems

I got my daughter's netbook upgraded to squeeze, however, there are some issues that I have encountered. I did it per the squeeze release notes, the audit, etc, then apt-get update on the new sources.lists, apt-get upgrade, upgraded kernel and udev, rebooted, then did the dist-upgrade. The dist-upgrade removed a bunch of packages:


The following packages will be REMOVED:
* build-essential cervisia cupsddk-drivers debhelper dh-make g++ g++-4.3 gcc
* gcc-4.3 gettext gnuift gnuift-perl imagemagick intltool-debian kde-trinity
* kdemultimedia-trinity kdewebdev-trinity kernel-package kommander-trinity

* libarts1-xine-trinity libblas3gf libcvsservice0 libdatrie0 libept0
* libgfortran3 libgomp1 libgraphviz4 liblapack3gf libmagick10 librpm4.4
* libstdc++6-4.3-dev libsuitesparse-3.1.0 libxine1 libxine1-misc-plugins

* libxine1-plugins libxml-libxml-common-perl linux-headers-2.6.32-5-686
* madwifi-source po-debconf python-glade2 python-gtk2 python-notify
* python-numeric quanta-trinity wicd-gtk xserver-xorg-video-all
* xserver-xorg-video-cyrix xserver-xorg-video-imstt xserver-xorg-video-nsc

* xserver-xorg-video-tseng xserver-xorg-video-v4l xserver-xorg-video-vga
* xulrunner-1.9

Now, when I try to install some of the packages that got removed, apt-get does not want to reinstall the dependencies. I'm not sure how far down the rabbit hole I need to go. As an example, I tried to install wicd-gtk, whcih got uninstalled in the upgrade:


[root@rubicon apt]# apt-get install wicd-gtk
Reading package lists... Done
Building dependency tree******
Reading state information... Done
Some packages could not be installed. This may mean that you have

requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:


The following packages have unmet dependencies:
*wicd-gtk : Depends: python-gtk2 but it is not going to be installed
*********** Depends: python-glade2 but it is not going to be installed
*********** Recommends: python-notify but it is not going to be installed

E: Broken packages
[root@rubicon apt]# apt-get install wicd-gtk python-gtk2 python-glade2
Reading package lists... Done
Building dependency tree******
Reading state information... Done
Some packages could not be installed. This may mean that you have

requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:


The following packages have unmet dependencies:
*python-glade2 : Depends: python-numpy (>= 1:1.4.1) but it is not going to be installed
**************** Depends: python-numpy (< 1:1.5) but it is not going to be installed

*python-gtk2 : Depends: python-numpy (>= 1:1.4.1) but it is not going to be installed
************** Depends: python-numpy (< 1:1.5) but it is not going to be installed
E: Broken packages
[root@rubicon apt]# apt-get install wicd-gtk python-gtk2 python-glade2 python-numpy

Reading package lists... Done
Building dependency tree******
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable

distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:

*python-numpy : Depends: libblas3gf but it is not going to be installed or
************************ libblas.so.3gf or
************************ libatlas3gf-base but it is not going to be installed
*************** Depends: libgfortran3 (>= 4.3) but it is not going to be installed

*************** Depends: liblapack3gf but it is not going to be installed or
************************ liblapack.so.3gf or
************************ libatlas3gf-base but it is not going to be installed
E: Broken packages


Can someone tell me why the dependencies are not being installed and how I can fix this? I dom't necessarily want to reboot, at least until I get her wicd back.

Thanks,
--b
 
Old 04-28-2011, 05:30 PM
Sven Joachim
 
Default Need help with post-squeeze problems

On 2011-04-28 18:39 +0200, Brad Alexander wrote:

> I got my daughter's netbook upgraded to squeeze, however, there are some
> issues that I have encountered. I did it per the squeeze release notes, the
> audit, etc, then apt-get update on the new sources.lists, apt-get upgrade,
> upgraded kernel and udev, rebooted, then did the dist-upgrade. The
> dist-upgrade removed a bunch of packages:
>
> The following packages will be REMOVED:
> build-essential cervisia cupsddk-drivers debhelper dh-make g++ g++-4.3 gcc
> gcc-4.3 gettext gnuift gnuift-perl imagemagick intltool-debian kde-trinity
> kdemultimedia-trinity kdewebdev-trinity kernel-package kommander-trinity
> libarts1-xine-trinity libblas3gf libcvsservice0 libdatrie0 libept0
> libgfortran3 libgomp1 libgraphviz4 liblapack3gf libmagick10 librpm4.4
> libstdc++6-4.3-dev libsuitesparse-3.1.0 libxine1 libxine1-misc-plugins
> libxine1-plugins libxml-libxml-common-perl linux-headers-2.6.32-5-686
> madwifi-source po-debconf python-glade2 python-gtk2 python-notify
> python-numeric quanta-trinity wicd-gtk xserver-xorg-video-all
> xserver-xorg-video-cyrix xserver-xorg-video-imstt xserver-xorg-video-nsc
> xserver-xorg-video-tseng xserver-xorg-video-v4l xserver-xorg-video-vga
> xulrunner-1.9

This should not have happened. Are there some packages that you had put
on hold?

> Now, when I try to install some of the packages that got removed, apt-get
> does not want to reinstall the dependencies.

That's why they got removed in the first place, I suppose.

> I'm not sure how far down the
> rabbit hole I need to go.

With apt-get you can go as far as you like, it will never output any
useful diagnostics why it does not install the package you want.

> Can someone tell me why the dependencies are not being installed and how I
> can fix this? I dom't necessarily want to reboot, at least until I get her
> wicd back.


> [root@rubicon apt]# apt-get install wicd-gtk python-gtk2 python-glade2
> python-numpy
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> Some packages could not be installed. This may mean that you have
> requested an impossible situation or if you are using the unstable
> distribution that some required packages have not yet been created
> or been moved out of Incoming.
> The following information may help to resolve the situation:
>
> The following packages have unmet dependencies:
> python-numpy : Depends: libblas3gf but it is not going to be installed or
> libblas.so.3gf or
> libatlas3gf-base but it is not going to be
> installed
> Depends: libgfortran3 (>= 4.3) but it is not going to be
> installed
> Depends: liblapack3gf but it is not going to be installed or
> liblapack.so.3gf or
> libatlas3gf-base but it is not going to be
> installed
> E: Broken packages
>
> Can someone tell me why the dependencies are not being installed and how I
> can fix this? I dom't necessarily want to reboot, at least until I get her
> wicd back.

Try using aptitude instead of apt-get, first in dry-run mode as a normal
user:

$ aptitude -s -V -D -o "Aptitude:elete-Unused=false" install wicd-gtk

If the suggested solution does not suit you, press 'n' at the prompt and
see what else aptitude has to offer.

Sven


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 878vuuuvu6.fsf@turtle.gmx.de">http://lists.debian.org/878vuuuvu6.fsf@turtle.gmx.de
 
Old 04-29-2011, 02:44 PM
Brad Alexander
 
Default Need help with post-squeeze problems

I figured it out. What happened was that there were a few packages that got installed over the years, that were from testing or more likely unstable. So, for instance, one package was dependent on g++-4.4.5-8, but 4.4.5-10 was installed and this is what was gumming up things.




Now that that is resolved, I have one more question. There are a number of kde3 3.5.9 and 3.5.10 packages that are listed as rc. I have trinity installed, which is kde 3.5.12. If I dpkg -P the rc files, do I need to apt-get install --reinstall the -trinity files to make sure it doesn't wipe the needed config files or is the installer wise enough to know that there is a package that needs them? This is mainly to clean up the package listing...


--b



On Thu, Apr 28, 2011 at 1:30 PM, Sven Joachim <svenjoac@gmx.de> wrote:



On 2011-04-28 18:39 +0200, Brad Alexander wrote:



> I got my daughter's netbook upgraded to squeeze, however, there are some

> issues that I have encountered. I did it per the squeeze release notes, the

> audit, etc, then apt-get update on the new sources.lists, apt-get upgrade,

> upgraded kernel and udev, rebooted, then did the dist-upgrade. The

> dist-upgrade removed a bunch of packages:

>

> The following packages will be REMOVED:

> * build-essential cervisia cupsddk-drivers debhelper dh-make g++ g++-4.3 gcc

> * gcc-4.3 gettext gnuift gnuift-perl imagemagick intltool-debian kde-trinity

> * kdemultimedia-trinity kdewebdev-trinity kernel-package kommander-trinity

> * libarts1-xine-trinity libblas3gf libcvsservice0 libdatrie0 libept0

> * libgfortran3 libgomp1 libgraphviz4 liblapack3gf libmagick10 librpm4.4

> * libstdc++6-4.3-dev libsuitesparse-3.1.0 libxine1 libxine1-misc-plugins

> * libxine1-plugins libxml-libxml-common-perl linux-headers-2.6.32-5-686

> * madwifi-source po-debconf python-glade2 python-gtk2 python-notify

> * python-numeric quanta-trinity wicd-gtk xserver-xorg-video-all

> * xserver-xorg-video-cyrix xserver-xorg-video-imstt xserver-xorg-video-nsc

> * xserver-xorg-video-tseng xserver-xorg-video-v4l xserver-xorg-video-vga

> * xulrunner-1.9



This should not have happened. *Are there some packages that you had put

on hold?



> Now, when I try to install some of the packages that got removed, apt-get

> does not want to reinstall the dependencies.



That's why they got removed in the first place, I suppose.



> I'm not sure how far down the

> rabbit hole I need to go.



With apt-get you can go as far as you like, it will never output any

useful diagnostics why it does not install the package you want.



> Can someone tell me why the dependencies are not being installed and how I

> can fix this? I dom't necessarily want to reboot, at least until I get her

> wicd back.





> [root@rubicon apt]# apt-get install wicd-gtk python-gtk2 python-glade2

> python-numpy

> Reading package lists... Done

> Building dependency tree

> Reading state information... Done

> Some packages could not be installed. This may mean that you have

> requested an impossible situation or if you are using the unstable

> distribution that some required packages have not yet been created

> or been moved out of Incoming.

> The following information may help to resolve the situation:

>

> The following packages have unmet dependencies:

> *python-numpy : Depends: libblas3gf but it is not going to be installed or

> * * * * * * * * * * * * *libblas.so.3gf or

> * * * * * * * * * * * * *libatlas3gf-base but it is not going to be

> installed

> * * * * * * * * Depends: libgfortran3 (>= 4.3) but it is not going to be

> installed

> * * * * * * * * Depends: liblapack3gf but it is not going to be installed or

> * * * * * * * * * * * * *liblapack.so.3gf or

> * * * * * * * * * * * * *libatlas3gf-base but it is not going to be

> installed

> E: Broken packages

>

> Can someone tell me why the dependencies are not being installed and how I

> can fix this? I dom't necessarily want to reboot, at least until I get her

> wicd back.



Try using aptitude instead of apt-get, first in dry-run mode as a normal

user:



$ aptitude -s -V -D -o "Aptitude:elete-Unused=false" install wicd-gtk



If the suggested solution does not suit you, press 'n' at the prompt and

see what else aptitude has to offer.



Sven





--

To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org

with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Archive: http://lists.debian.org/878vuuuvu6.fsf@turtle.gmx.de
 

Thread Tools




All times are GMT. The time now is 06:43 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org