FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian User

 
 
LinkBack Thread Tools
 
Old 04-28-2011, 02:42 PM
lina
 
Default specific kernel configuration for graphic card driver

Hi,

what's the specification for the

01:00.0 VGA compatible controller [0300]: ATI Technologies Inc NI
Whistler [AMD Radeon HD 6600M Series] [1002:6741]

Thanks ahead for any suggestion.

--
Best Regards,

lina


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: BANLkTi=rg5tNpykhhgFdbCg+uwozMbA64w@mail.gmail.com ">http://lists.debian.org/BANLkTi=rg5tNpykhhgFdbCg+uwozMbA64w@mail.gmail.com
 
Old 04-28-2011, 06:05 PM
Camaleón
 
Default specific kernel configuration for graphic card driver

On Thu, 28 Apr 2011 22:42:02 +0800, lina wrote:

> what's the specification for the
>
> 01:00.0 VGA compatible controller [0300]: ATI Technologies Inc NI
> Whistler [AMD Radeon HD 6600M Series] [1002:6741]

Lina,

What's the specific problem you are facing with that card?

If it's not working at all or loads a generic driver (fbdev/vesa) instead
the radeon one, maybe is becasue the chipset is too new that still lacks
for support even in the Xorg upstream project.

The more data you can provide about your problem, the better for people
here can help you :-)

Greetings,

--
Camaleón


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: pan.2011.04.28.18.05.41@gmail.com">http://lists.debian.org/pan.2011.04.28.18.05.41@gmail.com
 
Old 04-29-2011, 08:23 AM
Panayiotis Karabassis
 
Default specific kernel configuration for graphic card driver

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On 04/28/2011 09:05 PM, Camaleón wrote:
> On Thu, 28 Apr 2011 22:42:02 +0800, lina wrote:
>
>> what's the specification for the
>>
>> 01:00.0 VGA compatible controller [0300]: ATI Technologies Inc NI
>> Whistler [AMD Radeon HD 6600M Series] [1002:6741]
>
> Lina,
>
> What's the specific problem you are facing with that card?
>
> If it's not working at all or loads a generic driver (fbdev/vesa) instead
> the radeon one, maybe is becasue the chipset is too new that still lacks
> for support even in the Xorg upstream project.
>
> The more data you can provide about your problem, the better for people
> here can help you :-)
>
> Greetings,
>

What do you mean by kernel specification? I'm no expert, but I doubt you
have to build a custom kernel.

If you don't have a problem with non-free software, have you tried the
fglrx driver?

$ sudo aptitude install module-assistant
$ sudo m-a a-i fglrx

You will prompted to install some required package (kernel headers etc.)
and if all goes well - it should - the fglrx kernel module will be
installed.

Now all you have to do is configure Xorg to use it.

$ sudo Xorg -configure
$ sudo vim /etc/X11/xorg.conf

Section "Device"
...
Identifier "Card0"
Driver "fglrx"
...
EndSection

If the above hasn't installed it, also install the fglrx-glx package.

$ sudo aptitude install fglrx-glx

Now restart the X server.

Anyway that was just off the top of my head, you will getter better
instructions from an official source.

- --
Regards,
Panayiotis Karabassis
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iQEcBAEBAgAGBQJNunWNAAoJEN7RcJcJCZJislwIALcpE0Htz3 byOAKezxSvwtHZ
JE1D1/01JOXVKp1CsOzTebaiZnwH65fZAOOY6p8yBlnQr97ef8CcCKZo icVHx9f7
6BK3HNoQpeGygQhrB48+bUnQE+DLTjVxqVibGajClzOLIBZX/0hqeqpw6s37MkV1
CJPc1nI18+zsyNbH7tXlqZZO1w7poqRCualm+4TGW8RhqgxJ/Cu6QsqSrPyw1P6k
i2dNoWGOSdUdGNduvCz9EoUajQgCHD+8Gg0zxFBO0DO2crCn5P FbopSRhjGLHVmF
M6C+hX6OU7H40I8vt9uLOyM+JXIvPeppJCXDhkKDSM1CdD1rb9 mwxWrVYvKtIzg=
=QEiX
-----END PGP SIGNATURE-----


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 4DBA758E.4050005@gmail.com">http://lists.debian.org/4DBA758E.4050005@gmail.com
 
Old 04-29-2011, 08:29 AM
Panayiotis Karabassis
 
Default specific kernel configuration for graphic card driver

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On 04/29/2011 11:23 AM, Panayiotis Karabassis wrote:
> Anyway that was just off the top of my head, you will getter better
> instructions from an official source.

Which is...

http://wiki.debian.org/ATIProprietary

- --
Regards,
Panayiotis Karabassis
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iQEcBAEBAgAGBQJNunbRAAoJEN7RcJcJCZJisigH/i7CdqEyk9X4Jip/1CvcPBN5
o9F3yoakvQ9cT+1n+Wjb33dSwBUWR+9cKgbEbc1mUVzCgTA0xT axP+klgWbefx8B
d+cXfWC5J+tBdCDx2zNEWP0IHLbw5VCnjMj4C6PPRMmLEydwVp jfRfeQYkQVSbLO
Dr62/jk74LqgTtuhId/WmGGG4nTmfjNQsSuEpHVVjW7dDgQwUtl7pfyWKpz9gF6x
OjWPdIzJdmWg6QmzYVjV8kRCN+Hp4BN7HfXM36Kn1RclSzd40y Qep+VMLi8wIXnl
O31SgwWltQt9cmtX9g/FOSi7aNRmYSSEZXkdxZL7LYOHwFeTlWzC0tedEErpiHA=
=oHRo
-----END PGP SIGNATURE-----


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 4DBA76D1.5@gmail.com">http://lists.debian.org/4DBA76D1.5@gmail.com
 
Old 05-01-2011, 06:22 AM
lina
 
Default specific kernel configuration for graphic card driver

Thanks for providing me the links and information.

Part 1:

last time I tried that one (install from squeeze one), it popped some
errors like:


$ more /usr/share/ati/fglrx-install.log

Creating symlink /var/lib/dkms/fglrx/8.831.2/source ->
/usr/src/fglrx-8.831.2

DKMS: add Completed.

Kernel preparation unnecessary for this kernel. Skipping...

Building module:
cleaning build area....
cd /var/lib/dkms/fglrx/8.831.2/build; sh make.sh --nohints
--uname_r=2.6.38-mbp8
2-nhg --norootcheck.....(bad exit status: 1)
0
0
[Error] Kernel Module : Failed to build fglrx-8.831.2 with DKMS
[Error] Kernel Module : Removing fglrx-8.831.2 from DKMS

------------------------------
Deleting module version: 8.831.2
completely from the DKMS tree.
------------------------------
Done.


Part 2:

Later my collage told me to build the sid one. I downloaded, but met
the dependency problems.

the org-video-abi-8

which needed update the xserver-xorg-core. But I met the conflict of
updating the xserver-xorg-core sepearately, it would remove lots of
other packages. so I just gave up.

Part 3:

Is it possible to update xserver-xorg-core from stable one to unstable
one? without something I worry that I can't handle.


Thanks and best regards,

lina


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: BANLkTinyux2sBXYGEOTKrrFi9eJ7AeGBiQ@mail.gmail.com ">http://lists.debian.org/BANLkTinyux2sBXYGEOTKrrFi9eJ7AeGBiQ@mail.gmail.com
 
Old 05-01-2011, 07:28 AM
Panayiotis Karabassis
 
Default specific kernel configuration for graphic card driver

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On 05/01/2011 09:22 AM, lina wrote:
> Thanks for providing me the links and information.

You are welcome!

> Part 1:
>
> last time I tried that one (install from squeeze one), it popped some
> errors like:
>
>
> $ more /usr/share/ati/fglrx-install.log
>
> Creating symlink /var/lib/dkms/fglrx/8.831.2/source ->
> /usr/src/fglrx-8.831.2
>
> DKMS: add Completed.
>
> Kernel preparation unnecessary for this kernel. Skipping...
>
> Building module:
> cleaning build area....
> cd /var/lib/dkms/fglrx/8.831.2/build; sh make.sh --nohints
> --uname_r=2.6.38-mbp8
> 2-nhg --norootcheck.....(bad exit status: 1)
> 0
> 0
> [Error] Kernel Module : Failed to build fglrx-8.831.2 with DKMS
> [Error] Kernel Module : Removing fglrx-8.831.2 from DKMS
>
> ------------------------------
> Deleting module version: 8.831.2
> completely from the DKMS tree.
> ------------------------------
> Done.

We could research this further. But it's probably not worth it, because,
if your card is new, it will require a recent driver, which is not
available in Squeeze.

> Part 2:
>
> Later my collage told me to build the sid one. I downloaded, but met
> the dependency problems.
>
> the org-video-abi-8
>
> which needed update the xserver-xorg-core. But I met the conflict of
> updating the xserver-xorg-core sepearately, it would remove lots of
> other packages. so I just gave up.
>
> Part 3:
>
> Is it possible to update xserver-xorg-core from stable one to unstable
> one? without something I worry that I can't handle.

Have you tried the driver in Wheezy (testing)? It may have more relaxed
dependencies and still be up to date. But it probably won't.

So let's do this. Try to compile the fglrx package from sid on squeeze.

$ apt-get source ${fglrx-package-name}
$ cd ${fglrx-package-name}

Now edit debian/control and remove build and non-build dependencies as
necessary. Remove or relax the version strings, so it will build and run
on squeeze.

Now you will need the devscripts package and the build-dependencies of
the fglrx package. Install these manually or try (may not work):

$ sudo apt-get build-dep ${fglrx-package-name}
$ sudo aptitude install devscripts

Now run debuild from the sources' dir. You may want to run dch to update
the revision. You may also need to install some other packages: apt-file
is your friend. There will be errors towards the end, regarding missing
gpg keys, but ignore these.

A package will be built outside the sources' dir and you can go from there.

> Thanks and best regards,
>
> lina

You are welcome, but it may be worth waiting for someone more
knowledgeable than I to reply.

- --
Best Regards,
Panayiotis Karabassis
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iQEcBAEBAgAGBQJNvQuHAAoJEN7RcJcJCZJiGoUH/jDtTPXOx+LlXOlliOl8DBxw
mNZco6g6zwYoCpv591N1REFvnfB2WYYwiRKUNjj5VYqNj0kSRb MO8UGTNmRXigqx
e7MDHllznxxx9M2CdVUDiX2KlZpU75O1GDDfiUQVPpVQDFJGpZ O1tL58j82SrKyx
T92LpOjLjXW4qmcpVr2cY6dn2JjOHqkzk5s9JDB5s0ok1OEDVR dSNHvpa2k/pL0y
lE6Uu1IYYi3C0GGlwFnKkTxxd2mSvMVjkQfGstjrG2GbQjq/uCusa49GOBVVnGOd
JP7JnR/7w/sRiB0i3rKikVlHqUxFp5s03iMyInxHvACeHY0Dkr0P5OpykbY4 dp0=
=fDVa
-----END PGP SIGNATURE-----


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 4DBD0B8B.4090002@gmail.com">http://lists.debian.org/4DBD0B8B.4090002@gmail.com
 
Old 05-01-2011, 10:07 AM
lina
 
Default specific kernel configuration for graphic card driver

# aptitude install devscripts
The following NEW packages will be installed:
dctrl-tools{a} devscripts dput{a} equivs{a} libapt-pkg-perl{a}
libauthen-sasl-perl{a} libclass-accessor-perl{a}
libclass-inspector-perl{a} libcommon-sense-perl{a}
libconvert-binhex-perl{a} libcrypt-ssleay-perl{a}
libdevel-symdump-perl{a} libfcgi-perl{a} libhtml-template-perl{a}
libio-pty-perl{a} libio-string-perl{a} libio-stringy-perl{a}
libipc-run-perl{a} libjson-perl{a} libjson-xs-perl{a}
libmime-tools-perl{a} libossp-uuid-perl{a} libossp-uuid16{a}
libparse-debcontrol-perl{a} libparse-debianchangelog-perl{a}
libpod-coverage-perl{a} libsoap-lite-perl{a} libsub-name-perl{a}
libtask-weaken-perl{a} libterm-size-perl{a} libtest-pod-perl{a}
libtie-ixhash-perl{a} libxml-namespacesupport-perl{a}
libxml-sax-expat-perl{a} libxml-sax-perl{a} libxml-simple-perl{a}
libyaml-syck-perl{a} lintian{a} lzma{a} strace{a} wdiff{a}
The following packages will be REMOVED:
libaa1-dev{u} libartsc0-dev{u} libasound2-dev{u} libaudio-dev{u}
libaudiofile-dev{u} libavahi-client-dev{u} libavahi-common-dev{u}
libcaca-dev{u} libdbus-1-dev{u} libdirectfb-dev{u} libdirectfb-extra{u}
libesd0-dev{u} libglib2.0-dev{u} libjpeg62-dev{u} libldap2-dev{u}
libodbcinstq1c2{u} libopal-doc{u} libopal3.6.8{u} libpt-dev{u}
libpt2.6.7{u} libpulse-browse0{u} libpulse-dev{u} libsasl2-dev{u}
libsdl1.2-dev{u} libspeex-dev{u} libspeexdsp-dev{u} libspeexdsp1{u}
libsrtp0{u} libsrtp0-dev{u} libsvga1-dev{u} libsysfs-dev{u}
unixodbc-dev{u}
0 packages upgraded, 41 newly installed, 32 to remove and 0 not upgraded.
Need to get 3,746 kB of archives. After unpacking 124 MB will be freed.
Do you want to continue? [Y/n/?]



On Sun, May 1, 2011 at 3:28 PM, Panayiotis Karabassis <panayk@gmail.com> wrote:
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
>
> On 05/01/2011 09:22 AM, lina wrote:
>> Thanks for providing me the links and information.
>
> You are welcome!
>
>> Part 1:
>>
>> last time I tried that one (install from squeeze one), it popped some
>> errors like:
>>
>>
>> $ more /usr/share/ati/fglrx-install.log
>>
>> Creating symlink /var/lib/dkms/fglrx/8.831.2/source ->
>> * * * * * * * * */usr/src/fglrx-8.831.2
>>
>> DKMS: add Completed.
>>
>> Kernel preparation unnecessary for this kernel. *Skipping...
>>
>> Building module:
>> cleaning build area....
>> cd /var/lib/dkms/fglrx/8.831.2/build; sh make.sh --nohints
>> --uname_r=2.6.38-mbp8
>> 2-nhg --norootcheck.....(bad exit status: 1)
>> 0
>> 0
>> [Error] Kernel Module : Failed to build fglrx-8.831.2 with DKMS
>> [Error] Kernel Module : Removing fglrx-8.831.2 from DKMS
>>
>> ------------------------------
>> Deleting module version: 8.831.2
>> completely from the DKMS tree.
>> ------------------------------
>> Done.
>
> We could research this further. But it's probably not worth it, because,
> if your card is new, it will require a recent driver, which is not
> available in Squeeze.
>
>> Part 2:
>>
>> Later my collage told me to build the sid one. I downloaded, but met
>> the dependency problems.
>>
>> *the org-video-abi-8
>>
>> which needed update the xserver-xorg-core. But I met the conflict of
>> updating the xserver-xorg-core sepearately, it would remove lots of
>> other packages. so I just gave up.
>>
>> Part 3:
>>
>> Is it possible to update xserver-xorg-core from stable one to unstable
>> one? without something I worry that I can't handle.
>
> Have you tried the driver in Wheezy (testing)? It may have more relaxed
> dependencies and still be up to date. But it probably won't.
>
> So let's do this. Try to compile the fglrx package from sid on squeeze.
>
> $ apt-get source ${fglrx-package-name}
> $ cd ${fglrx-package-name}
>
> Now edit debian/control and remove build and non-build dependencies as
> necessary. Remove or relax the version strings, so it will build and run
> on squeeze.
>
> Now *you will need the devscripts package and the build-dependencies of
> the fglrx package. Install these manually or try (may not work):
>
> $ sudo apt-get build-dep ${fglrx-package-name}
> $ sudo aptitude install devscripts
>
> Now run debuild from the sources' dir. You may want to run dch to update
> the revision. You may also need to install some other packages: apt-file
> is your friend. There will be errors towards the end, regarding missing
> gpg keys, but ignore these.
>
> A package will be built outside the sources' dir and you can go from there.
>
>> Thanks and best regards,
>>
>> lina
>
> You are welcome, but it may be worth waiting for someone more
> knowledgeable than I to reply.
>
> - --
> Best Regards,
> * *Panayiotis Karabassis
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.11 (GNU/Linux)
> Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/
>
> iQEcBAEBAgAGBQJNvQuHAAoJEN7RcJcJCZJiGoUH/jDtTPXOx+LlXOlliOl8DBxw
> mNZco6g6zwYoCpv591N1REFvnfB2WYYwiRKUNjj5VYqNj0kSRb MO8UGTNmRXigqx
> e7MDHllznxxx9M2CdVUDiX2KlZpU75O1GDDfiUQVPpVQDFJGpZ O1tL58j82SrKyx
> T92LpOjLjXW4qmcpVr2cY6dn2JjOHqkzk5s9JDB5s0ok1OEDVR dSNHvpa2k/pL0y
> lE6Uu1IYYi3C0GGlwFnKkTxxd2mSvMVjkQfGstjrG2GbQjq/uCusa49GOBVVnGOd
> JP7JnR/7w/sRiB0i3rKikVlHqUxFp5s03iMyInxHvACeHY0Dkr0P5OpykbY4 dp0=
> =fDVa
> -----END PGP SIGNATURE-----
>



--
Best Regards,

lina


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: BANLkTi=duJs6cf=nD8jRfLX2tA9bjRfMEQ@mail.gmail.com ">http://lists.debian.org/BANLkTi=duJs6cf=nD8jRfLX2tA9bjRfMEQ@mail.gmail.com
 
Old 05-01-2011, 11:52 AM
lina
 
Default specific kernel configuration for graphic card driver

fglrx-driver depends on xserver-xorg (>= 1:7.6+1)
fglrx-driver depends on xorg-video-abi-8
xorg-video-abi-8 does not appear to be available

for the wheezy version fglrx, it's also had the dependency problems.

Thanks and best regards,

lina


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: BANLkTi=JKoyzY75MqykGzK_cb-tGP3Dz-w@mail.gmail.com">http://lists.debian.org/BANLkTi=JKoyzY75MqykGzK_cb-tGP3Dz-w@mail.gmail.com
 
Old 05-02-2011, 06:26 AM
Panayiotis Karabassis
 
Default specific kernel configuration for graphic card driver

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On 05/01/2011 01:07 PM, lina wrote:
> # aptitude install devscripts
> The following NEW packages will be installed:
> dctrl-tools{a} devscripts dput{a} equivs{a} libapt-pkg-perl{a}
> libauthen-sasl-perl{a} libclass-accessor-perl{a}
> libclass-inspector-perl{a} libcommon-sense-perl{a}
> libconvert-binhex-perl{a} libcrypt-ssleay-perl{a}
> libdevel-symdump-perl{a} libfcgi-perl{a} libhtml-template-perl{a}
> libio-pty-perl{a} libio-string-perl{a} libio-stringy-perl{a}
> libipc-run-perl{a} libjson-perl{a} libjson-xs-perl{a}
> libmime-tools-perl{a} libossp-uuid-perl{a} libossp-uuid16{a}
> libparse-debcontrol-perl{a} libparse-debianchangelog-perl{a}
> libpod-coverage-perl{a} libsoap-lite-perl{a} libsub-name-perl{a}
> libtask-weaken-perl{a} libterm-size-perl{a} libtest-pod-perl{a}
> libtie-ixhash-perl{a} libxml-namespacesupport-perl{a}
> libxml-sax-expat-perl{a} libxml-sax-perl{a} libxml-simple-perl{a}
> libyaml-syck-perl{a} lintian{a} lzma{a} strace{a} wdiff{a}
> The following packages will be REMOVED:
> libaa1-dev{u} libartsc0-dev{u} libasound2-dev{u} libaudio-dev{u}
> libaudiofile-dev{u} libavahi-client-dev{u} libavahi-common-dev{u}
> libcaca-dev{u} libdbus-1-dev{u} libdirectfb-dev{u} libdirectfb-extra{u}
> libesd0-dev{u} libglib2.0-dev{u} libjpeg62-dev{u} libldap2-dev{u}
> libodbcinstq1c2{u} libopal-doc{u} libopal3.6.8{u} libpt-dev{u}
> libpt2.6.7{u} libpulse-browse0{u} libpulse-dev{u} libsasl2-dev{u}
> libsdl1.2-dev{u} libspeex-dev{u} libspeexdsp-dev{u} libspeexdsp1{u}
> libsrtp0{u} libsrtp0-dev{u} libsvga1-dev{u} libsysfs-dev{u}
> unixodbc-dev{u}
> 0 packages upgraded, 41 newly installed, 32 to remove and 0 not upgraded.
> Need to get 3,746 kB of archives. After unpacking 124 MB will be freed.
> Do you want to continue? [Y/n/?]

Probably you have been using apt-get?
Try:
$ sudo apt-get devscripts

- --
Regards,
Panayiotis Karabassis
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iQEcBAEBAgAGBQJNvk6rAAoJEN7RcJcJCZJigY0H/3abar5Rkdh07Yw7jbIBmqwR
e6nsPDeBfk8s18Iq4xx6TWk9dE1mqiii8PmuhguS6nMaZu1etq kTpVbM8ONzSYUz
XVCJkWKBA1ENaAa++NZqEgFeBh+h1mUn3cOyiMG1gf6/S7fpS5WNPS9ta1nvwl1X
PanxsXezFLMQoZaiCNY0CjFlPjdDovtmQZ9MqQdapj/N1AXRFgl+NtcIfjt7Wc+r
riuL9WKL84bsGKMoeaTDiWcmumC48ECj7EcGw3C7GhU/sUHlThzauTx6xTehGH7s
8IWkUFaoqfoJ8HAMZgsOZh1vjXYcX5bj9PIE9CLsiLAHo9nE70 B1jnr6sQJQKPs=
=dMzr
-----END PGP SIGNATURE-----


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 4DBE4EB0.8040408@gmail.com">http://lists.debian.org/4DBE4EB0.8040408@gmail.com
 
Old 05-02-2011, 06:51 AM
Panayiotis Karabassis
 
Default specific kernel configuration for graphic card driver

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On 05/01/2011 02:52 PM, lina wrote:
> fglrx-driver depends on xserver-xorg (>= 1:7.6+1)
> fglrx-driver depends on xorg-video-abi-8
> xorg-video-abi-8 does not appear to be available

Is this from aptitude? Don't install the binary package, just the
*source* (apt-get source). Then modify the dependencies, to create a
package that will build and run on Squeeze. We're betting on the
possibility that these are not really *required* dependencies and that
an older version of the xserver will do as well.

Also have you thought about upgrading to Wheezy? It's a well documented
process, but there pros (newer software) and cons (instability, bugs -
but not too many).

It is also possible to upgrade just the xserver. There are two steps.
a) Add wheezy to /etc/apt/sources.list
b) Add as many packages from wheezy as are required to
/etc/apt/preferences and forbid the rest (in the same file). See:

$ man apt_preferences

> Thanks and best regards,
>
> lina

- --
Regards,
Panayiotis Karabassis
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iQEcBAEBAgAGBQJNvlRdAAoJEN7RcJcJCZJiv7cIAJYiZ+JPlw 2jde9Wa3Df7hVc
fPM/9cqySLuuypXBEYNbqhiUq+Lragu/uHbXLSaWmKhLyQ4XJ6Y7LGGmM7Hcs/PT
5VvzNnsgluw2rIZguoEB05cXQMpogjyvpZ6XsrtSkzzqUMl1WR gAcCLNTSObHkzb
bvV7NSNbRb49WYr1dmBwUNhLUTcxhOzVDRVm6Yh89GazTbJoyJ i7YQaD64JE32PE
3NCXbAhIZaNh8jvlewaUQaoRaO6EcLL/MsvgXdvcZExtZYnvYK9XBHjWySa4ZLND
1yOjUAAnXH3ss8u5/elwSbbIYxp9U7JmyKf57DX/YONCwHc905S/duYfmff+M80=
=vUNX
-----END PGP SIGNATURE-----


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 4DBE5461.5020806@gmail.com">http://lists.debian.org/4DBE5461.5020806@gmail.com
 

Thread Tools




All times are GMT. The time now is 12:11 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org