Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Debian User (http://www.linux-archive.org/debian-user/)
-   -   Can I get some help with this? (Cleaning bad dependencies with APT) (http://www.linux-archive.org/debian-user/509657-can-i-get-some-help-cleaning-bad-dependencies-apt.html)

Ken Ingram 04-04-2011 09:54 AM

Can I get some help with this? (Cleaning bad dependencies with APT)
 
apollo:/var/cache/apt/archives# apt-get -f autoremoveReading package lists... Done

Building dependency tree * * *Reading state information... Done

Correcting dependencies... DoneThe following packages were automatically installed and are no longer required:

*libcamel1.2-8 libwxgtk2.4-1 libexchange-storage1.2-1 libmono-peapi2.0-cil libccid libgnorbagtk0 libedata-cal1.2-5 libgtkxmhtml1 libgpod0

*libmono-microsoft-build2.0-cil ksync libegroupwise1.2-10 oaf poster mp3info libebook1.2-5 libedataserverui1.2-6 libiw28 libxklavier10 libtotem-plparser1

*libzvt2 liboaf0 libpisync0The following extra packages will be installed:

*kdepim-devThe following packages will be REMOVED:

*ksync libcamel1.2-8 libccid libebook1.2-5 libedata-cal1.2-5 libedataserverui1.2-6 libegroupwise1.2-10 libexchange-storage1.2-1 libgnorbagtk0 libgpod0

*libgtkxmhtml1 libiw28 libmono-microsoft-build2.0-cil libmono-peapi2.0-cil liboaf0 libpisync0 libtotem-plparser1 libwxgtk2.4-1 libxklavier10 libzvt2

*mp3info oaf posterThe following packages will be upgraded:

*kdepim-dev1 upgraded, 0 newly installed, 23 to remove and 2186 not upgraded.

31 not fully installed or removed.Need to get 83.0kB of archives.

After this operation, 11.2MB disk space will be freed.Do you want to continue [Y/n]? Y

Get:1 http://mirrors.kernel.org lenny/main kdepim-dev 4:3.5.9-5 [83.0kB]Fetched 83.0kB in 0s (175kB/s)

Reading package fields... DoneReading package status... Done

Retrieving bug reports... 0% W: Connection refused - connect(2)Error retrieving bug reports

Retry downloading bug information?[Y/n]? yW: Connection refused - connect(2)

Error retrieving bug reportsRetry downloading bug information?[Y/n]? n

Abort the installation[Y/n]? nRetrieving bug reports... Done

Parsing Found/Fixed information... DoneReading changelogs... Done

(Reading database ... 659787 files and directories currently installed.)Preparing to replace kdepim-dev 4:3.5.5.dfsg.1-6 (using .../kdepim-dev_4%3a3.5.9-5_i386.deb) ...

Unpacking replacement kdepim-dev ...dpkg: error processing /var/cache/apt/archives/kdepim-dev_4%3a3.5.9-5_i386.deb (--unpack):

trying to overwrite `/usr/lib/libkode.la', which is also in package kodeErrors were encountered while processing:

/var/cache/apt/archives/kdepim-dev_4%3a3.5.9-5_i386.debE: Sub-process /usr/bin/dpkg returned an error code (1)

apollo:/var/cache/apt/archives# apt-get install netselectReading package lists... Done

Building dependency tree * * *Reading state information... Done

You might want to run `apt-get -f install' to correct these:The following packages have unmet dependencies:

*kdepim-dev: Depends: kaddressbook (= 4:3.5.5.dfsg.1-6) but 4:3.5.9-5 is to be installed* * * * * * *Depends: kalarm (= 4:3.5.5.dfsg.1-6) but 4:3.5.9-5 is to be installed

* * * * * * *Depends: kdepim-kresources (= 4:3.5.5.dfsg.1-6) but 4:3.5.9-5 is to be installed* * * * * * *Depends: kitchensync (= 4:3.5.5.dfsg.1-6) but 4:3.5.9-5 is to be installed

* * * * * * *Depends: kmail (= 4:3.5.5.dfsg.1-6) but 4:3.5.9-5 is to be installed* * * * * * *Depends: knotes (= 4:3.5.5.dfsg.1-6) but 4:3.5.9-5 is to be installed

* * * * * * *Depends: kontact (= 4:3.5.5.dfsg.1-6) but 4:3.5.9-5 is to be installed* * * * * * *Depends: korganizer (= 4:3.5.5.dfsg.1-6) but 4:3.5.9-5 is to be installed

* * * * * * *Depends: kpilot (= 4:3.5.5.dfsg.1-6) but 4:3.5.9-5 is to be installed* * * * * * *Depends: libkpimidentities1 (= 4:3.5.5.dfsg.1-6) but 4:3.5.9-5 is to be installed

* * * * * * *Depends: libkcal2-dev (= 4:3.5.5.dfsg.1-6) but 4:3.5.9-5 is to be installed* * * * * * *Depends: libkdepim1-dev (= 4:3.5.5.dfsg.1-6) but 4:3.5.9-5 is to be installed

* * * * * * *Depends: libkgantt0-dev (= 4:3.5.5.dfsg.1-6) but 4:3.5.9-5 is to be installed* * * * * * *Depends: libkleopatra1-dev (= 4:3.5.5.dfsg.1-6) but 4:3.5.9-5 is to be installed

* * * * * * *Depends: libkpimexchange1-dev (= 4:3.5.5.dfsg.1-6) but 4:3.5.9-5 is to be installed* * * * * * *Depends: libksieve0-dev (= 4:3.5.5.dfsg.1-6) but 4:3.5.9-5 is to be installed

* * * * * * *Depends: libktnef1-dev (= 4:3.5.5.dfsg.1-6) but 4:3.5.9-5 is to be installed* * * * * * *Depends: libmimelib1-dev (= 4:3.5.5.dfsg.1-6) but 4:3.5.9-5 is to be installed

E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).


So I tried that recommendation:


apollo:/var/cache/apt/archives# apt-get -f installReading package lists... Done

Building dependency tree * * *Reading state information... Done

Correcting dependencies... DoneThe following packages were automatically installed and are no longer required:

*libcamel1.2-8 libwxgtk2.4-1 libexchange-storage1.2-1 libmono-peapi2.0-cil libccid libgnorbagtk0 libedata-cal1.2-5 libgtkxmhtml1 libgpod0

*libmono-microsoft-build2.0-cil ksync libegroupwise1.2-10 oaf poster mp3info libebook1.2-5 libedataserverui1.2-6 libiw28 libxklavier10 libtotem-plparser1

*libzvt2 liboaf0 libpisync0Use 'apt-get autoremove' to remove them.

The following extra packages will be installed:*kdepim-dev

The following packages will be upgraded:*kdepim-dev

1 upgraded, 0 newly installed, 0 to remove and 2194 not upgraded.31 not fully installed or removed.

Need to get 0B/83.0kB of archives.After this operation, 139kB disk space will be freed.

Do you want to continue [Y/n]? yReading package fields... Done

Reading package status... DoneRetrieving bug reports... 0% W: Connection refused - connect(2)

Error retrieving bug reportsRetry downloading bug information?[Y/n]? n

Abort the installation[Y/n]? nRetrieving bug reports... Done

Parsing Found/Fixed information... DoneReading changelogs... Done

(Reading database ... 659787 files and directories currently installed.)Preparing to replace kdepim-dev 4:3.5.5.dfsg.1-6 (using .../kdepim-dev_4%3a3.5.9-5_i386.deb) ...

Unpacking replacement kdepim-dev ...dpkg: error processing /var/cache/apt/archives/kdepim-dev_4%3a3.5.9-5_i386.deb (--unpack):

trying to overwrite `/usr/lib/libkode.la', which is also in package kodeErrors were encountered while processing:

/var/cache/apt/archives/kdepim-dev_4%3a3.5.9-5_i386.debE: Sub-process /usr/bin/dpkg returned an error code (1)

apollo:/var/cache/apt/archives#

Chris Bannister 04-05-2011 03:10 AM

Can I get some help with this? (Cleaning bad dependencies with APT)
 
On Mon, Apr 04, 2011 at 02:54:44AM -0700, Ken Ingram wrote:

Why are you doing:

> apollo:/var/cache/apt/archives# apt-get -f autoremove

when you have this:

> 1 upgraded, 0 newly installed, 23 to remove and 2186 not upgraded.

> 31 not fully installed or removed.
> Need to get 83.0kB of archives.
> After this operation, 11.2MB disk space will be freed.
> Do you want to continue [Y/n]? Y

:(

> You might want to run `apt-get -f install' to correct these:
> The following packages have unmet dependencies:
> kdepim-dev: Depends: kaddressbook (= 4:3.5.5.dfsg.1-6) but 4:3.5.9-5 is to

What happens if you purge kdepim-dev, then try apt-get -f install?
Don't press y!

what is output of:

apt-cache policy kdepim-dev
apt-cache policy kode
cat /etc/apt/sources.lst
ls -al /etc/apt/
ls -al /etc/apt/*d/

--
"Religion is excellent stuff for keeping common people quiet."
-- Napoleon Bonaparte


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20110405031022.GD19011@fischer">http://lists.debian.org/20110405031022.GD19011@fischer

Ken Ingram 04-05-2011 07:46 PM

Can I get some help with this? (Cleaning bad dependencies with APT)
 
1. I ran the autoremove since that was suggested after I ran "apt-get -f install".
It would appear that it is a never-ending loop of poor suggestions to resolving the problem.

2. I'm from RedHat and rpm so I'm still trying to get a grip on apt while having a workable system.


*** I'd like to get familiar with Debian and possibly switch, but I won't until I know I can keep the
*** system running while learning how to administer it.
3. Thanks for taking a look. REally I just want to set up subversion and make sure my cold backup


*** will work anywhere. I'd hate to lose 4 years and 5Gb of version control.


Output:

apollo:/var/www/fss# apt-cache policy kdepim-dev
kdepim-dev:
* Installed: 4:3.5.5.dfsg.1-6
* Candidate: 4:3.5.9-5


* Version table:
**** 4:3.5.9-5 0
******* 500 http://mirrors.kernel.org lenny/main Packages
**** 4:3.5.5.dfsg.1-6 0
******* 100 /var/lib/dpkg/status

apollo:/var/www/fss# apt-cache policy kode


kode:
* Installed: 4:3.5.5.dfsg.1-6
* Candidate: 4:3.5.9-5
* Version table:
**** 4:3.5.9-5 0
******* 500 http://mirrors.kernel.org lenny/main Packages
**** 4:3.5.5.dfsg.1-6 0


******* 100 /var/lib/dpkg/status

apollo:/var/www/fss# cat /etc/apt/sources.lst
cat: /etc/apt/sources.lst: No such file or directory
apollo:/var/www/fss# ls -al /etc/apt/
total 76
drwxr-xr-x** 5 root root* 4096 2010-07-29 14:17 .


drwxr-xr-x 291 root root 20480 2011-04-03 15:06 ..
-rw-r--r--** 1 root root** 158 2008-09-17 00:13 apt-build.conf
drwxr-xr-x** 2 root root* 4096 2010-07-29 17:34 apt.conf.d
-rw-r--r--** 1 root root* 2524 2006-11-14 06:43 apt-file.conf


drwxr-xr-x** 2 root root* 4096 2008-09-16 23:09 listbugs
-rw-r--r--** 1 root root*** 99 2008-09-16 23:09 listchanges.conf
-rw-------** 1 root root**** 0 2008-09-16 07:08 secring.gpg
-rw-r--r--** 1 root root** 601 2010-07-29 13:08 sources.list


-rw-r--r--** 1 root root**** 0 2008-09-16 07:08 sources.list~
-rw-r--r--** 1 root root** 541 2010-07-29 13:03 sources.list.backup
drwxr-xr-x** 2 root root* 4096 2007-02-26 13:21 sources.list.d
-rw-------** 1 root root* 1200 2010-07-29 13:11 trustdb.gpg


-rw-------** 1 root root* 6473 2010-07-29 13:11 trusted.gpg
-rw-------** 1 root root* 6473 2010-07-29 13:11 trusted.gpg~
apollo:/var/www/fss# ls -al /etc/apt/*d/
/etc/apt/apt.conf.d/:
total 36
drwxr-xr-x 2 root root 4096 2010-07-29 17:34 .


drwxr-xr-x 5 root root 4096 2010-07-29 14:17 ..
-rw-r--r-- 1 root root** 40 2008-09-16 07:08 00trustcdrom
-rw-r--r-- 1 root root** 92 2010-05-12 13:25 01autoremove
-rw-r--r-- 1 root root* 381 2006-11-22 07:10 10apt-listbugs


-rw-r--r-- 1 root root** 91 2007-02-20 06:05 10periodic
-rw-r--r-- 1 root root* 141 2008-01-17 08:04 20listchanges
-rw-r--r-- 1 root root* 182 2008-03-13 03:32 70debconf
-rw-r--r-- 1 root root* 127 2008-09-16 23:28 90debsums



/etc/apt/sources.list.d/:
total 8
drwxr-xr-x 2 root root 4096 2007-02-26 13:21 .
drwxr-xr-x 5 root root 4096 2010-07-29 14:17 ..

"Huang, Tao" 04-07-2011 02:55 AM

Can I get some help with this? (Cleaning bad dependencies with APT)
 
On Wed, Apr 6, 2011 at 3:46 AM, Ken Ingram <ken.ingram@gmail.com> wrote:
[snip]
> apollo:/var/www/fss# cat /etc/apt/sources.lst
> cat: /etc/apt/sources.lst: No such file or directory
should be /etc/apt/sources.list

it appears to me that purging "kdepim-dev" and reinstall it afterwards
might be a solution.
and what's the output if u run "apt-get autoremove" without "-f"?

btw, i'd recommand aptitude over apt-get.


Cheers,

Tao
--
http://huangtao.me/
http://www.google.com/profiles/UniIsland

School of Mathematical Science
Peking University


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: BANLkTi=cNZ6cXiXyqsjJKM8utReD49p1DA@mail.gmail.com ">http://lists.debian.org/BANLkTi=cNZ6cXiXyqsjJKM8utReD49p1DA@mail.gmail.com


All times are GMT. The time now is 12:09 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.