FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian User

 
 
LinkBack Thread Tools
 
Old 04-02-2011, 07:22 PM
Wolfgang Karall
 
Default dpkg bug regarding dependencies?

Hello,

when trying to work around
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=620088 I downgraded
nfs-common to the version in testing, which actually worked, even though
nfs-kernel-server has a versioned dependency on nfs-common (see below),
is this a bug in dpkg or did I miss something regarding the versioned
dependency handling?

I actually only noticed since "aptitude forbid-version" did bail out
telling me that there is a dependency problem.

Cheers
Wolfgang

PS: the shell output:

x61s:~# apt-cache policy nfs-common nfs-kernel-server
nfs-common:
Installed: 1:1.2.3-1
Candidate: 1:1.2.3-1
Version table:
*** 1:1.2.3-1 0
500 http://ftp.at.debian.org/debian/ sid/main i386 Packages
100 /var/lib/dpkg/status
nfs-kernel-server:
Installed: 1:1.2.3-1
Candidate: 1:1.2.3-1
Version table:
*** 1:1.2.3-1 0
500 http://ftp.at.debian.org/debian/ sid/main i386 Packages
100 /var/lib/dpkg/status
x61s:~# apt-cache show nfs-kernel-server | grep ^Depends
Depends: libblkid1 (>= 2.16), libc6 (>= 2.3), libcomerr2 (>= 1.01),
libgssapi-krb5-2 (>= 1.6.dfsg.2), libgssglue1, libk5crypto3 (>=
1.6.dfsg.2), libkrb5-3 (>= 1.6.dfsg.2), libnfsidmap2, libtirpc1,
libwrap0 (>= 7.6-4~), nfs-common (= 1:1.2.3-1), ucf, lsb-base (>=
1.3-9ubuntu3)
x61s:~# dpkg -i nfs-common_1.2.2-5_i386.deb
dpkg: warning: downgrading nfs-common from 1:1.2.3-1 to 1:1.2.2-5.
(Reading database ... 177879 files and directories currently installed.)
Preparing to replace nfs-common 1:1.2.3-1 (using
nfs-common_1.2.2-5_i386.deb) ...
Unpacking replacement nfs-common ...
Setting up nfs-common (1:1.2.2-5) ...
Installing new version of config file /etc/init.d/nfs-common ...
Stopping NFS common utilities: statd.
Starting NFS common utilities: statd.
Processing triggers for man-db ...
x61s:~#


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20110402192217.GA3761@lenny.spiney.org">http://lists.debian.org/20110402192217.GA3761@lenny.spiney.org
 
Old 04-02-2011, 07:40 PM
Sven Joachim
 
Default dpkg bug regarding dependencies?

On 2011-04-02 21:22 +0200, Wolfgang Karall wrote:

> Hello,
>
> when trying to work around
> http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=620088 I downgraded
> nfs-common to the version in testing, which actually worked, even though
> nfs-kernel-server has a versioned dependency on nfs-common (see below),
> is this a bug in dpkg or did I miss something regarding the versioned
> dependency handling?

This seems to be bug #20471¹.

Sven


¹ http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=20471


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 87fwq0zbkh.fsf@turtle.gmx.de">http://lists.debian.org/87fwq0zbkh.fsf@turtle.gmx.de
 
Old 04-02-2011, 08:23 PM
System User
 
Default dpkg bug regarding dependencies?

On Sat, Apr 02, 2011 at 09:40:30PM +0200, Sven Joachim wrote:
> > is this a bug in dpkg or did I miss something regarding the versioned
> > dependency handling?
>
> This seems to be bug #20471?.

Ah, thanks for pointing this out, haven't noticed it with
reportbug/bugs.d.o.

I actually wonder why this is "not serious" as Raphaėl Herzog says at
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=481823#10 (after all
the state of the packages stays in this unresolved-dependencies state
until the next APT/dpkg activity) but OTOH I can understand it's low
priority.

Regards
Wolfgang


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20110402202344.GA6009@lenny.spiney.org">http://lists.debian.org/20110402202344.GA6009@lenny.spiney.org
 

Thread Tools




All times are GMT. The time now is 12:27 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org