FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian User

 
 
LinkBack Thread Tools
 
Old 04-02-2011, 05:26 PM
Tapio Lehtonen
 
Default How come dist-upgrade needed in lenny?

Lenny can not install bind9 update in the usual upgrade way, because
this upgrade needs two package removals and two new packages to be
installed. I think this should be mentioned in the security note of this
bind9 upgrade or otherwise inform users so they do not waste time
figuring out what is happening and how to get the upgrade installed.


toppari:/usr/share/doc/approx# LANG=C date
Sat Apr 2 20:18:45 EEST 2011

toppari:/usr/share/doc/approx# LANG=C apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done

The following packages have been kept back:
bind9 bind9-host bind9utils dnsutils libbind9-50 libisccc50 libisccfg50
liblwres50 lwresd
0 upgraded, 0 newly installed, 0 to remove and 9 not upgraded.

toppari:/usr/share/doc/approx# LANG=C apt-get dist-upgrade --simulate
Reading package lists... Done
Building dependency tree
Reading state information... Done

Calculating upgrade... Done
The following packages will be REMOVED:
libdns55 libisc52
The following NEW packages will be installed:
libdns58 libisc50
The following packages will be upgraded:
bind9 bind9-host bind9utils dnsutils libbind9-50 libisccc50 libisccfg50
liblwres50 lwresd
9 upgraded, 2 newly installed, 2 to remove and 0 not upgraded.
Inst lwresd [1:9.6.ESV.R1+dfsg-0+lenny2] (1:9.6.ESV.R3+dfsg-0+lenny1
Debian:5.0.8/oldstable, Debian-Security:5.0/stable) []

..... rest cut away

--
Tapio Lehtonen
pj. Linux-Aktivaattori http://l-a.fi


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Archive: 4D975C40.6020004@dnainternet.net">http://lists.debian.org/4D975C40.6020004@dnainternet.net
 
Old 04-02-2011, 08:56 PM
Liam O'Toole
 
Default How come dist-upgrade needed in lenny?

On 2011-04-02, Tapio Lehtonen <tapio.lehtonen@dnainternet.net> wrote:
> Lenny can not install bind9 update in the usual upgrade way, because
> this upgrade needs two package removals and two new packages to be
> installed. I think this should be mentioned in the security note of this
> bind9 upgrade or otherwise inform users so they do not waste time
> figuring out what is happening and how to get the upgrade installed.

I've seen such warnings in the past, on the rare occasions when security
updates required a full-upgrade or dist-upgrade.

--
Liam O'Toole
Cork, Ireland


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: slrnipf3ci.3io.liam.p.otoole@dipsy.tubbynet">http://lists.debian.org/slrnipf3ci.3io.liam.p.otoole@dipsy.tubbynet
 
Old 04-03-2011, 01:51 PM
Camaleón
 
Default How come dist-upgrade needed in lenny?

On Sat, 02 Apr 2011 20:56:51 +0000, Liam O'Toole wrote:

> On 2011-04-02, Tapio Lehtonen <tapio.lehtonen@dnainternet.net> wrote:
>> Lenny can not install bind9 update in the usual upgrade way, because
>> this upgrade needs two package removals and two new packages to be
>> installed. I think this should be mentioned in the security note of
>> this bind9 upgrade or otherwise inform users so they do not waste time
>> figuring out what is happening and how to get the upgrade installed.
>
> I've seen such warnings in the past, on the rare occasions when security
> updates required a full-upgrade or dist-upgrade.

Me too.

And the required commands to perform the update are usually noted on the
same e-mail received from debian-security-announce mailing list.

Greetings,

--
Camaleón


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: pan.2011.04.03.13.51.09@gmail.com">http://lists.debian.org/pan.2011.04.03.13.51.09@gmail.com
 

Thread Tools




All times are GMT. The time now is 07:58 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org