FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian User

 
 
LinkBack Thread Tools
 
Old 03-06-2011, 07:23 AM
Tom H
 
Default Revert to lenny's grub

On Sat, Mar 5, 2011 at 2:41 AM, George <pinkisntwell@gmail.com> wrote:
>
> Something unfortunate happened: I removed grub-pc and installed
> grub-legacy, but my computer still boots using grub 1.97! It seems to
> work fine now, but I don't like the fact that grub and grub-pc show up
> as "not installed" in aptitude, grub-legacy shows up as "installed",
> but my computer is booting with 1.97. What's going on here? Is it
> possible that grub 1.97 was installed in the MBR?

Use
http://sourceforge.net/projects/bootinfoscript/
to try to find out what's going.

You can paste the result on
http://pastebin.com/


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: AANLkTimok0x1ExYRJyNox2rF62yJ9y2VQ9gW-GZteD21@mail.gmail.com">http://lists.debian.org/AANLkTimok0x1ExYRJyNox2rF62yJ9y2VQ9gW-GZteD21@mail.gmail.com
 
Old 03-07-2011, 10:57 AM
George
 
Default Revert to lenny's grub

On 3/6/11, Tom H <tomh0665@gmail.com> wrote:
> On Sat, Mar 5, 2011 at 2:41 AM, George <pinkisntwell@gmail.com> wrote:
>>
>> Something unfortunate happened: I removed grub-pc and installed
>> grub-legacy, but my computer still boots using grub 1.97! It seems to
>> work fine now, but I don't like the fact that grub and grub-pc show up
>> as "not installed" in aptitude, grub-legacy shows up as "installed",
>> but my computer is booting with 1.97. What's going on here? Is it
>> possible that grub 1.97 was installed in the MBR?
>
> Use
> http://sourceforge.net/projects/bootinfoscript/
> to try to find out what's going.
>
I wasn't able to run the script because my system was missing some programs.

However, I investigated further and saw that the package grub-common
was still installed. It had version number 1.9x, so in a fit of
near-frustration I uninstalled grub-legacy and installed grub-pc
again, and now my system appears to be working perfectly.


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: AANLkTim=8=hb_t_vOX8PAEPCS=m3J2d1+z1raK=UiUZ7@mail .gmail.com">http://lists.debian.org/AANLkTim=8=hb_t_vOX8PAEPCS=m3J2d1+z1raK=UiUZ7@mail .gmail.com
 

Thread Tools




All times are GMT. The time now is 10:43 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org