FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian User

 
 
LinkBack Thread Tools
 
Old 11-24-2010, 03:27 PM
jeremy jozwik
 
Default cinelerra is a makin me crazy

hello folks, im tired of kicking my debian laptops butt everyday by
non-stop rendering in cinelerra.
im attempting to install on my debian lenny 32bit workstation and
getting annoying errors with libquicktime and libmjpegtools0.

using [1] as my guide i have most dependants in place. the only left are

libmjpegtools0
libopenexr2ldbl
libquicktimehv

if i install mjpeg then quicktime, lame0 will remove mjpeg. and if i
install quicktime then mjpeg, mjpeg will remove quicktime.

delbian:/home/po# apt-get install liblame0
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
libswscale0 libavutil49 libmpeg3hv libpostproc51 mesa-common-dev
libx264-60 libschroedinger-1.0-0 libdirac0 libgl1-mesa-dev libimlib2
Use 'apt-get autoremove' to remove them.
The following packages will be REMOVED:
libavcodec51 libmjpegtools0 libmp3lame0 libquicktime1 mjpegtools
The following NEW packages will be installed:
liblame0
0 upgraded, 1 newly installed, 5 to remove and 13 not upgraded.
Need to get 0B/186kB of archives.
After this operation, 10.9MB disk space will be freed.
Do you want to continue [Y/n]? y
(Reading database ... 91287 files and directories currently installed.)
Removing mjpegtools ...
Removing libmjpegtools0 ...
Removing libquicktime1 ...
Removing libavcodec51 ...
Removing libmp3lame0 ...
Processing triggers for man-db ...
Selecting previously deselected package liblame0.
(Reading database ... 91142 files and directories currently installed.)
Unpacking liblame0 (from .../liblame0_3.97-0.0_i386.deb) ...
Setting up liblame0 (3.97-0.0) ...

delbian:/home/po# apt-get install libquicktimehv
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
libswscale0 libavutil49 libpostproc51 mesa-common-dev libx264-60
libschroedinger-1.0-0 libdirac0 libgl1-mesa-dev libimlib2
Use 'apt-get autoremove' to remove them.
The following NEW packages will be installed:
libquicktimehv
0 upgraded, 1 newly installed, 0 to remove and 13 not upgraded.
Need to get 0B/4482kB of archives.
After this operation, 12.1MB of additional disk space will be used.
WARNING: The following packages cannot be authenticated!
libquicktimehv
Install these packages without verification [y/N]? y
Selecting previously deselected package libquicktimehv.
(Reading database ... 91147 files and directories currently installed.)
Unpacking libquicktimehv (from
.../libquicktimehv_1%3a2.1.0-2svn20071030_i386.deb) ...
Setting up libquicktimehv (1:2.1.0-2svn20071030) ...

delbian:/home/po# apt-get install cinelerra
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
cinelerra: Depends: libmjpegtools0 (>= 1:1.8.0) but it is not going
to be installed
Depends: libopenexr2ldbl (>= 1.2.2) but it is not installable

ok, so i thought "nuts to this, ill just build it"
and i get quicktime build errors.

interlacemodes.c:26:33: error: mjpegtools/yuv4mpeg.h: No such file or directory
interlacemodes.c: In function 'ilace_bc_to_yuv4mpeg':
interlacemodes.c:163: error: 'Y4M_UNKNOWN' undeclared (first use in
this function)
interlacemodes.c:163: error: (Each undeclared identifier is reported only once
interlacemodes.c:163: error: for each function it appears in.)
interlacemodes.c:166: error: 'Y4M_ILACE_TOP_FIRST' undeclared (first
use in this function)
interlacemodes.c:169: error: 'Y4M_ILACE_BOTTOM_FIRST' undeclared
(first use in this function)
interlacemodes.c:172: error: 'Y4M_ILACE_NONE' undeclared (first use in
this function)
interlacemodes.c: In function 'ilace_yuv4mpeg_to_bc':
interlacemodes.c:181: error: 'Y4M_UNKNOWN' undeclared (first use in
this function)
interlacemodes.c:184: error: 'Y4M_ILACE_NONE' undeclared (first use in
this function)
interlacemodes.c:187: error: 'Y4M_ILACE_TOP_FIRST' undeclared (first
use in this function)
interlacemodes.c:190: error: 'Y4M_ILACE_BOTTOM_FIRST' undeclared
(first use in this function)
interlacemodes.c: In function 'ilace_yuv4mpeg_mode_to_text':
interlacemodes.c:206: error: 'Y4M_UNKNOWN' undeclared (first use in
this function)
interlacemodes.c:207: error: 'Y4M_ILACE_NONE' undeclared (first use in
this function)
interlacemodes.c:208: error: 'Y4M_ILACE_TOP_FIRST' undeclared (first
use in this function)
interlacemodes.c:209: error: 'Y4M_ILACE_BOTTOM_FIRST' undeclared
(first use in this function)
make[2]: *** [interlacemodes.lo] Error 1
make[2]: Leaving directory `/home/po/packages/cinelerra/my_cinelerra/quicktime'
make[1]: *** [install-recursive] Error 1
make[1]: Leaving directory `/home/po/packages/cinelerra/my_cinelerra/quicktime'
make: *** [install-recursive] Error 1

can anyone send out a guiding light, ive been at this on and off for a
few months now and would like a working cinelerra 32 bit at some
point.

[1] http://www.assistcg.com/component/content/article/66.html


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: AANLkTi=decz+O0w3QHbS4syqB0FuZyhQU6chaCXux7nt@mail .gmail.com">http://lists.debian.org/AANLkTi=decz+O0w3QHbS4syqB0FuZyhQU6chaCXux7nt@mail .gmail.com
 
Old 11-24-2010, 04:05 PM
"tv.debian@googlemail.com"
 
Default cinelerra is a makin me crazy

24/11/2010 17:27, jeremy jozwik wrote:
> hello folks, im tired of kicking my debian laptops butt everyday by
> non-stop rendering in cinelerra.
> im attempting to install on my debian lenny 32bit workstation and
> getting annoying errors with libquicktime and libmjpegtools0.
>
> using [1] as my guide i have most dependants in place. the only left are
>
> libmjpegtools0
> libopenexr2ldbl
> libquicktimehv
>
> if i install mjpeg then quicktime, lame0 will remove mjpeg. and if i
> install quicktime then mjpeg, mjpeg will remove quicktime.
>

Hi, Cinelerra is available from debian-multimedia repository :

http://www.debian-multimedia.org

If you install it from debian-multimedia a better place to discuss about
it would be dmo-discussion@debian-multimedia.org since debian-multimedia
isn't an official component of Debian.

Anyhow, Cinelerra (un)stability is known to drive people crazy...


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 4CED45E7.3040805@googlemail.com">http://lists.debian.org/4CED45E7.3040805@googlemail.com
 

Thread Tools




All times are GMT. The time now is 02:15 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org