FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian User

 
 
LinkBack Thread Tools
 
Old 11-14-2010, 08:10 PM
b1
 
Default fontconfig / defoma segfault

Hello altogether

Today I ran into some strange problem. While reinstalling munin, I got a
segfault, while fontconfig was getting installed. I played around a
little bit, and think I located the root of the problem at defoma. For
example if I run:

apt-get install fontconfig

I get:

E: Unable to load: /var/lib/defoma/scripts/fontconfig.defoma
because:
/var/lib/defoma/scripts/fontconfig.defoma did not return a true
value at (eval 4) line 1.

Updating font configuration of fontconfig...
E: fontconfig was excluded from configuration due to the error
in the header.
E: Please perform the following things.
E: (1) run defoma-app purge fontconfig.
E: (2) upgrade fontconfig and/or defoma.
E: (3) run defoma-app update fontconfig.
/var/lib/dpkg/info/fontconfig.postinst: line 25: 2580
Speicherzugriffsfehler /usr/bin/defoma-app update fontconfig
dpkg: Fehler beim Bearbeiten von fontconfig (--configure):
Unterprozess post-installation script gab den Fehlerwert 139
zurück
Fehler traten auf beim Bearbeiten von:
fontconfig
E: Sub-process /usr/bin/dpkg returned an error code (1)

I get a similar errror while trying to install psfontmgr, which also
depends on defoma:

apt-get install psfontmgr

Richte psfontmgr ein (0.11.10-0.2) ...
/var/lib/dpkg/info/psfontmgr.postinst: line 12: 2684
Speicherzugriffsfehler /usr/bin/defoma-app -t update psfontmgr
1>&2
dpkg: Fehler beim Bearbeiten von psfontmgr (--configure):
Unterprozess post-installation script gab den Fehlerwert 139
zurück
Fehler traten auf beim Bearbeiten von:
psfontmgr
E: Sub-process /usr/bin/dpkg returned an error code (1)

I already tried purging defoma and reinstalling it again. No luck. The
only Idea I still have is trying to install defoma from the backports,
however, I don't like the idea of having to many packages installed
fromt the backports. Besides, it obviously works after a fresh install.

So I would really appreciate your advice on how to erase this issue.

Thanks in advance


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 1289769044.3460.10.camel@localhost.localdomain">ht tp://lists.debian.org/1289769044.3460.10.camel@localhost.localdomain
 
Old 11-15-2010, 07:33 PM
b1
 
Default fontconfig / defoma segfault

I solved the problemm by noticing that the scripts
in /var/lib/defoma/scripts were all empty. Strang as it is, these
scripts don't get regenerated on reinstalling. I copied them from an old
backup.



--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 1289853193.3404.34.camel@localhost.localdomain">ht tp://lists.debian.org/1289853193.3404.34.camel@localhost.localdomain
 

Thread Tools




All times are GMT. The time now is 07:16 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org