Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Debian User (http://www.linux-archive.org/debian-user/)
-   -   Where has my Windows partition gone? (http://www.linux-archive.org/debian-user/452190-where-has-my-windows-partition-gone.html)

John O Laoi 11-13-2010 09:33 PM

Where has my Windows partition gone?
 
Hello,
I have a dual boot laptop running squeeze.

I update regularly.

I rarely use the Windows partition – I have not used it for several months.

However, it now appears to be gone, according to grub.
At least, when I boot up, and get the blue screen with the list of
options, the Windows one is not there.
Instead I get a list of kernels

But “fdisk -l” says it is still there.

Device Boot Start End Blocks Id System

/dev/sda1 1 11 88326 de Dell Utility

/dev/sda2 * 12 2622 20972857+ 7 HPFS/NTFS

/dev/sda3 2623 5233 20972857+ 7 HPFS/NTFS

/dev/sda4 5234 12161 55649160 5 Extended

/dev/sda5 5234 7191 15727603+ 83 Linux

/dev/sda6 7192 7452 2096451 82 Linux swap / Solaris

/dev/sda7 7453 12161 37825011 83 Linux



Any ideas?

John


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: AANLkTin_Uf1H_nMUuqpwyK8my0d2pWk-F681MQA7pWL0@mail.gmail.com">http://lists.debian.org/AANLkTin_Uf1H_nMUuqpwyK8my0d2pWk-F681MQA7pWL0@mail.gmail.com

Thierry Chatelet 11-13-2010 09:51 PM

Where has my Windows partition gone?
 
On Saturday 13 November 2010 23:33:25 John O Laoi wrote:
> Hello,

> Any ideas?
>
> John

Try: update-grub

Thierry


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 201011132351.54504.tchatelet@free.fr">http://lists.debian.org/201011132351.54504.tchatelet@free.fr

Thierry Chatelet 11-13-2010 09:57 PM

Where has my Windows partition gone?
 
On Saturday 13 November 2010 23:51:54 Thierry Chatelet wrote:
> On Saturday 13 November 2010 23:33:25 John O Laoi wrote:
> > Hello,
> >
> > Any ideas?
> >
> > John
>
> Try: update-grub
as root!
Thierry


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 201011132357.19833.tchatelet@free.fr">http://lists.debian.org/201011132357.19833.tchatelet@free.fr

John O Laoi 11-13-2010 10:11 PM

Where has my Windows partition gone?
 
>> Try: update-grub
> as root!

Thank you.
Unfortunately, this did not do the trick:

# update-grub
Generating grub.cfg ...
Found background image: moreblue-orbit-grub.png
Found linux image: /boot/vmlinuz-2.6.32-5-686
Found initrd image: /boot/initrd.img-2.6.32-5-686
Found linux image: /boot/vmlinuz-2.6.32-3-686
Found initrd image: /boot/initrd.img-2.6.32-3-686
Found linux image: /boot/vmlinuz-2.6.32-trunk-686
Found initrd image: /boot/initrd.img-2.6.32-trunk-686
Found linux image: /boot/vmlinuz-2.6.30-2-686
Found initrd image: /boot/initrd.img-2.6.30-2-686
Found linux image: /boot/vmlinuz-2.6.30-1-686
Found initrd image: /boot/initrd.img-2.6.30-1-686
Found linux image: /boot/vmlinuz-2.6.26-2-686
Found initrd image: /boot/initrd.img-2.6.26-2-686
done

Any other ideas


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: AANLkTikw_O080bboL=17V39QpYHyqvkOV3gL3nhxMZzs@mail .gmail.com">http://lists.debian.org/AANLkTikw_O080bboL=17V39QpYHyqvkOV3gL3nhxMZzs@mail .gmail.com

Davide Mancusi 11-13-2010 10:18 PM

Where has my Windows partition gone?
 
On Sat, 13 Nov 2010 22:33:25 +0000
John O Laoi <brianolaoi@gmail.com> wrote:

> Hello,
> I have a dual boot laptop running squeeze.
>
> I update regularly.
>
> I rarely use the Windows partition – I have not used it for several
> months.
>
> However, it now appears to be gone, according to grub.
> At least, when I boot up, and get the blue screen with the list of
> options, the Windows one is not there.
> Instead I get a list of kernels
>
> But “fdisk -l” says it is still there.
>
> Device Boot Start End Blocks Id System
>
> /dev/sda1 1 11 88326 de Dell Utility
>
> /dev/sda2 * 12 2622 20972857+ 7 HPFS/NTFS
>
> /dev/sda3 2623 5233 20972857+ 7 HPFS/NTFS
>
> /dev/sda4 5234 12161 55649160 5 Extended
>
> /dev/sda5 5234 7191 15727603+ 83 Linux
>
> /dev/sda6 7192 7452 2096451 82 Linux swap /
> Solaris
>
> /dev/sda7 7453 12161 37825011 83 Linux
>
>
>
> Any ideas?
>
> John

Do you have os-prober installed?

Cheers,
Davide

--
Time flies like an arrow. Fruit flies like a banana.
--
If anything can go wrong it wSegmentation fault
core dumped


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20101114001848.7ee2e6a9@macco.homelinux.com">http://lists.debian.org/20101114001848.7ee2e6a9@macco.homelinux.com


All times are GMT. The time now is 12:16 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.