FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian User

 
 
LinkBack Thread Tools
 
Old 10-12-2010, 12:43 PM
Arif Ali
 
Default Bad archive mirror using customised preseed and mirror

I have created multiple preseeds to install nodes using preseed and
ubuntu, and have worked without any problems, but with lenny I am
having a few issues. I hope someone on this list can help

Here are my steps

1. Copy CD 1 into a directory, which is available via httpd
2. Set-up PXE/tftp so that it picks up the netboot initrd/vmlinuz fom
the server, and uses the following preseed file

http://pastebin.com/py6TKqr6

I have enabled DEBIAN_FRONTEND=text, so that I can see the text a lot
easier in a remote console, and the error I am getting is

Checking the Debian archive mirror ..25%..50%..100%
!! ERROR: Bad archive mirror

I have checked that I can get to the URL myself, and checked logs on
the server as well, But I can't seem to find the root of the problem.

Like I said, I used the same process for the ubuntu CDs, and the
preseed worked without any problem. Some advice on this would be
appreciated

regards,


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: AANLkTinZcy+N4n6iV8dPKShvv8Nmqd8us1yy11KiCb91@mail .gmail.com">http://lists.debian.org/AANLkTinZcy+N4n6iV8dPKShvv8Nmqd8us1yy11KiCb91@mail .gmail.com
 
Old 10-14-2010, 05:27 PM
Arif Ali
 
Default Bad archive mirror using customised preseed and mirror

On 12 October 2010 13:43, Arif Ali <debian@arif-ali.co.uk> wrote:
> I have created multiple preseeds to install nodes using preseed and
> ubuntu, and have worked without any problems, but with lenny I am
> having a few issues. I hope someone on this list can help
>
> Here are my steps
>
> 1. Copy CD 1 into a directory, which is available via httpd
> 2. Set-up PXE/tftp so that it picks up the netboot initrd/vmlinuz fom
> the server, and uses the following preseed file
>
> http://pastebin.com/py6TKqr6
>
> I have enabled DEBIAN_FRONTEND=text, so that I can see the text a lot
> easier in a remote console, and the error I am getting is
>
> Checking the Debian archive mirror *..25%..50%..100%
> !! ERROR: Bad archive mirror
>
> I have checked that I can get to the URL myself, and checked logs on
> the server as well, But I can't seem to find the root of the problem.
>
> Like I said, I used the same process for the ubuntu CDs, and the
> preseed worked without any problem. Some advice on this would be
> appreciated
>
> regards,
>

Hi All,

Any ideas on this, I have tried a few howtos that I found via google
in making a DVD/CD into a repository and preseeding, but still unable
to fix the problem.

Is there anyway at all to debug exactly what the machine is doing, and
what it is expecting. I would be really grateful if someone could
point me in a solvable direction.

thanks in advance

regards,
Arif


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: AANLkTimUA1EYNwMyXmU6DjumAO5ifCRKPt_EVcNgTjkG@mail .gmail.com">http://lists.debian.org/AANLkTimUA1EYNwMyXmU6DjumAO5ifCRKPt_EVcNgTjkG@mail .gmail.com
 
Old 10-15-2010, 05:25 PM
Arif Ali
 
Default Bad archive mirror using customised preseed and mirror

On 14 October 2010 18:27, Arif Ali <debian@arif-ali.co.uk> wrote:
> On 12 October 2010 13:43, Arif Ali <debian@arif-ali.co.uk> wrote:
>> I have created multiple preseeds to install nodes using preseed and
>> ubuntu, and have worked without any problems, but with lenny I am
>> having a few issues. I hope someone on this list can help
>>
>> Here are my steps
>>
>> 1. Copy CD 1 into a directory, which is available via httpd
>> 2. Set-up PXE/tftp so that it picks up the netboot initrd/vmlinuz fom
>> the server, and uses the following preseed file
>>
>> http://pastebin.com/py6TKqr6
>>
>> I have enabled DEBIAN_FRONTEND=text, so that I can see the text a lot
>> easier in a remote console, and the error I am getting is
>>
>> Checking the Debian archive mirror Â*..25%..50%..100%
>> !! ERROR: Bad archive mirror
>>
>> I have checked that I can get to the URL myself, and checked logs on
>> the server as well, But I can't seem to find the root of the problem.
>>
>> Like I said, I used the same process for the ubuntu CDs, and the
>> preseed worked without any problem. Some advice on this would be
>> appreciated
>>
>> regards,
>>
>
> Hi All,
>
> Any ideas on this, I have tried a few howtos that I found via google
> in making a DVD/CD into a repository and preseeding, but still unable
> to fix the problem.
>
> Is there anyway at all to debug exactly what the machine is doing, and
> what it is expecting. I would be really grateful if someone could
> point me in a solvable direction.
>
> thanks in advance
>
> regards,
> Arif
>

This specific problem has now been solved. In order to fix this is to
remove the links of unstable and testing in the dists folder. Once
that is done, the mirror is picked up


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: http://lists.debian.org/AANLkTi�jaHHT=ZgBzjQM3ZQK_yG_rr09dkYNURLxP@mail. gmail.com
 

Thread Tools




All times are GMT. The time now is 04:06 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org