Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Debian User (http://www.linux-archive.org/debian-user/)
-   -   Please explain X strangeness (http://www.linux-archive.org/debian-user/434399-please-explain-x-strangeness.html)

Mark Neidorff 10-01-2010 06:56 PM

Please explain X strangeness
 
Hi all,

Debian Lenny system patched up using nvidia driver. I have a KVM switch
because I am setting up a new machine. Normal behavior is that X starts just
fine if the Debian box has KVM "focus" as it boots. If it doesn't have
"focus" (I see the video from the other computer on the screen) the I get an
"out of range" error on the screen. A quick ctrl-alt-backspace restarts the
X server and everything is fine. Recently, I've gotten a 3rd PC to setup.
Since my monitor has multiple video inputs, I hooked the 3rd PC to video2 on
the monitor. Yesterday, I unhooked the 3rd PC from the monitor (but left the
cable hooked to the monitor with an unattached end). Today when I tried to
start X, even when I see the output of the debian box on the monitor, I got
an "out of range" error. Tapping ctrl-alt-backspace restarts X, but does not
allow X to start. Here is the part I would like an explanation for....I
pulled the video cable (that is attached to nothing) off of the connector on
the monitor, tapped ctrl-alt-backspace, and X started just fine. Why does
the presence of a disconnected cable give X a problem?

Thanks for any insight.

Mark


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 201010011456.04750.mark@neidorff.com">http://lists.debian.org/201010011456.04750.mark@neidorff.com

Camaleón 10-02-2010 12:06 PM

Please explain X strangeness
 
On Fri, 01 Oct 2010 14:56:04 -0400, Mark Neidorff wrote:

(...)
> Yesterday, I unhooked the 3rd PC
> from the monitor (but left the cable hooked to the monitor with an
> unattached end). Today when I tried to start X, even when I see the
> output of the debian box on the monitor, I got an "out of range" error.
> Tapping ctrl-alt-backspace restarts X, but does not allow X to start.
> Here is the part I would like an explanation for....I pulled the video
> cable (that is attached to nothing) off of the connector on the monitor,
> tapped ctrl-alt-backspace, and X started just fine. Why does the
> presence of a disconnected cable give X a problem?

In brief, you are experiencing weirdnesses with a headless system and
your xorg/vga drivers/monitor, right?

I would start by reviwing the Xorg log file (/var/log/Xorg.0.log) to get
any clue. You can upload its whole content (it does not contain sensitive
data) to any online service such www.pastebin.com.

Greetings,

--
Camaleón


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: pan.2010.10.02.12.06.38@gmail.com">http://lists.debian.org/pan.2010.10.02.12.06.38@gmail.com


All times are GMT. The time now is 06:41 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.