FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian User

 
 
LinkBack Thread Tools
 
Old 09-27-2010, 02:22 PM
Mike Viau
 
Default nvidia-kernel-2.6-amd64 vs nvidia-kernel-dkms method

Hello,

I was just wondering what the advantages of using the nvidia-kernel-2.6 packages were in contrast to what I am/have been using which is the nvidia-glx package which depends on nvidia-kernel-dkms to compile the NVIDIA driver module (with the kernel headers) into /lib/modules/${kernel_version}/updates/dkms/nvidia.ko

Has the nouveau code been stripped from the nvidia-kernel-2.6 packages so that it only used the NVIDIA driver module?

Thanks.


-M




--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: BAY148-w53D03A384BFFDF4675B8AAEF650@phx.gbl">http://lists.debian.org/BAY148-w53D03A384BFFDF4675B8AAEF650@phx.gbl
 
Old 09-27-2010, 05:35 PM
Camaleón
 
Default nvidia-kernel-2.6-amd64 vs nvidia-kernel-dkms method

On Mon, 27 Sep 2010 10:22:18 -0400, Mike Viau wrote:

> I was just wondering what the advantages of using the nvidia-kernel-2.6
> packages were in contrast to what I am/have been using which is the
> nvidia-glx package which depends on nvidia-kernel-dkms to compile the
> NVIDIA driver module (with the kernel headers) into
> /lib/modules/${kernel_version}/updates/dkms/nvidia.ko

I think (but maybe wrongly) that "nvidia-kernel-dkms" kernel will allow
you you build/install a new kernel despite there is a matching in header
files, whereas "nvidia-kernel" needs an exact kernel headers
correspondence.

> Has the nouveau code been stripped from the nvidia-kernel-2.6 packages
> so that it only used the NVIDIA driver module?

I also think that "nuvó" driver follows a different path (it uses another
driver set) :-?

Greetings,

--
Camaleón


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: pan.2010.09.27.17.35.18@gmail.com">http://lists.debian.org/pan.2010.09.27.17.35.18@gmail.com
 
Old 09-28-2010, 04:45 AM
Mark Allums
 
Default nvidia-kernel-2.6-amd64 vs nvidia-kernel-dkms method

Has the nouveau code been stripped from the nvidia-kernel-2.6 packages
so that it only used the NVIDIA driver module?


They were still in staging, last I looked. That means that you have to
enable staging drivers in the kernel source configuration and compile a
custom kernel. This may not be the case for very recent kernels, such
as 2.6.35/36, but I haven't checked lately.



--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Archive: 4CA172CD.10204@allums.com">http://lists.debian.org/4CA172CD.10204@allums.com
 
Old 09-28-2010, 01:58 PM
Mike Viau
 
Default nvidia-kernel-2.6-amd64 vs nvidia-kernel-dkms method

> On Mon, 27 Sep 2010 23:45:01 -0500 <mark@allums.com> wrote:
>
>>> Has the nouveau code been stripped from the nvidia-kernel-2.6 packages
>>> so that it only used the NVIDIA driver module?
>
> They were still in staging, last I looked. That means that you have to
> enable staging drivers in the kernel source configuration and compile a
> custom kernel. This may not be the case for very recent kernels, such
> as 2.6.35/36, but I haven't checked lately.
>

I believe this is correct judging by:

24.3.2010 posted by xavier

Merge of 2.6.34-rc2.

On Monday, nouveau git tree went straight from 2.6.32 to 2.6.34-rc2. One backlight API change
in 2.6.34-rc2 breaks compatibility with older kernels (<
2.6.34-rc2), so people doing out-of-tree builds will have to update
their kernel to rc2. Alternatively, you could try to revert the backlight commit.

[1] http://nouveau.freedesktop.org/wiki/


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: BAY148-w13737ED231A132F9F4E4B7EF660@phx.gbl">http://lists.debian.org/BAY148-w13737ED231A132F9F4E4B7EF660@phx.gbl
 

Thread Tools




All times are GMT. The time now is 08:41 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org