FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian User

 
 
LinkBack Thread Tools
 
Old 09-20-2010, 09:01 AM
Erik Hjelmås
 
Default /dev/xen/evtchn disappears, HVM fails, xen 4.0.1-1 Debian Squeeze

Hi,

(this currently also being discussed on xen-users list but no solution yet)

my
server running xen 4.0.1 and Debian Squeeze (with all the xen 4.0.1
debian packages, everything installed using aptitude) was working fine
for PV and HVM guest until an aptitude upgrade last Monday, and Ive been
spending the last couple of days trying to figure this out:


- I boot my server and as long as a stick with PV guests Im fine, if
I try to start a HVM guest, the HVM guest will not boot and
/dev/xen/evtchn disappears, and any PV guest I start now will just take
off with 100% CPU



in other words:


zimbu:/home/erikh# ls -l /dev/xen/

total 0
crw------- 1 root root 10, 57 Sep 17 14:32 evtchn
crw------- 1 root root 10, 62 Sep 17 14:32 gntdev

zimbu:/home/erikh# xm create /opt/mln/projects/root/vm32/cube_xen.hvm



Using config file "/opt/mln/projects/root/vm32/cube_xen.hvm".
Error: Domain 'cube.vm32' does not exist.

zimbu:/home/erikh# ls -l /dev/xen/

total 0
crw------- 1 root root 10, 62 Sep 17 14:32 gntdev



zimbu:/home/erikh# cat /var/log/xen/qemu-dm-cube.vm32.log

domid: 5
-c config qemu network with xen bridge for
tap5.0 lan.vm32
Strip off blktap sub-type prefix to /dev/mln-images/cube.vm32 (drv 'aio')


Watching /local/domain/0/device-model/5/logdirty/cmd
Watching /local/domain/0/device-model/5/command
qemu_map_cache_init nr_buckets = 10000 size 4194304
shared page at pfn feffd
buffered io page at pfn feffb


Guest uuid = 9d1d2624-9d17-c913-9f27-ce4b705f47c7
Time offset set 0
ERROR Internal error: Could not open event channel interface (22 = Invalid argument)
open: Invalid argument
Unable to find x86 CPU definition



zimbu:/home/erikh# dpkg -l | grep xen
libxenstore3.0********************* 4.0.1-1
linux-image-2.6.32-5-xen-amd64***** 2.6.32-21
xen-hypervisor-4.0-amd64*********** 4.0.1-1
xen-linux-system-2.6.32-5-xen-amd64 2.6.32-21


xen-qemu-dm-4.0******************** 4.0.1-1
xen-tools************************** 4.2~rc1-1
xen-utils-4.0********************** 4.0.1-1
xen-utils-common******************* 4.0.0-1
xenstore-utils********************* 4.0.1-1


zimbu:/home/erikh#


any help greatly appreciated...

/Erik
 
Old 08-31-2011, 07:34 AM
Erik Hjelmås
 
Default /dev/xen/evtchn disappears, HVM fails, xen 4.0.1-1 Debian Squeeze

This problem still exists for me, I still have to downgrade to run kernel

linux-image-2.6.32-5-xen-amd64_2.6.32-18_amd64.deb (from july 2010)

for it to work.

The discussion not leading to a solution can be found here:

http://lists.xensource.com/archives/html/xen-users/2010-09/msg00488.html

In other words, most recent kernel in Debian stable does not work as a Dom0 kernel for me!


I have to go "in production" by the end of next week and it would feel much better to use a more recent Dom0 kernel

/Erik
 

Thread Tools




All times are GMT. The time now is 08:51 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org