FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian User

 
 
LinkBack Thread Tools
 
Old 07-22-2010, 02:21 PM
"Raghavendra. S"
 
Default dpkg -i libgssdp-1.0-dev_0.7.2-2_i386.deb error installing

Hi All,

** I downloaded

gssdp_0.7.2-2.diff.gz
gssdp_0.7.2-2.dsc

gssdp_0.7.2.orig.tar.gz

from http://ftp.debian.org/debian/pool/main/g/gssdp/. merged all three using dpkg-source -x gssdp_0.7.2-2.dsc command.


compiled successfully. But when i tried to install* libgssdp-1.0-dev_0.7.2-2_i386.deb, I am getting following error.

dpkg -i libgssdp-1.0-dev_0.7.2-2_i386.deb
(Reading database ... 154512 files and directories currently installed.)

Unpacking libgssdp-1.0-dev (from libgssdp-1.0-dev_0.7.2-2_i386.deb) ...
dpkg: error processing libgssdp-1.0-dev_0.7.2-2_i386.deb (--install):
*trying to overwrite '/usr/share/gir-1.0/GSSDP-1.0.gir', which is also in package gir-repository-dev 0:0.6.5-5ubuntu2

Errors were encountered while processing:
*libgssdp-1.0-dev_0.7.2-2_i386.deb


Does any body know what is the reason for this error?
--
Regards & Thanks
Raghavendra. S
9880329621
 
Old 07-22-2010, 03:38 PM
"Boyd Stephen Smith Jr."
 
Default dpkg -i libgssdp-1.0-dev_0.7.2-2_i386.deb error installing

On Thursday 22 July 2010 09:21:09 Raghavendra. S wrote:
> dpkg -i libgssdp-1.0-dev_0.7.2-2_i386.deb
> (Reading database ... 154512 files and directories currently installed.)
> Unpacking libgssdp-1.0-dev (from libgssdp-1.0-dev_0.7.2-2_i386.deb) ...
> *dpkg: error processing libgssdp-1.0-dev_0.7.2-2_i386.deb (--install):
> trying to overwrite '/usr/share/gir-1.0/GSSDP-1.0.gir', which is also in
> package gir-repository-dev 0:0.6.5-5ubuntu2*
> Errors were encountered while processing:
> libgssdp-1.0-dev_0.7.2-2_i386.deb
>
> Does any body know what is the reason for this error?

Your new package (libgssdp-1.0-dev version 0.7.2-2) wants to install a file
that is already controlled by a currently installed package (gir-repository-
dev version 0:0.6.5-5ubuntu2). The specific file is
/usr/share/gir-1.0/GSSDP-1.0.gir.

IMO, neither package should install this file. /usr/share/$foo is usually the
domain of a package named "$foo".

Finally, it appears that you are mixing repositories, which you should only do
when you know the combination is safe, due to the policies governing each
repository.

I can't make a recommendation on how to solve your issue without knowing more
about why you are installing a package from a .dsc. However, one way to fix
you issue is, prior to building the .deb, to edit debian/rules so that
/usr/share/gir-1.0/GSSDP-1.0.gir is not installed.
--
Boyd Stephen Smith Jr. ,= ,-_-. =.
bss@iguanasuicide.net ((_/)o o(\_))
ICQ: 514984 YM/AIM: DaTwinkDaddy `-'(. .)`-'
http://iguanasuicide.net/ \_/
 
Old 07-23-2010, 03:45 AM
"Raghavendra. S"
 
Default dpkg -i libgssdp-1.0-dev_0.7.2-2_i386.deb error installing

On Thu, Jul 22, 2010 at 9:08 PM, Boyd Stephen Smith Jr. <bss@iguanasuicide.net> wrote:


On Thursday 22 July 2010 09:21:09 Raghavendra. S wrote:
> dpkg -i libgssdp-1.0-dev_0.7.2-2_i386.deb
> (Reading database ... 154512 files and directories currently installed.)
> Unpacking libgssdp-1.0-dev (from libgssdp-1.0-dev_0.7.2-2_i386.deb) ...

> *dpkg: error processing libgssdp-1.0-dev_0.7.2-2_i386.deb (--install):
> *trying to overwrite '/usr/share/gir-1.0/GSSDP-1.0.gir', which is also in
> package gir-repository-dev 0:0.6.5-5ubuntu2*

> Errors were encountered while processing:
> *libgssdp-1.0-dev_0.7.2-2_i386.deb
>
> Does any body know what is the reason for this error?

Your new package (libgssdp-1.0-dev version 0.7.2-2) wants to install a file

that is already controlled by a currently installed package (gir-repository-
dev version 0:0.6.5-5ubuntu2). *The specific file is
/usr/share/gir-1.0/GSSDP-1.0.gir.

IMO, neither package should install this file. /usr/share/$foo is usually the

domain of a package named "$foo".

Finally, it appears that you are mixing repositories, which you should only do
when you know the combination is safe, due to the policies governing each
repository.


I can't make a recommendation on how to solve your issue without knowing more
about why you are installing a package from a .dsc.**
*
*
As I mentioned I had taken this code from http://ftp.debian.org/debian/pool/main/g/gssdp/. I havenot modified any thing.
*
*
However, one way to fix
you issue is, prior to building the .deb, to edit debian/rules so that
/usr/share/gir-1.0/GSSDP-1.0.gir is not installed.


*
*
I edited debian/rules file as you mentioned,*but no success. I am getting same error.
*
*
--
Boyd Stephen Smith Jr. * * * * * * * * * ,= ,-_-. =.
bss@iguanasuicide.net * * * * * * * * * ((_/)o o(\_))

ICQ: 514984 YM/AIM: DaTwinkDaddy * * * * `-'(. .)`-'
http://iguanasuicide.net/ * * * * * * * * * *\_/


*
*
*
*

--
Regards & Thanks
Raghavendra. S
9880329621
 
Old 07-23-2010, 04:16 AM
"Raghavendra. S"
 
Default dpkg -i libgssdp-1.0-dev_0.7.2-2_i386.deb error installing

Hi,


I am getting same error while installing

dpkg -i libgupnp-1.0-dev_0.13.4-1_i386.deb
(Reading database ... 154552 files and directories currently installed.)
Unpacking libgupnp-1.0-dev (from libgupnp-1.0-dev_0.13.4-1_i386.deb) ...

dpkg: error processing libgupnp-1.0-dev_0.13.4-1_i386.deb (--install):
*trying to overwrite '/usr/share/gir-1.0/GUPnP-1.0.gir', which is also in package gir-repository-dev 0:0.6.5-5ubuntu2
Processing triggers for man-db ...

Errors were encountered while processing:
*libgupnp-1.0-dev_0.13.4-1_i386.deb


-Raghu



On Fri, Jul 23, 2010 at 9:40 AM, Raghavendra. S <raghavendra.akkasali@gmail.com> wrote:

Hi,
*
** I first installed* gir-repository-dev**using apt-get install. So this is also from debian.
*
* Then I downloaded code from debian, build gssdp. and tried to install using dpkg -i command.
*
* I am getting this error only while installing gssdp deb package.
*
*
* Please let me know if you know any solution for this.
*
-Raghu


On Thu, Jul 22, 2010 at 8:55 PM, Arne Wichmann <aw@old-forest.org> wrote:

In article <f94WC-3CJ-15@gated-at.bofh.it>,

Raghavendra. S <raghavendra.akkasali@gmail.com> wrote:

>-=-=-=-=-=-
[...]
>compiled successfully. But when i tried to install
>libgssdp-1.0-dev_0.7.2-2_i386.deb, I am getting following error.
>
>dpkg -i libgssdp-1.0-dev_0.7.2-2_i386.deb
>(Reading database ... 154512 files and directories currently installed.)


>Unpacking libgssdp-1.0-dev (from libgssdp-1.0-dev_0.7.2-2_i386.deb) ...
>*dpkg: error processing libgssdp-1.0-dev_0.7.2-2_i386.deb (--install):
> trying to overwrite '/usr/share/gir-1.0/GSSDP-1.0.gir', which is also in


>package gir-repository-dev 0:0.6.5-5ubuntu2*
>Errors were encountered while processing:
> libgssdp-1.0-dev_0.7.2-2_i386.deb
>
>
>Does any body know what is the reason for this error?



It seems that your libgssdp-1.0-dev_0.7.2-2_i386.deb and the already
installed package gir-repository-dev both provide
/usr/share/gir-1.0/GSSDP-1.0.gir - that means you cannot install both on
the same system. This can happen as the two packages originate from


different distributions if I read "0:0.6.5-5ubuntu2" correctly, other
reasons are possible, too. (If both packages were directly from a debian
mirror this would be a bug.)

N.B. Could you tell me whether you get this message once or twice? I am


testing.

cu

AW
--
[...] If you don't want to be restricted, don't agree to it. If you are
coerced, comply as much as you must to protect yourself, just don't support


it. Noone can free you but yourself. (crag, on Debian Planet)
Arne Wichmann (aw@linux.de)



--
Regards & Thanks
Raghavendra. S

9880329621



--
Regards & Thanks
Raghavendra. S
9880329621
 
Old 07-23-2010, 03:41 PM
"Boyd Stephen Smith Jr."
 
Default dpkg -i libgssdp-1.0-dev_0.7.2-2_i386.deb error installing

On Thursday 22 July 2010 22:45:09 Raghavendra. S wrote:
> On Thu, Jul 22, 2010 at 9:08 PM, Boyd Stephen Smith Jr. <
>
> bss@iguanasuicide.net> wrote:
> > On Thursday 22 July 2010 09:21:09 Raghavendra. S wrote:
> > > *dpkg: error processing libgssdp-1.0-dev_0.7.2-2_i386.deb (--install):
> > > trying to overwrite '/usr/share/gir-1.0/GSSDP-1.0.gir', which is also
> > > in
> > >
> > > package gir-repository-dev 0:0.6.5-5ubuntu2*
> > >
> > > Errors were encountered while processing:
> > > libgssdp-1.0-dev_0.7.2-2_i386.deb
> > >
> > > Does any body know what is the reason for this error?
> >
> > Your new package (libgssdp-1.0-dev version 0.7.2-2) wants to install a
> > file that is already controlled by a currently installed package
> > (gir-repository-
> > dev version 0:0.6.5-5ubuntu2). The specific file is
> > /usr/share/gir-1.0/GSSDP-1.0.gir.
> >
> > IMO, neither package should install this file. /usr/share/$foo is usually
> > the
> > domain of a package named "$foo".
> >
> > Finally, it appears that you are mixing repositories, which you should
> > only do
> > when you know the combination is safe, due to the policies governing each
> > repository.
>
> As I mentioned I had taken this code from
> http://ftp.debian.org/debian/pool/main/g/gssdp/. I havenot modified any
> thing.

I didn't claim you modified anything.

However, you appear to be using package from both the Ubuntu and Debian
archives/repositories. Those archives/repositories are not compatible in
general. You should get all your packages from a set of compatible
repositories.

You should also be using apt-get or aptitude to install packages, unless you
have good reasons to use not to. (Even if you need to make modifications, it
is relatively painless to create your own local apt repository.)

> > However, one way to fix
> > you issue is, prior to building the .deb, to edit debian/rules so that
> > /usr/share/gir-1.0/GSSDP-1.0.gir is not installed.
>
> I edited debian/rules file as you mentioned, but no success. I am getting
> same error.

After you edit the debian/rules file, you'll need to rebuild the .deb package.
--
Boyd Stephen Smith Jr. ,= ,-_-. =.
bss@iguanasuicide.net ((_/)o o(\_))
ICQ: 514984 YM/AIM: DaTwinkDaddy `-'(. .)`-'
http://iguanasuicide.net/ \_/
 
Old 07-23-2010, 03:43 PM
"Boyd Stephen Smith Jr."
 
Default dpkg -i libgssdp-1.0-dev_0.7.2-2_i386.deb error installing

Please trim your replies in the future. Full-quoting is rarely of any
assistance in a mailing-list setting.

On Thursday 22 July 2010 23:16:08 Raghavendra. S wrote:
> I am getting same error while installing
>
> *dpkg -i libgupnp-1.0-dev_0.13.4-1_i386.deb*
> (Reading database ... 154552 files and directories currently installed.)
> Unpacking libgupnp-1.0-dev (from libgupnp-1.0-dev_0.13.4-1_i386.deb) ...
> *dpkg: error processing libgupnp-1.0-dev_0.13.4-1_i386.deb (--install):
> trying to overwrite '/usr/share/gir-1.0/GUPnP-1.0.gir', which is also in
> package gir-repository-dev 0:0.6.5-5ubuntu2
> *Processing triggers for man-db ...
> Errors were encountered while processing:
> libgupnp-1.0-dev_0.13.4-1_i386.deb

Different file. Different package combination. Same issue. Same resolution.
--
Boyd Stephen Smith Jr. ,= ,-_-. =.
bss@iguanasuicide.net ((_/)o o(\_))
ICQ: 514984 YM/AIM: DaTwinkDaddy `-'(. .)`-'
http://iguanasuicide.net/ \_/
 

Thread Tools




All times are GMT. The time now is 07:28 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org