FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian User

 
 
LinkBack Thread Tools
 
Old 07-08-2010, 01:40 PM
Andrew Perrin
 
Default evolution-mapi - anybody got it working?

My university is shifting over to Exchange 2007, which means I would like
to try to get evolution working as a client. However, evolution-mapi
doesn't install for me, even from unstable, because the package depends on
evolution version < 2.29 where the version in the repository is 2.30. I
will keep tinkering, but if anybody has made this work so far I'd
appreciate guidance.


Thanks.

----------------------------------------------------------------------
Andrew J Perrin - andrew_perrin (at) unc.edu - http://perrin.socsci.unc.edu
Associate Professor and Associate Chair of Sociology
University of North Carolina - CB#3210, Chapel Hill, NC 27599-3210 USA



--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Archive: alpine.DEB.2.00.1007080939280.12522@perrin.socsci. unc.edu">http://lists.debian.org/alpine.DEB.2.00.1007080939280.12522@perrin.socsci. unc.edu
 
Old 07-09-2010, 04:24 AM
Ron Johnson
 
Default evolution-mapi - anybody got it working?

On 07/08/2010 08:40 AM, Andrew Perrin wrote:

My university is shifting over to Exchange 2007, which means I would
like to try to get evolution working as a client. However,
evolution-mapi doesn't install for me, even from unstable, because the
package depends on evolution version < 2.29 where the version in the
repository is 2.30. I will keep tinkering, but if anybody has made this
work so far I'd appreciate guidance.



Are you sure you're up-to-date? Or maybe actually running Squeeze?

I ask because in Sid, evolution-mapi Depends: evolution (>= 2.28.3).

--
Seek truth from facts.


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Archive: 4C36A49B.2020404@cox.net">http://lists.debian.org/4C36A49B.2020404@cox.net
 
Old 07-09-2010, 10:45 AM
Andrew Perrin
 
Default evolution-mapi - anybody got it working?

On Thu, 8 Jul 2010, Ron Johnson wrote:


Are you sure you're up-to-date? Or maybe actually running Squeeze?

I ask because in Sid, evolution-mapi Depends: evolution (>= 2.28.3).


Well, not completely sure, but here's what I've got:

sandbox:~# cat /etc/apt/sources.list
deb http://http.us.debian.org/debian unstable main contrib non-free


sandbox:~# cat /etc/debian_version
squeeze/sid


sandbox:~# apt-cache show evolution-mapi
Package: evolution-mapi
Priority: optional
Section: gnome
Installed-Size: 1260
Maintainer: Debian Evolution Maintainers
<pkg-evolution-maintainers@lists.alioth.debian.org>

Architecture: amd64
Version: 0.28.3-2
Depends: evolution (>= 2.28.3), libart-2.0-2 (>= 2.3.18), libatk1.0-0 (>=
1.20.0), libbonobo2-0 (>= 2.15.0), libbonoboui2-0 (>= 2.15.1), libc6 (>=
2.2.5), libcairo2 (>= 1.2.4), libcamel1.2-14 (>= 2.27), libcamel1.2-14 (<<
2.29), libdcerpc0, libebackend1.2-0 (>= 2.28.3.1), libebook1.2-9 (>=
2.28.3.1), libecal1.2-7 (>= 2.28.3.1), libedata-book1.2-2 (>= 2.28.3.1),
libedata-cal1.2-6 (>= 2.28.3.1), libedataserver1.2-11 (>= 2.28.3.1),
libexchangemapi-1.0-0 (>= 0.28), libexchangemapi-1.0-0 (<< 0.29),
libfontconfig1 (>= 2.8.0), libfreetype6 (>= 2.2.1), libgconf2-4 (>=
2.27.0), libglib2.0-0 (>= 2.16.0), libgnome2-0 (>= 2.17.3),
libgnomecanvas2-0 (>= 2.11.1), libgnomeui-0 (>= 2.22.0), libgnomevfs2-0
(>= 1:2.17.90), libgtk2.0-0 (>= 2.14.0), libical0 (>= 0.42), libice6 (>=
1:1.0.0), libmapi0, libndr0, liborbit2 (>= 1:2.14.10), libpango1.0-0 (>=
1.14.0), libpopt0 (>= 1.15), libsamba-hostconfig0, libsm6, libsoup2.4-1
(>= 2.4.0), libsqlite3-0 (>= 3.6.22), libtalloc2 (>= 2.0.0), libtevent0,
libxml2 (>= 2.6.27), evolution (<< 2.29.0)

Filename: pool/main/e/evolution-mapi/evolution-mapi_0.28.3-2_amd64.deb
Size: 192332
MD5sum: d62d3c2b49ad06bd84da39e9ca2c07bd
SHA1: 690cc861157ba5d801c192ef777b411f3a70a892
SHA256: 8d1b18ffb3d6993d640f3a0266f14e564e44c1905bde96b240 43881a5e1e644b
Description: Exchange support for the Evolution groupware suite
The Evolution MAPI provider adds support for Microsoft Exchange,
including Exchange 2007, to the Evolution groupware suite, using the
proprietary MAPI protocol.
.
Unlike the Exchange connector (in the evolution-exchange package), it
does not use Outlook Web Access and requires direct access to the
Exchange server.
Homepage: http://www.go-evolution.org/MAPIProvider
Tag: uitoolkit::gtk





----------------------------------------------------------------------
Andrew J Perrin - andrew_perrin (at) unc.edu - http://perrin.socsci.unc.edu
Associate Professor and Associate Chair of Sociology
University of North Carolina - CB#3210, Chapel Hill, NC 27599-3210 USA





--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Archive: alpine.DEB.2.00.1007090642300.16817@perrin.socsci. unc.edu">http://lists.debian.org/alpine.DEB.2.00.1007090642300.16817@perrin.socsci. unc.edu
 
Old 07-09-2010, 01:21 PM
Ron Johnson
 
Default evolution-mapi - anybody got it working?

On 07/09/2010 05:45 AM, Andrew Perrin wrote:

On Thu, 8 Jul 2010, Ron Johnson wrote:


Are you sure you're up-to-date? Or maybe actually running Squeeze?

I ask because in Sid, evolution-mapi Depends: evolution (>= 2.28.3).


Well, not completely sure, but here's what I've got:

sandbox:~# cat /etc/apt/sources.list
deb http://http.us.debian.org/debian unstable main contrib non-free


[snip]


sandbox:~# apt-cache show evolution-mapi
Package: evolution-mapi

[snip]

Version: 0.28.3-2
Depends: evolution (>= 2.28.3), libart-2.0-2 (>= 2.3.18), libatk1.0-0



So where did you see "depends on evolution version < 2.29"?

Or did that "disappear" after you did an "apt-get update"?

--
Seek truth from facts.


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Archive: 4C372256.3000805@cox.net">http://lists.debian.org/4C372256.3000805@cox.net
 
Old 07-09-2010, 01:40 PM
Andrew Perrin
 
Default evolution-mapi - anybody got it working?

On Fri, 9 Jul 2010, Ron Johnson wrote:


On 07/09/2010 05:45 AM, Andrew Perrin wrote:

On Thu, 8 Jul 2010, Ron Johnson wrote:


Are you sure you're up-to-date? Or maybe actually running Squeeze?

I ask because in Sid, evolution-mapi Depends: evolution (>= 2.28.3).


Well, not completely sure, but here's what I've got:

sandbox:~# cat /etc/apt/sources.list
deb http://http.us.debian.org/debian unstable main contrib non-free


[snip]


sandbox:~# apt-cache show evolution-mapi
Package: evolution-mapi

[snip]

Version: 0.28.3-2
Depends: evolution (>= 2.28.3), libart-2.0-2 (>= 2.3.18), libatk1.0-0



So where did you see "depends on evolution version < 2.29"?

Or did that "disappear" after you did an "apt-get update"?


The last line of the Depends:

evolution (<< 2.29.0)


----------------------------------------------------------------------
Andrew J Perrin - andrew_perrin (at) unc.edu - http://perrin.socsci.unc.edu
Associate Professor and Associate Chair of Sociology
University of North Carolina - CB#3210, Chapel Hill, NC 27599-3210 USA




--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Archive: alpine.DEB.2.00.1007090939440.20543@perrin.socsci. unc.edu">http://lists.debian.org/alpine.DEB.2.00.1007090939440.20543@perrin.socsci. unc.edu
 
Old 07-09-2010, 02:10 PM
Ron Johnson
 
Default evolution-mapi - anybody got it working?

On 07/09/2010 08:40 AM, Andrew Perrin wrote:

On Fri, 9 Jul 2010, Ron Johnson wrote:


On 07/09/2010 05:45 AM, Andrew Perrin wrote:

On Thu, 8 Jul 2010, Ron Johnson wrote:


Are you sure you're up-to-date? Or maybe actually running Squeeze?

I ask because in Sid, evolution-mapi Depends: evolution (>= 2.28.3).


Well, not completely sure, but here's what I've got:

sandbox:~# cat /etc/apt/sources.list
deb http://http.us.debian.org/debian unstable main contrib non-free


[snip]


sandbox:~# apt-cache show evolution-mapi
Package: evolution-mapi

[snip]

Version: 0.28.3-2
Depends: evolution (>= 2.28.3), libart-2.0-2 (>= 2.3.18), libatk1.0-0



So where did you see "depends on evolution version < 2.29"?

Or did that "disappear" after you did an "apt-get update"?


The last line of the Depends:

evolution (<< 2.29.0)



Hmm, yes. I guess there was an Evo 2.28.4.

--
Seek truth from facts.


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Archive: 4C372DF3.30307@cox.net">http://lists.debian.org/4C372DF3.30307@cox.net
 
Old 07-09-2010, 03:27 PM
Javier Vasquez
 
Default evolution-mapi - anybody got it working?

On 7/9/10, Ron Johnson <ron.l.johnson@cox.net> wrote:
> On 07/09/2010 08:40 AM, Andrew Perrin wrote:
>> On Fri, 9 Jul 2010, Ron Johnson wrote:
>>
>>> On 07/09/2010 05:45 AM, Andrew Perrin wrote:
>>>> On Thu, 8 Jul 2010, Ron Johnson wrote:
>>>>
>>>>> Are you sure you're up-to-date? Or maybe actually running Squeeze?
>>>>>
>>>>> I ask because in Sid, evolution-mapi Depends: evolution (>= 2.28.3).
>>>>
>>>> Well, not completely sure, but here's what I've got:
>>>>
>>>> sandbox:~# cat /etc/apt/sources.list
>>>> deb http://http.us.debian.org/debian unstable main contrib non-free
>>>>
>>> [snip]
>>>>
>>>> sandbox:~# apt-cache show evolution-mapi
>>>> Package: evolution-mapi
>>> [snip]
>>>> Version: 0.28.3-2
>>>> Depends: evolution (>= 2.28.3), libart-2.0-2 (>= 2.3.18), libatk1.0-0
>>>
>>>
>>> So where did you see "depends on evolution version < 2.29"?
>>>
>>> Or did that "disappear" after you did an "apt-get update"?
>>
>> The last line of the Depends:
>>
>> evolution (<< 2.29.0)
>>
>
> Hmm, yes. I guess there was an Evo 2.28.4.

I mailed developers some time back:

-----
To: pkg-evolution-maintainers@lists.alioth.debian.org
...

I just noticed that under unstable, evolution-mapi version is
0.28.3-2, but it depends on evolution < 2.29.0, while current
evolution in unstable is 2.30.2-1.

It might be left in such state in purpose, or it might be the package
requires refresh for current evolution package (it sounds more like
it)...

I'm not sure if this is something you'd like to have a bug against, or
if it's something you're aware of already, and you don't need to be
bugged because of it...
...
-----

And I got the answer:

-----
From: Yves-Alexis Perez <corsac@debian.org>
Cc: pkg-evolution-maintainers@lists.alioth.debian.org
...
At least, that's something we would need people for. Like exchange, I
have no setup, no knowledge nor any interest in it. So if you're
interested in it, you might have to give some time.
...
-----

So, I think more time is needed, and help can be offered to the
developers... :-)

--
Javier.


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: AANLkTik_6MItkA0CJKIOv7isLIzAN5J05k4zj6v7TZu8@mail .gmail.com">http://lists.debian.org/AANLkTik_6MItkA0CJKIOv7isLIzAN5J05k4zj6v7TZu8@mail .gmail.com
 

Thread Tools




All times are GMT. The time now is 01:28 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org