FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian User

 
 
LinkBack Thread Tools
 
Old 07-07-2010, 07:44 AM
"Gorka"
 
Default Installing Java on Lenny

Hi linux friends. I've got Debian Lenny 5.0.5.

I'm trying to install mirth, whose requires Java 1.5 or 1.6.

The fact is that Lenny had Java somehow on it before installing it manually,
because it says:
# java -version
java version "1.5.0"
gij (GNU libgcj) version 4.3.2

Anyway it doesn't let me install mirth, printing this error:
#./mirth-1.8.2.4472.1351-linux-installer.bin
Error: The installer could not find a valid Java(tm) on this machine.
Supported versions:
Vendor : Sun min. 1.5 max. any

Why?

I've installed every package on Debian Volatile relative to sun-java-1.5
from the following repositories ...
#deb http://volatile.debian.org/debian-volatile lenny/volatile main
#deb-src http://volatile.debian.org/debian-volatile lenny/volatile main
... but I'm getting the same error.

But the most annoying thing is that if I install packages relating to
sun-java-1.6 me I'm getting the same error, the Sun site says I'm on 1.6 but
'java -version' command says I'm on 1.5.0 version.

I've also tried to install jre-6u20-linux-i586.bin (that's supposed to be in
1.6 version) downloaded directly from Sun site, instead of using the Debian
packages. Unsuccessfully.

How can I install Java to let me install mirth?


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 02f101cb1da8$415f0a90$c41d1fb0$@es">http://lists.debian.org/02f101cb1da8$415f0a90$c41d1fb0$@es
 
Old 07-07-2010, 08:04 AM
Eero Volotinen
 
Default Installing Java on Lenny

2010/7/7 Gorka <gorkalinux@yahoo.es>:
>
>
> Hi linux friends. I've got Debian Lenny 5.0.5.
>
> I'm trying to install mirth, whose requires Java 1.5 or 1.6.
>
> The fact is that Lenny had Java somehow on it before installing it manually,
> because it says:
> # java -version
> java version "1.5.0"
> gij (GNU libgcj) version 4.3.2
>
> Anyway it doesn't let me install mirth, printing this error:
> #./mirth-1.8.2.4472.1351-linux-installer.bin
> Error: The installer could not find a valid Java(tm) on this machine.
> Supported versions:
> Vendor : Sun *min. 1.5 max. any
>
> Why?
>
> I've installed every package on Debian Volatile relative to sun-java-1.5
> from the following repositories ...
> #deb http://volatile.debian.org/debian-volatile lenny/volatile main
> #deb-src http://volatile.debian.org/debian-volatile lenny/volatile main
> ... but I'm getting the same error.
>
> But the most annoying thing is that if I install packages relating to
> sun-java-1.6 me I'm getting the same error, the Sun site says I'm on 1.6 but
> 'java -version' command says I'm on 1.5.0 version.
>
> I've also tried to install jre-6u20-linux-i586.bin (that's supposed to be in
> 1.6 version) downloaded directly from Sun site, instead of using the Debian
> packages. Unsuccessfully.

http://www.rsreese.com/2009/05/installing-sun-java-on-debian-lenny/

--
Eero


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: AANLkTikb-MCM2pMjmZ9Hwcr99mJe0bahxVGOIXU9gL7M@mail.gmail.com ">http://lists.debian.org/AANLkTikb-MCM2pMjmZ9Hwcr99mJe0bahxVGOIXU9gL7M@mail.gmail.com
 
Old 07-07-2010, 08:50 AM
"Gorka"
 
Default Installing Java on Lenny

> -----Mensaje original-----
> De: eero.t.volotinen@gmail.com [mailto:eero.t.volotinen@gmail.com] En
> nombre de Eero Volotinen
> Enviado el: miércoles, 07 de julio de 2010 10:04
> Para: Gorka
> CC: LINUX EN
> Asunto: Re: Installing Java on Lenny
>
> 2010/7/7 Gorka <gorkalinux@yahoo.es>:
> >
> >
> > Hi linux friends. I've got Debian Lenny 5.0.5.
> >
> > I'm trying to install mirth, whose requires Java 1.5 or 1.6.
> >
> > The fact is that Lenny had Java somehow on it before installing it
> manually,
> > because it says:
> > # java -version
> > java version "1.5.0"
> > gij (GNU libgcj) version 4.3.2
> >
> > Anyway it doesn't let me install mirth, printing this error:
> > #./mirth-1.8.2.4472.1351-linux-installer.bin
> > Error: The installer could not find a valid Java(tm) on this machine.
> > Supported versions:
> > Vendor : Sun *min. 1.5 max. any
> >
> > Why?
> >
> > I've installed every package on Debian Volatile relative to sun-java-
> 1.5
> > from the following repositories ...
> > #deb http://volatile.debian.org/debian-volatile lenny/volatile main
> > #deb-src http://volatile.debian.org/debian-volatile lenny/volatile
> main
> > ... but I'm getting the same error.
> >
> > But the most annoying thing is that if I install packages relating to
> > sun-java-1.6 me I'm getting the same error, the Sun site says I'm on
> 1.6 but
> > 'java -version' command says I'm on 1.5.0 version.
> >
> > I've also tried to install jre-6u20-linux-i586.bin (that's supposed
> to be in
> > 1.6 version) downloaded directly from Sun site, instead of using the
> Debian
> > packages. Unsuccessfully.
>
> http://www.rsreese.com/2009/05/installing-sun-java-on-debian-lenny/
>
> --
> Eero

Thanks.


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 02f501cb1db1$6e1de160$4a59a420$@es">http://lists.debian.org/02f501cb1db1$6e1de160$4a59a420$@es
 

Thread Tools




All times are GMT. The time now is 09:46 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org