FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian User

 
 
LinkBack Thread Tools
 
Old 07-01-2010, 08:43 PM
Andrei Popescu
 
Default Local apt repository and specific version

On Jo, 01 iul 10, 20:51:05, Didster wrote:

[...]

> Then "apt-get install package-system" installs package-system 2.0.2
> along with V2.1.99 of the three packages. But "apt-get install
> package-system=2.0.1" fails as follows:
>
> The following packages have unmet dependencies.
> package-system: Depends: package1 (= 2.1.88) but 2.1.99 is to be installed
> Depends: package2 (= 2.1.88) but 2.1.99 is to be installed
> Depends: package3 (= 2.1.88) but 2.1.99 is to be installed
> E: Broken packages

Does aptitude behave the same way?

Regards,
Andrei
--
Offtopic discussions among Debian users and developers:
http://lists.alioth.debian.org/mailman/listinfo/d-community-offtopic
 
Old 07-01-2010, 08:54 PM
Jordan Metzmeier
 
Default Local apt repository and specific version

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

On 07/01/2010 03:51 PM, Didster wrote:
> Hi there,
>
> We use a local apt repository as a means to distribute our own
> software. The software is not and will not ever be part of the
> official Debian archives. Our software consists of 4 packages, 3 real
> ones, lets call then package1, package2 and package3 and a overall
> package that exists to bring in the three packages at a specific
> version to make a overall version of our system - gets call that
> package-system.
>
> The local repository consists of many versions of each of the four
> packages. When asking apt to install the very latest version of
> package-system, everything works just as it should. But when asking
> apt to install a specific older version of package-system (which we
> sometimes need to do), apt complains and says the dependencies cannot
> be met.
>
> Assume we have
>


What about a system similar to say, debian kernels. You can add the
versions to the package names so they become distinct packages eg.
package1-2.1.88. Of course, this could end up being a nightmare in the
Conflicts: field to prevent multiple version from being installed.

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)

iQIcBAEBCAAGBQJMLQCHAAoJEKj/C3qNthmT+FcQAIHubtpYkt7X1fLjhffJvBxA
hbk/3cb94g2C8pBnOm2OygUsmAY09eTcWhcUgbucweg0BSzknpLyH3 EJ9yaRcEv/
acu/dqJCtMt3ApgA2tdbMkwKdMrqq7OBOs+uQxNYOvtwXsRE6dGhAl CFN/lTwltW
lFGFIc3Q4Eh6KzZR82/GhJb0QSjyYNxPRTU4mHeSfoIsOyqqK15ojvrfTi75w2Ls
k3+3YZHWNz8hLav/8/mYy2VCqtIJcqG0gs41Lt9HYyway4/hyR+J+sUO8gIUbPpg
gAzGjJcaie21MMFu9U44n2iCSkg4BGpI03P0hoKwNvUoRKW1lV q7kyIjg6QCwT7C
Z0nJzbDiUelwNuXsBtiklFTLlZfYRGpe/eTxbBJhGHdmuW6cn1/M+Ri4GRM9XNf5
DvY1d1nj/PlHCS4uIg+uB7LRPZWps6vCA3Q3TnVc6WJfXJJ/ODFD0hoj6D1gMqId
4O9TD7IBzMFISuWpd+HS78zRtr9mPqhYPT4diIg9z5UKx6dG8N aIysdf2qDLqly0
NaT5tf4EfXkIwtE7DCK9jg0Sh0PQHg2LvQpulsUChpAhIWn+R2 02WNNaeg5G6ooS
fQi6WVfIlktMvx8ASyqHNTDfmyjERv2+mMcuYtEUHCzhNoodGp iIHASgKDo1oOfT
DXBoIjrBgM6MoXFYxFv7
=DfPE
-----END PGP SIGNATURE-----


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 4C2D0087.6060006@gmail.com">http://lists.debian.org/4C2D0087.6060006@gmail.com
 
Old 07-01-2010, 09:06 PM
Didster
 
Default Local apt repository and specific version

Sort of - but it can actually do the install:

The following packages are BROKEN:
package-system
The following packages have unmet dependencies:
package-system: Depends: package1 (= 2.1.88) but it is not installable
Depends: package2 (= 2.1.88) but it is not installable
Depends: package3 (= 2.1.88) but it is not installable
The following actions will resolve these dependencies:

Install the following packages:
package1 [2.1.88 (unstable)]
packge2 [2.1.88 (unstable)]
packge3 [2.1.88 (unstable)]

Selecting yes goes ahead and installs package1 2 and 3 followed by
package-system

How can a package that is "not installable" then be installed??!

Thanks


On Thu, Jul 1, 2010 at 9:43 PM, Andrei Popescu <andreimpopescu@gmail.com> wrote:
> On Jo, 01 iul 10, 20:51:05, Didster wrote:
>
> [...]
>
>> Then "apt-get install package-system" installs package-system 2.0.2
>> along with V2.1.99 of the three packages. *But "apt-get install
>> package-system=2.0.1" fails as follows:
>>
>> The following packages have unmet dependencies.
>> * package-system: Depends: package1 (= 2.1.88) but 2.1.99 is to be installed
>> * * * * * * * * Depends: package2 (= 2.1.88) but 2.1.99 is to be installed
>> * * * * * * * * Depends: package3 (= 2.1.88) but 2.1.99 is to be installed
>> E: Broken packages
>
> Does aptitude behave the same way?
>
> Regards,
> Andrei
> --
> Offtopic discussions among Debian users and developers:
> http://lists.alioth.debian.org/mailman/listinfo/d-community-offtopic
>
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.10 (GNU/Linux)
>
> iQEcBAEBCAAGBQJMLP31AAoJEHNWs3jeoi3pjyMH/2hgebZN/XviZNwxJowTqr5A
> xIJObvCcJ8Ndr1vvQpPzXaQHzSHMvJSpPBojL1lcspJBnzVN6k cryAdeTXlguo6+
> 4ZFjtRDfd0J0LOLMHulNtB4oKIuSX1KT7+wiIkclcJRdHt02Os 2qSkPzhMmiwTl8
> L6qsjVGbtkKbczFVl2SMr065aZtzs5ehpg6pqRLGESf8z8bBsj TgNw9+RLSx7u1m
> HXPFYRExKt09lmt9jfeO4MYHzAtBGdMtUsCQtRHV8MgZy//wgX68iz8Tlew0IyWz
> 0ToJJSWTx3pEsd0F+e/4zmv6RRkSVrhoFoHxOURyEA6PRH+oJaGk5HPKs19InGQ=
> =RB/Y
> -----END PGP SIGNATURE-----
>
>


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: AANLkTikxxfMcbdT-b1B4Rs6jYjFwd3SfWNxusF3OZ_4W@mail.gmail.com">http://lists.debian.org/AANLkTikxxfMcbdT-b1B4Rs6jYjFwd3SfWNxusF3OZ_4W@mail.gmail.com
 
Old 07-01-2010, 09:16 PM
Didster
 
Default Local apt repository and specific version

I tried this, but it didn't help.

I gave package-system a unique name based on the version, but it did
the same thing. I didn't try giving all 3 packages their own name
based on version (nor would I want to!)

Thanks


On Thu, Jul 1, 2010 at 9:54 PM, Jordan Metzmeier <titan8990@gmail.com> wrote:
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA256
>
> On 07/01/2010 03:51 PM, Didster wrote:
>> Hi there,
>>
>> We use a local apt repository as a means to distribute our own
>> software. *The software is not and will not ever be part of the
>> official Debian archives. *Our software consists of 4 packages, 3 real
>> ones, lets call then package1, package2 and package3 and a overall
>> package that exists to bring in the three packages at a specific
>> version to make a overall version of our system - gets call that
>> package-system.
>>
>> The local repository consists of many versions of each of the four
>> packages. *When asking apt to install the very latest version of
>> package-system, everything works just as it should. *But when asking
>> apt to install a specific older version of package-system (which we
>> sometimes need to do), apt complains and says the dependencies cannot
>> be met.
>>
>> Assume we have
>>
>
>
> What about a system similar to say, debian kernels. You can add the
> versions to the package names so they become distinct packages eg.
> package1-2.1.88. Of course, this could end up being a nightmare in the
> Conflicts: field to prevent multiple version from being installed.
>
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.9 (GNU/Linux)
>
> iQIcBAEBCAAGBQJMLQCHAAoJEKj/C3qNthmT+FcQAIHubtpYkt7X1fLjhffJvBxA
> hbk/3cb94g2C8pBnOm2OygUsmAY09eTcWhcUgbucweg0BSzknpLyH3 EJ9yaRcEv/
> acu/dqJCtMt3ApgA2tdbMkwKdMrqq7OBOs+uQxNYOvtwXsRE6dGhAl CFN/lTwltW
> lFGFIc3Q4Eh6KzZR82/GhJb0QSjyYNxPRTU4mHeSfoIsOyqqK15ojvrfTi75w2Ls
> k3+3YZHWNz8hLav/8/mYy2VCqtIJcqG0gs41Lt9HYyway4/hyR+J+sUO8gIUbPpg
> gAzGjJcaie21MMFu9U44n2iCSkg4BGpI03P0hoKwNvUoRKW1lV q7kyIjg6QCwT7C
> Z0nJzbDiUelwNuXsBtiklFTLlZfYRGpe/eTxbBJhGHdmuW6cn1/M+Ri4GRM9XNf5
> DvY1d1nj/PlHCS4uIg+uB7LRPZWps6vCA3Q3TnVc6WJfXJJ/ODFD0hoj6D1gMqId
> 4O9TD7IBzMFISuWpd+HS78zRtr9mPqhYPT4diIg9z5UKx6dG8N aIysdf2qDLqly0
> NaT5tf4EfXkIwtE7DCK9jg0Sh0PQHg2LvQpulsUChpAhIWn+R2 02WNNaeg5G6ooS
> fQi6WVfIlktMvx8ASyqHNTDfmyjERv2+mMcuYtEUHCzhNoodGp iIHASgKDo1oOfT
> DXBoIjrBgM6MoXFYxFv7
> =DfPE
> -----END PGP SIGNATURE-----
>
>
> --
> To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
> with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
> Archive: http://lists.debian.org/4C2D0087.6060006@gmail.com
>
>


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: AANLkTin0Gkdkh6Gmv1IMM46GApsw8QTn4SSnPPox-Y3n@mail.gmail.com">http://lists.debian.org/AANLkTin0Gkdkh6Gmv1IMM46GApsw8QTn4SSnPPox-Y3n@mail.gmail.com
 
Old 07-01-2010, 10:16 PM
Andrei Popescu
 
Default Local apt repository and specific version

On Jo, 01 iul 10, 22:06:49, Didster wrote:
>
> How can a package that is "not installable" then be installed??!

As you've shown in you 'apt-cache policy' those versions are not
'candidate' versions, but aptitude offers alternative solutions (one of
the benefits over apt-get), one of them being to actually install
non-candidate versions. This is AFAIU, someone will correct me if I'm
wrong.

Regards,
Andrei
--
Offtopic discussions among Debian users and developers:
http://lists.alioth.debian.org/mailman/listinfo/d-community-offtopic
 
Old 07-01-2010, 10:23 PM
Didster
 
Default Local apt repository and specific version

Aha...

So I assume that basically boils down to apt-get not being able to
resolve a dependency at a specific version and instead will always
look for and install the candidate version?

I need to stick to apt-get really - just because I dont want to re-do
2 tons of documentation ;o)

I have managed to work around it by having a repro that is specific
for each overall version number and just pointing apt at the one I
want installed rather than using =<version>. That seems to work OK.

Thanks for the help.

On Thu, Jul 1, 2010 at 11:16 PM, Andrei Popescu
<andreimpopescu@gmail.com> wrote:
> On Jo, 01 iul 10, 22:06:49, Didster wrote:
>>
>> How can a package that is "not installable" then be installed??!
>
> As you've shown in you 'apt-cache policy' those versions are not
> 'candidate' versions, but aptitude offers alternative solutions (one of
> the benefits over apt-get), one of them being to actually install
> non-candidate versions. This is AFAIU, someone will correct me if I'm
> wrong.
>
> Regards,
> Andrei
> --
> Offtopic discussions among Debian users and developers:
> http://lists.alioth.debian.org/mailman/listinfo/d-community-offtopic
>
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.10 (GNU/Linux)
>
> iQEcBAEBCAAGBQJMLRPKAAoJEHNWs3jeoi3pcBwH/A/i/WJjBOEmxHbYQw9FqXC8
> R3O/b430HVIwCO26pThPW05QzxLR5PwbI0rc/eBx1Fz4bCkhT+TKE0EZ9HqvhBud
> UR0m3T1hv0CoKL58KgG9XUk6+D2Faw3jNeofgGOI3TemfxsSgv CMYDszNXLjg4nf
> 4Oa33KbnolnhAqXPFUjjKSHxlTHbSSvZSpK9QlfNVQ9L92OW9m M2QFZYlUghns4H
> /n7xPL0OxyD/ZG8xxZk1lUhTFwu973VATnNsb3MdWzd5sbFHS8JORX+GSEku1x OK
> nsHTOC4yO0Sem3lyU/47V00GHm3boMbdZ2etKLby9wuAAoKqHdZu+u9hOs+lh1Q=
> =26Aq
> -----END PGP SIGNATURE-----
>
>


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: AANLkTimGDrNiuebRTtdCrDTfs8mRS2hd8peeJSBcVlli@mail .gmail.com">http://lists.debian.org/AANLkTimGDrNiuebRTtdCrDTfs8mRS2hd8peeJSBcVlli@mail .gmail.com
 

Thread Tools




All times are GMT. The time now is 07:46 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org