FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian User

 
 
LinkBack Thread Tools
 
Old 07-01-2010, 11:34 AM
Satellite
 
Default Debian unstable Bug - after dist-upgrade (CUPS removed my Canon Printer drivers)

After an upgrade yesterday CUPS removed my network Canon i-SENSYS
MF4120 official printer drivers ('cndrvcups-common_2.00-2_i386' и
'cndrvcups-ufr2-uk_2.00-2_i386'):


Selecting previously deselected package cndrvcups-common.
(Reading database ... 181386 files and directories currently installed.)
Unpacking cndrvcups-common (from cndrvcups-common_2.00-2_i386.deb) ...
Selecting previously deselected package cndrvcups-ufr2-uk.
Unpacking cndrvcups-ufr2-uk (from cndrvcups-ufr2-uk_2.00-2_i386.deb) ...
dpkg: dependency problems prevent configuration of cndrvcups-common:
cndrvcups-common depends on cupsys; however:
Package cupsys is not installed.
cndrvcups-common depends on gs-esp; however:
Package gs-esp is not installed.
dpkg: error processing cndrvcups-common (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of cndrvcups-ufr2-uk:
cndrvcups-ufr2-uk depends on cndrvcups-common (>= 2.00); however:
Package cndrvcups-common is not configured yet.
dpkg: error processing cndrvcups-ufr2-uk (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
cndrvcups-common
cndrvcups-ufr2-uk


NOTE:
1) there is no 'cupsys' in repos (seems that it's deprecated or not used)
2) 'gs-esp' and some other one (don't remember) were also removed by
'cups'.



--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Archive: 4C2C7D38.9020002@gmail.com">http://lists.debian.org/4C2C7D38.9020002@gmail.com
 
Old 07-01-2010, 12:07 PM
Ron Johnson
 
Default Debian unstable Bug - after dist-upgrade (CUPS removed my Canon Printer drivers)

On 07/01/2010 06:34 AM, Satellite wrote:

After an upgrade yesterday CUPS removed my network Canon i-SENSYS MF4120
official printer drivers ('cndrvcups-common_2.00-2_i386' и
'cndrvcups-ufr2-uk_2.00-2_i386'):

Selecting previously deselected package cndrvcups-common.
(Reading database ... 181386 files and directories currently installed.)
Unpacking cndrvcups-common (from cndrvcups-common_2.00-2_i386.deb) ...
Selecting previously deselected package cndrvcups-ufr2-uk.
Unpacking cndrvcups-ufr2-uk (from cndrvcups-ufr2-uk_2.00-2_i386.deb) ...
dpkg: dependency problems prevent configuration of cndrvcups-common:
cndrvcups-common depends on cupsys; however:
Package cupsys is not installed.
cndrvcups-common depends on gs-esp; however:
Package gs-esp is not installed.
dpkg: error processing cndrvcups-common (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of cndrvcups-ufr2-uk:
cndrvcups-ufr2-uk depends on cndrvcups-common (>= 2.00); however:
Package cndrvcups-common is not configured yet.
dpkg: error processing cndrvcups-ufr2-uk (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
cndrvcups-common
cndrvcups-ufr2-uk


NOTE:
1) there is no 'cupsys' in repos (seems that it's deprecated or not used)
2) 'gs-esp' and some other one (don't remember) were also removed by
'cups'.



It's there in Sid/unstable.

$ apt-cache policy cupsys
cupsys:
Installed: 1.4.3-1
Candidate: 1.4.3-1
Version table:
*** 1.4.3-1 0
100 /var/lib/dpkg/status

$ apt-cache show cupsys
Package: cupsys
Status: install ok installed
Priority: extra
Section: oldlibs
Installed-Size: 104
Maintainer: Debian CUPS Maintainers
<pkg-cups-devel@lists.alioth.debian.org>

Architecture: all
Source: cups
Version: 1.4.3-1
Depends: cups
Description: Common UNIX Printing System (transitional package)
This is a dummy package to ease transition to new package name.
.
You can safely remove it after the upgrade.


--
Seek truth from facts.


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Archive: 4C2C8504.70700@cox.net">http://lists.debian.org/4C2C8504.70700@cox.net
 
Old 07-01-2010, 12:42 PM
Satellite
 
Default Debian unstable Bug - after dist-upgrade (CUPS removed my Canon Printer drivers)

2Wolodja Wentland:

1) your commands return nothing for me ( neither aptitude search
"?provides(cupsys)" nor aptitude search "~Pcupsys")

2) I installed these two packages again ('gs-esp' and 'ghostscript-x')

Still, while trying to install official Canon drivers I get this:

Selecting previously deselected package cndrvcups-common.
(Reading database ... 181399 files and directories currently installed.)
Unpacking cndrvcups-common (from cndrvcups-common_2.00-2_i386.deb) ...
Selecting previously deselected package cndrvcups-ufr2-uk.
Unpacking cndrvcups-ufr2-uk (from cndrvcups-ufr2-uk_2.00-2_i386.deb) ...
dpkg: dependency problems prevent configuration of cndrvcups-common:
cndrvcups-common depends on cupsys; however:
Package cupsys is not installed.
dpkg: error processing cndrvcups-common (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of cndrvcups-ufr2-uk:
cndrvcups-ufr2-uk depends on cndrvcups-common (>= 2.00); however:
Package cndrvcups-common is not configured yet.
dpkg: error processing cndrvcups-ufr2-uk (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
cndrvcups-common
cndrvcups-ufr2-uk


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Archive: 4C2C8D2D.4050507@gmail.com">http://lists.debian.org/4C2C8D2D.4050507@gmail.com
 
Old 07-01-2010, 01:01 PM
Wolodja Wentland
 
Default Debian unstable Bug - after dist-upgrade (CUPS removed my Canon Printer drivers)

On Thu, Jul 01, 2010 at 14:34 +0300, Satellite wrote:

> After an upgrade yesterday CUPS removed my network Canon i-SENSYS
> MF4120 official printer drivers ('cndrvcups-common_2.00-2_i386' и
> 'cndrvcups-ufr2-uk_2.00-2_i386'):
[...]
> dpkg: dependency problems prevent configuration of cndrvcups-common:
> cndrvcups-common depends on cupsys; however:
> Package cupsys is not installed.
[...]

> 1) there is no 'cupsys' in repos (seems that it's deprecated or not used)

The "cups" package in sid should provide "cupsys" [1]

Issue the following command:

aptitude search "?provides(cupsys)"

or

aptitude search "~Pcupsys"

to list all packages that provide cupsys.

> cndrvcups-common depends on gs-esp; however:
> Package gs-esp is not installed.
[...]

> 2) 'gs-esp' and some other one (don't remember) were also removed by
> 'cups'.

The same holds true for gs-esp which is provided by "ghostscript-x" ...
So just make sure that you have those packages installed ...

[1] http://packages.debian.org/sid/cupsys
--
.'`. Wolodja Wentland <wentland@cl.uni-heidelberg.de>
: :' :
`. `'` 4096R/CAF14EFC
`- 081C B7CD FF04 2BA9 94EA 36B2 8B7F 7D30 CAF1 4EFC
 
Old 07-01-2010, 01:07 PM
Wolodja Wentland
 
Default Debian unstable Bug - after dist-upgrade (CUPS removed my Canon Printer drivers)

On Thu, Jul 01, 2010 at 15:42 +0300, Satellite wrote:
> 2Wolodja Wentland:
>
> 1) your commands return nothing for me ( neither aptitude search
> "?provides(cupsys)" nor aptitude search "~Pcupsys")
> 2) I installed these two packages again ('gs-esp' and 'ghostscript-x')

Hmmm - can't explain that right now and I don't have a sid system around
to investigate ... Either someone else provides some clues, or I'll use
other means to gather additional information.

Btw - The two commands do exactly the same and you might take a look at
[1] to understand them. They essentially search for packages that
provide cupsys or gs-esp (if called with ~Pgs-esp)

> Still, while trying to install official Canon drivers I get this:

Are you sure that you have the latest versions of these packages
installed? As you are installing an unsupported third-party deb of
unknown quality it might also be necessary to install the virtual
packages (i.e. cupsys/gs-esp) that should not be needed anymore because
they are provided by cups and ghostscript-x respectively.

[1]
http://algebraicthunk.net/~dburrows/projects/aptitude/doc/en/ch02s03s05.html
--
.'`. Wolodja Wentland <wentland@cl.uni-heidelberg.de>
: :' :
`. `'` 4096R/CAF14EFC
`- 081C B7CD FF04 2BA9 94EA 36B2 8B7F 7D30 CAF1 4EFC
 

Thread Tools




All times are GMT. The time now is 12:15 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org