Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Debian User (http://www.linux-archive.org/debian-user/)
-   -   Glitch-y wicd-curses Install (http://www.linux-archive.org/debian-user/319746-glitch-y-wicd-curses-install.html)

02-03-2010 03:19 AM

Glitch-y wicd-curses Install
 
Upgrading wicd-curses 1.7.0-2 to 1.7.0-3 with aptitude on squeeze.

First I noticed that wicd was installed, which is supposed to conflict with
wicd-curses and which I remember purposefully not installing.

But the upgrade asked to remove wicd so I just took that.

The install succeeded but threw errors attached below. Have I gotten myself
into something here? (Some script-heavy packages can be hard to back out
of.) I also have python errors in apt-listchanges.

|
| Unpacking replacement wicd-curses ...
| Preparing to replace wicd-daemon 1.7.0-2 (using
| .../wicd-daemon_1.7.0-3_all.deb) ...
| Stopping Network connection manager: wicd.
| Unpacking replacement wicd-daemon ...
| Preparing to replace python-wicd 1.7.0-2 (using
| .../python-wicd_1.7.0-3_all.deb) ...
| Unpacking replacement python-wicd ...
| Preparing to replace shared-mime-info 0.70-1 (using
| .../shared-mime-info_0.71-1_i386.deb) ...
| Unpacking replacement shared-mime-info ...
| Processing triggers for man-db ...
| Processing triggers for python-support ...
| Setting up iso-codes (3.13-1) ...
| Setting up python-wicd (1.7.0-3) ...
| Setting up wicd-daemon (1.7.0-3) ...
| Installing new version of config file /etc/init.d/wicd ...
| Restarting Network connection manager: wicd.
| Setting up wicd-curses (1.7.0-3) ...
| Setting up shared-mime-info (0.71-1) ...
| Unknown media type in type 'all/all'
|
| Unknown media type in type 'all/allfiles'
|
| Unknown media type in type 'uri/mms'
|
| Unknown media type in type 'uri/mmst'
|
| Unknown media type in type 'uri/mmsu'
|
| Unknown media type in type 'uri/pnm'
|
| Unknown media type in type 'uri/rtspt'
|
| Unknown media type in type 'uri/rtspu'
|
| Unknown media type in type 'fonts/package'
|
| Unknown media type in type 'interface/x-winamp-skin'
|
| Processing triggers for python-support ...
| Press return to continue.
|

--
Kind Regards,
Freeman


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

"Wayne 02-03-2010 02:51 PM

Glitch-y wicd-curses Install
 
evenso@worldwidehtml.com wrote:
Upgrading wicd-curses 1.7.0-2 to 1.7.0-3 with aptitude on squeeze.


First I noticed that wicd was installed, which is supposed to conflict with
wicd-curses and which I remember purposefully not installing.



apt-cache show wicd shows you that version 1.7.0-3 does not conflict
with wicd-client.



But the upgrade asked to remove wicd so I just took that.



Yes, remove the 1.7.0-2 version.


The install succeeded but threw errors attached below. Have I gotten myself
into something here? (Some script-heavy packages can be hard to back out
of.) I also have python errors in apt-listchanges.



I ran into the same problem going from a working 1.6.2.2-4 wicd on
amd64 bit testing. As I do not do an aptitude autoclean, I simply
removed the, none working, 1.7.0-3 and then used dpkg to install the

1.6.2.2-4 from the archives directory.

With the current problems in squeeze/Sid I think autoclean is not an
good option to use.


On amd64 the 1.7.0-2 package did not work either. I falsely assumed
that wicd 1.7.0-3 package worked on AMD62 as it was now
wicd_1.7.0-3_all.deb. I was wrong. David has some more work to do, it
seems.


I think you mean the apt-listbugs package has ruby errors.
apt-cache version 0.1.1 seems to be working here.

HTH

Wayne


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Freeman 02-04-2010 01:34 AM

Glitch-y wicd-curses Install
 
On Wed, Feb 03, 2010 at 10:51:42AM -0500, Wayne <linuxtwo@gmail.com> wrote:
> evenso@worldwidehtml.com wrote:
> >Upgrading wicd-curses 1.7.0-2 to 1.7.0-3 with aptitude on squeeze.
> >
> >First I noticed that wicd was installed, which is supposed to conflict with
> >wicd-curses and which I remember purposefully not installing.
> >
>
> apt-cache show wicd shows you that version 1.7.0-3 does not conflict
> with wicd-client.
>
> >But the upgrade asked to remove wicd so I just took that.
> >
>
> Yes, remove the 1.7.0-2 version.
>
> >The install succeeded but threw errors attached below. Have I gotten myself
> >into something here? (Some script-heavy packages can be hard to back out
> >of.) I also have python errors in apt-listchanges.
> >
>
> I ran into the same problem going from a working 1.6.2.2-4 wicd on
> amd64 bit testing. As I do not do an aptitude autoclean, I simply
> removed the, none working, 1.7.0-3 and then used dpkg to install the
> 1.6.2.2-4 from the archives directory.
>
> With the current problems in squeeze/Sid I think autoclean is not an
> good option to use.
>
> On amd64 the 1.7.0-2 package did not work either. I falsely assumed
> that wicd 1.7.0-3 package worked on AMD62 as it was now
> wicd_1.7.0-3_all.deb. I was wrong. David has some more work to do,
> it seems.
>
> I think you mean the apt-listbugs package has ruby errors.
> apt-cache version 0.1.1 seems to be working here.
>

Nope, I like both but apt-listchanges is the one throwing python errors.

Anyway, since those install errors, I haven't had a problem yet. So I am
going ahead with it!

--
Kind Regards,
Freeman


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org


All times are GMT. The time now is 01:13 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.