FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian User

 
 
LinkBack Thread Tools
 
Old 01-29-2010, 05:55 AM
Thierry Chatelet
 
Default wicd fails to start after upgrade

On Friday 29 January 2010 02:31:38 Sebastian wrote:
> Hi all!
>
> After the last upgrade wicd fails to start. It also stopped writing it's
> logs and when I call it directly by just entering 'wicd' I get following
> error:
>
>
> Sebastian
>

Same here. Reinstalled wicd and wicd-gtk. Everything OK now.
Thierry


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 01-29-2010, 07:04 AM
Vincent Lefevre
 
Default wicd fails to start after upgrade

On 2010-01-29 01:31:38 +0000, Sebastian wrote:
> Hi all!
>
> After the last upgrade wicd fails to start. It also stopped writing it's logs and when I call it directly by just entering 'wicd' I get following error:
>
> Traceback (most recent call last):
> File "/usr/share/wicd/daemon/wicd-daemon.py", line 61, in <module>
> from wicd.logfile import ManagedStdio
> ImportError: No module named logfile

I have no such problem with wicd 1.7.0-2 (from unstable).

--
Vincent Lefèvre <vincent@vinc17.net> - Web: <http://www.vinc17.net/>
100% accessible validated (X)HTML - Blog: <http://www.vinc17.net/blog/>
Work: CR INRIA - computer arithmetic / Arénaire project (LIP, ENS-Lyon)


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 01-29-2010, 05:31 PM
Sebastian
 
Default wicd fails to start after upgrade

On Thu, Jan 28, 2010 at 09:27PM -0500, Wayne <linuxtwo@gmail.com> wrote:
> Sebastian wrote:
>>
>> After the last upgrade wicd fails to start. It also stopped writing it's logs and when I call it directly by just entering 'wicd' I get following error:
>>
>> Traceback (most recent call last):
>> File "/usr/share/wicd/daemon/wicd-daemon.py", line 61, in <module>
>> from wicd.logfile import ManagedStdio
>> ImportError: No module named logfile
>>
>> I tried purging and re-installing it but to no avail...
>> Should I file this as a bug or is it just me not seeing something obvious?
>
> Can't really say as you forgot to tell us what you are running on and
> which version of wicd isn't working.
>

Ah yeah, sorry...

I'm running squeeze/sid (apt prefers testing) mainly testing yet I am
a bit confused as I can only seem to find version 1.7.0-2 of wicd on
my system but packages.debian.org states that the current testing
version is 1.6.2.2-4 and testing is 1.7.0-2 (my version). I tried
removing it and re-installing with 'apt-get install wicd=1.6.2.2-4'
with the reply: E: Version '1.6.2.2-4' for 'wicd' was not found?!?

Even if I remove the unstable and stable entries from sources.list and
apt/preferences no other versions show up

Is there a good way of checking from which repository an installed
package is, by the way?

TIA, Sebastian


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 01-29-2010, 06:36 PM
"Wayne
 
Default wicd fails to start after upgrade

Sebastian wrote:

On Thu, Jan 28, 2010 at 09:27PM -0500, Wayne <linuxtwo@gmail.com> wrote:

Sebastian wrote:

After the last upgrade wicd fails to start. It also stopped writing it's logs and when I call it directly by just entering 'wicd' I get following error:

Traceback (most recent call last):
File "/usr/share/wicd/daemon/wicd-daemon.py", line 61, in <module>
from wicd.logfile import ManagedStdio
ImportError: No module named logfile

I tried purging and re-installing it but to no avail...
Should I file this as a bug or is it just me not seeing something obvious?
Can't really say as you forgot to tell us what you are running on and
which version of wicd isn't working.




Ah yeah, sorry...

I'm running squeeze/sid (apt prefers testing) mainly testing yet I am
a bit confused as I can only seem to find version 1.7.0-2 of wicd on
my system but packages.debian.org states that the current testing
version is 1.6.2.2-4 and testing is 1.7.0-2 (my version). I tried
removing it and re-installing with 'apt-get install wicd=1.6.2.2-4'
with the reply: E: Version '1.6.2.2-4' for 'wicd' was not found?!?


I also run testing/sid and my wicd is from testing.

You might(?) want to try 'aptitude -t testing install wicd' after you
remove your current wicd sid package (not purge). That will bull in a


Just did an update and 'apt-cache show wicd'. Note: I have squeeze and
unstable in my sources.list. Your 1.7.0-2 version does not use the
python packages that 1.6.2.2-4 does.


Strange, I see that there is a python-wicd 1.7.0-2 package in unstable
but it is not shown as Depends in wicd 1.7.0-2 package. Wonder what that
is about???



Even if I remove the unstable and stable entries from sources.list and
apt/preferences no other versions show up


I would not put all 3 dists in sources.list. That could/would cause
quite some mess. testing/unstable is bad enough but you should be
careful using it. If I even 'think' about pulling in an unstable
package, and it's dependices, I first run apt-listbugs on all of those
packages before I download any of them


Is there a good way of checking from which repository an installed

package is, by the way?


Yes 'apt-cache policy wicd' will show the packages in every dist you
have in the sources.list, I believe. Here it shows both testing/unstable.


Hope this helps

Wayne


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 01-30-2010, 12:07 AM
Vincent Lefevre
 
Default wicd fails to start after upgrade

On 2010-01-29 14:36:03 -0500, Wayne <linuxtwo@gmail.com> wrote:
> Strange, I see that there is a python-wicd 1.7.0-2 package in unstable
> but it is not shown as Depends in wicd 1.7.0-2 package. Wonder what
> that is about???

wicd 1.7.0-2 depends on wicd-daemon 1.7.0-2, which depends on
python-wicd 1.7.0-2. There's nothing wrong with that.

--
Vincent Lefèvre <vincent@vinc17.net> - Web: <http://www.vinc17.net/>
100% accessible validated (X)HTML - Blog: <http://www.vinc17.net/blog/>
Work: CR INRIA - computer arithmetic / Arénaire project (LIP, ENS-Lyon)


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 01-30-2010, 12:46 AM
"Wayne
 
Default wicd fails to start after upgrade

Vincent Lefevre wrote:

On 2010-01-29 14:36:03 -0500, Wayne <linuxtwo@gmail.com> wrote:

Strange, I see that there is a python-wicd 1.7.0-2 package in unstable
but it is not shown as Depends in wicd 1.7.0-2 package. Wonder what
that is about???


wicd 1.7.0-2 depends on wicd-daemon 1.7.0-2, which depends on
python-wicd 1.7.0-2. There's nothing wrong with that.



Your right. I didn't check all of the various depend's. I just pointed
it out to Sabastian. If your running wicd in Sid maybe you have an idea
'why' it isn't running then.


Wayne


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 01-30-2010, 10:44 AM
Sebastian
 
Default wicd fails to start after upgrade

On Fri, Jan 29, 2010 at 02:36PM -0500, Wayne <linuxtwo@gmail.com> wrote:

> >>Sebastian wrote:
> >>>After the last upgrade wicd fails to start. It also stopped writing it's logs and when I call it directly by just entering 'wicd' I get following error:
> >>>
> >>>Traceback (most recent call last):
> >>> File "/usr/share/wicd/daemon/wicd-daemon.py", line 61, in <module>
> >>> from wicd.logfile import ManagedStdio
> >>>ImportError: No module named logfile
> >>>
> >>>I tried purging and re-installing it but to no avail...
> >>>Should I file this as a bug or is it just me not seeing something obvious?
> >
> >I'm running squeeze/sid (apt prefers testing) mainly testing yet I am
> >a bit confused as I can only seem to find version 1.7.0-2 of wicd on
> >my system but packages.debian.org states that the current testing
> >version is 1.6.2.2-4 and testing is 1.7.0-2 (my version). I tried
> >removing it and re-installing with 'apt-get install wicd=1.6.2.2-4'
> >with the reply: E: Version '1.6.2.2-4' for 'wicd' was not found?!?
>
> I also run testing/sid and my wicd is from testing.
>
> >Even if I remove the unstable and stable entries from sources.list and
> >apt/preferences no other versions show up
>
> I would not put all 3 dists in sources.list. That could/would cause
> quite some mess. testing/unstable is bad enough but you should be
> careful using it. If I even 'think' about pulling in an unstable
> package, and it's dependices, [...snip...]

I thought if you set up apt-pinning in /etc/apt/preferences that
should be possible without any major problems?

> [...snip...]
> I first run apt-listbugs on all of
> those packages before I download any of them
>

Yes, I have apt-listbugs installed and working here as well, yet I
can't remember any bugs for wicd coming up before the upgrade - of
course it was late in the night and who knows what I was seeing ;-)

Anyway, I removed unstable from the sources.list and tried removing
and re-installing wicd but I can still only get 1.7.0-2

>
> Yes 'apt-cache policy wicd' will show the packages in every dist you
> have in the sources.list, I believe. Here it shows both
> testing/unstable.
>

thanks, 'apt-cache policy wicd' shows
wicd:
Installed: 1.7.0-2
Candidate: 1.7.0-2
Version table:
*** 1.7.0-2 0
700 http://ftp.ie.debian.org testing/main Packages
100 /var/lib/dpkg/status

hmmm... 1.7.0-2 is testing??? And no 1.6...?
Getting more and more confused here... - Any hints?

> Hope this helps
>
> Wayne

Thanx a mil Wayne

Sebastian

--
A man of genius makes no mistakes.
His errors are volitional and are the portals of discovery.
-- James Joyce, "Ulysses"


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 01-30-2010, 02:43 PM
"Wayne
 
Default wicd fails to start after upgrade

Sebastian wrote:

On Fri, Jan 29, 2010 at 02:36PM -0500, Wayne <linuxtwo@gmail.com> wrote:


Sebastian wrote:

After the last upgrade wicd fails to start. It also stopped writing it's logs and when I call it directly by just entering 'wicd' I get following error:


<---Snip--->



[...snip...]
I first run apt-listbugs on all of
those packages before I download any of them



Yes, I have apt-listbugs installed and working here as well, yet I
can't remember any bugs for wicd coming up before the upgrade - of
course it was late in the night and who knows what I was seeing ;-)

Anyway, I removed unstable from the sources.list and tried removing
and re-installing wicd but I can still only get 1.7.0-2


Yes 'apt-cache policy wicd' will show the packages in every dist you
have in the sources.list, I believe. Here it shows both
testing/unstable.



thanks, 'apt-cache policy wicd' shows
wicd:
Installed: 1.7.0-2
Candidate: 1.7.0-2
Version table:
*** 1.7.0-2 0
700 http://ftp.ie.debian.org testing/main Packages
100 /var/lib/dpkg/status

hmmm... 1.7.0-2 is testing??? And no 1.6...?
Getting more and more confused here... - Any hints?
]


Humm.... After removing unstable from sources.list did you do another
aptitude update?

I just did another update, here it is:
VT/dev/pts/0 wtopa@dj-SQUEEZE]
~$ policy wicd
wicd:
Installed: 1.6.2.2-4
Candidate: 1.7.0-2
Version table:
1.7.0-2 0
990 http://mirrors.geeks.org squeeze/main Packages
600 http://mirror.rit.edu unstable/main Packages
*** 1.6.2.2-4 0
100 /var/lib/dpkg/status
Note that I have aliased apt-cache policy in my .bashrc
as policy.

It seems that wicd has migrated to squeeze/testing since we started this
discussion. One thing I have noticed in the last 4-6 months though is
that there seems to be more packages entering testing that fail
apt-listbugs then there used to be.


So to test that, I tried apt-listbugs, which I recall had it's own bugs
after my last upgrade. ;_( I had to upgrade it, again now, to test my
theory so... Note my alias for apt-listbugs used here:


[VT/dev/pts/0 wtopa@dj-SQUEEZE]
~$ bugs list wicd=1.6.2.2-4 wicd=1.7.0-2
Reading package fields... Done
Reading package status... Done
Retrieving bug reports... Done
Parsing Found/Fixed information... Done

That says that both versions should work. To see which one will be
installed I did


aptitude -s install wicd

Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
Reading task descriptions... Done
The following NEW packages will be installed:
python-wicd{a} wicd-daemon{a} wicd-gtk{a}
The following packages will be REMOVED:
python-urwid{u}
The following packages will be upgraded:
wicd
1 packages upgraded, 3 newly installed, 1 to remove and 12 not upgraded.

That is version 1.7.0-2.

As I am not having a problem with my current version, I won't upgrade
wicd for a while. You, on the other hand, can do an aptitude update and
then safe-upgrade and, it might have been fixed. I say might because it
just migrated and I am leery of packages coming into testing, as I
mentioned above.



Thanx a mil Wayne


No problem Sabestian, just hope it goes well for you, this time.

Wayne



--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 01-30-2010, 03:08 PM
"Boyd Stephen Smith Jr."
 
Default wicd fails to start after upgrade

In <20100130114447.GA2955@hexbrex.tri>, Sebastian wrote:
>On Fri, Jan 29, 2010 at 02:36PM -0500, Wayne <linuxtwo@gmail.com> wrote:
>> >Even if I remove the unstable and stable entries from sources.list and
>> >apt/preferences no other versions show up
>>
>> I would not put all 3 dists in sources.list. That could/would cause
>> quite some mess. testing/unstable is bad enough but you should be
>> careful using it.
>
>I thought if you set up apt-pinning in /etc/apt/preferences that
>should be possible without any major problems?

You've got to remember a few things when running a mixed system:

1. Debian policy is to maintain the ABI for libraries that keep the same
SONAME, but sometimes packages headed for unstable/experimental break this,
usually unintentionally. If it is an important library, this can really mess
with your system stability (i.e. lack of crashes).

2. Downgrades are not supported, and can't really be. Once you've pulled in a
package from testing/unstable you can't go back, and as that package has new
version released, it may gradually need more dependencies from
testing/unstable. For some packages you can PURGE and then reinstall a lower
version, but doing the purge can be difficult if you have other packages that
depend on it. I've done some normal package downgrades before, but I got
lucky and they worked; I wouldn't recommend them to anyone.

3. Just because a package says it will work with the libraries in stable
doesn't always mean it will. Humans do the packaging and they make mistakes.
Since most packages are uploaded to unstable (and migrate to testing/stable
through other means), they are tested against a pure unstable system. Even
packages that are uploaded specifically to testing (rare) or stable(-proposed-
updates), aren't tested on a mixed system, but rather a pure testing or pure
stable system.

4. apt-listbugs is your friend, particularly when you are upgrading a package
from stable -> testing or testing -> unstable. You don't have to let every
bug hold you back, but you should be selective about which bugs you install.

5. apt-cache policy is invaluable in making sure your /etc/apt/preferences
file is provided the level of "mix" you want.

In short, you are in potentially dangerous and completely unsupported waters.
The mix of testing/unstable is fairly well tested and documented in
apt_preferences(5). Using stable + backports is very safe, even without
pinning (backports pins itself to priority 1). Using unstable + experimental
is how experimental was designed (it doesn't have every package) so it is as
safe as using "experimental" packages ever is.

Something like my stable/backports/testing/unstable/experimental mix is well
beyond unsupported, at least in theory. In practice it has been no harder to
maintain that any other Debian system, and I've been able to use the same
resources I ever did.

I recommend it for advanced users that are comfortable working with the
interactive dependency resolver in aptitude, but with the warnings above in
mind.
--
Boyd Stephen Smith Jr. ,= ,-_-. =.
bss@iguanasuicide.net ((_/)o o(\_))
ICQ: 514984 YM/AIM: DaTwinkDaddy `-'(. .)`-'
http://iguanasuicide.net/ \_/
 
Old 01-31-2010, 05:28 PM
"Wayne
 
Default wicd fails to start after upgrade

Sebastian wrote:

On Fri, Jan 29, 2010 at 02:36PM -0500, Wayne <linuxtwo@gmail.com> wrote:


Sebastian wrote:

After the last upgrade wicd fails to start. It also stopped writing it's logs and when I call it directly by just entering 'wicd' I get following error:

Traceback (most recent call last):
File "/usr/share/wicd/daemon/wicd-daemon.py", line 61, in <module>
from wicd.logfile import ManagedStdio
ImportError: No module named logfile



<--- snip --->


Yes, I have apt-listbugs installed and working here as well, yet I
can't remember any bugs for wicd coming up before the upgrade - of
course it was late in the night and who knows what I was seeing ;-)

Anyway, I removed unstable from the sources.list and tried removing
and re-installing wicd but I can still only get 1.7.0-2


Yes 'apt-cache policy wicd' will show the packages in every dist you
have in the sources.list, I believe. Here it shows both
testing/unstable.



thanks, 'apt-cache policy wicd' shows
wicd:
Installed: 1.7.0-2
Candidate: 1.7.0-2
Version table:
*** 1.7.0-2 0
700 http://ftp.ie.debian.org testing/main Packages
100 /var/lib/dpkg/status

hmmm... 1.7.0-2 is testing??? And no 1.6...?
Getting more and more confused here... - Any hints


Sebastian

I just finished setting up another testing box with wireless, an
old Netgear WPN311 pci card. Using the madwifi ath5k modules.

I installed wicd 1.7.0-2 and, after fixing some of my usual typo's,
it is running as good ad the old 1.6 version.

HTH
Wayne


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 

Thread Tools




All times are GMT. The time now is 12:17 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org