FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian User

 
 
LinkBack Thread Tools
 
Old 01-08-2008, 01:43 AM
Roberto Alejandro Espi Muñoz
 
Default problem restarting services ...

Hi ... I'm having problems in my Debian Etch ( made with debootstrap ) to restart two services in particular. One is apache2, I issue:

# /etc/init.d/apache2 start

And it does nothing, and when I call it by:

# apache2

It starts. I can't manage also to start the sudo init.d script that way. In another pc installed from the installation discs everything works fine. My guess is that since debootstrap doesn't install much of the programs that the other one does ( sudo for example ), I'm missing something ...

Can anybody help me?
Thanks
 
Old 01-08-2008, 01:53 AM
Kumar Appaiah
 
Default problem restarting services ...

On Mon, Jan 07, 2008 at 09:43:49PM -0500, Roberto Alejandro Espi Muñoz wrote:
> Hi ... I'm having problems in my Debian Etch ( made with debootstrap ) to restart two services in particular. One is apache2, I issue:
>
> # /etc/init.d/apache2 start
>
> And it does nothing, and when I call it by:
>
> # apache2
>
> It starts. I can't manage also to start the sudo init.d script that way. In another pc installed from the installation discs everything works fine. My guess is that since debootstrap doesn't install much of the programs that the other one does ( sudo for example ), I'm missing something ...

Please check the contents of /etc/default/apache2. It should have
NO_START=0.

(Just a guess).

HTH.

Kumar
--
Kumar Appaiah,
458, Jamuna Hostel,
Indian Institute of Technology Madras,
Chennai - 600 036
 
Old 01-08-2008, 02:34 AM
Roberto Alejandro Espi Muñoz
 
Default problem restarting services ...

Thanks it worked. Now I know something new. Still the same for sudo though


-----Original Message-----
From: Kumar Appaiah [mailto:akumar@iitm.ac.in]
Sent: Mon 1/7/2008 9:53 pm
To: debian-user@lists.debian.org
Subject: Re: problem restarting services ...

On Mon, Jan 07, 2008 at 09:43:49PM -0500, Roberto Alejandro Espi Muñoz wrote:
> Hi ... I'm having problems in my Debian Etch ( made with debootstrap ) to restart two services in particular. One is apache2, I issue:
>
> # /etc/init.d/apache2 start
>
> And it does nothing, and when I call it by:
>
> # apache2
>
> It starts. I can't manage also to start the sudo init.d script that way. In another pc installed from the installation discs everything works fine. My guess is that since debootstrap doesn't install much of the programs that the other one does ( sudo for example ), I'm missing something ...

Please check the contents of /etc/default/apache2. It should have
NO_START=0.

(Just a guess).

HTH.

Kumar
--
Kumar Appaiah,
458, Jamuna Hostel,
Indian Institute of Technology Madras,
Chennai - 600 036
 

Thread Tools




All times are GMT. The time now is 02:39 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org