FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian User

 
 
LinkBack Thread Tools
 
Old 01-22-2010, 08:26 PM
Hans Ekbrand
 
Default wpa_supplicant returns too early to ifup? Scripts in /etc/if-up.d executed before network is ready

I recently switch to wpa_supplicant (earlier I used ifup and ifdown
manually). Now, scripts in /etc/if-up.d/ are executed before the net
is ready (so the scripts fail).

Does anyone here at debian-user recognise this problem?

Here is my /etc/network/interfaces

-------------------------
auto ath0
iface ath0 inet manual
wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf

iface work inet dhcp
wpa-driver wext

iface home inet dhcp
wpa-driver wext
-------------------------

--
Note that I use Debian version 5.0.3
Linux esset 2.6.26-2-686 #1 SMP Wed Nov 4 20:45:37 UTC 2009 i686 GNU/Linux
Hans Ekbrand (http://sociologi.cjb.net) <hans@sociologi.cjb.net>
Q. What is that strange attachment in this mail?
A. My digital signature, see www.gnupg.org for info on how you could
use it to ensure that this mail is from me and has not been
altered on the way to you.
 

Thread Tools




All times are GMT. The time now is 03:21 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org