FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian User

 
 
LinkBack Thread Tools
 
Old 01-20-2010, 01:37 PM
Nuno MagalhĂŁes
 
Default modprobe vboxdrv failed (virtualbox-ose 3.1.2-dfsg-1+b1)

Greetings,

Ever since the latest kernel update i can't run VirtualBox. I've seen
some scarce posts, all with the same issue, but no solution. I've
tried installing through the .deb on VBs site, it even used dkms to
build a driver, but i still can't run virtualbox. So i purger
everything virtualbox-* and started over.

# aptitude install virtualbox-ose virtualbox-ose-qt virtualbox-guest-additions

Then i get these:
Stopping VirtualBox kernel modules.
Starting VirtualBox kernel modulesmodprobe vboxdrv failed. Please use
'dmesg' to find out why ... failed!

# dmesg |tail
vboxdrv: disagrees about version of symbol module_layout

I have *vboxdrv* in the following directories:

/var/lib/dkms/vboxdrv/3.1.2
/var/lib/dkms/vboxdrv/kernel-2.6.32-trunk-amd64-x86_64
/var/lib/update-rc.d/vboxdrv

VBox does run but when i start any VM it throws pop-ups at me saying:
"Failed to open a session for the virtual machine XP Pro x32 en SP3.
Virtual machine 'XP Pro x32 en SP3' has terminated unexpectedly during startup.
Result Code:
NS_ERROR_FAILURE (0x80004005)
Component:
Machine
Interface:
IMachine {99404f50-dd10-40d3-889b-dd2f79f1e95e}"

And
"Kernel driver not installed (rc=-1908)
Please install the virtualbox-ose-dkms package and execute 'modprobe
vboxdrv' as root."

Which i did:
# aptitude install virtualbox-ose-dkms

And it tries doing a bunch of stuff [1], but i guess i still have a
driver laying around? Either way, it thinks the driver's good and it
still fails:
Running DKMS auto installation service for kernel 2.6.32-trunk-amd64:
vboxnetflt (3.1.2)...failed.
vboxdrv (3.1.2)...failed.
vboxnetadp (3.1.2)...failed

# modprobe vboxdrv
WARNING: All config files need .conf: /etc/modprobe.d/alsa-fix, it
will be ignored in a future release.
FATAL: Error inserting vboxdrv
(/lib/modules/2.6.32-trunk-amd64/updates/dkms/vboxdrv.ko): Invalid
module format

# cat /etc/modules
loop
sbp2

So i'm kinda stranded. Any suggestions? i'm running Sid, the kernel's
2.6.32-trunk-amd64. It would appear the driver's borked, but that's
beyond me.

TIA,
Nuno

[1] http://pastebin.com/m6d0b6021

--
() ascii-rubanda kampajno - kontraĆ* html-a retpoƝto
/ ascii ribbon campaign - against html e-mail


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 01-20-2010, 05:39 PM
Ole Toft Jensen
 
Default modprobe vboxdrv failed (virtualbox-ose 3.1.2-dfsg-1+b1)

On Wed, Jan 20, 2010 at 02:37:45PM +0000, Nuno Magalhăes wrote:
> Greetings,
>
> # dmesg |tail
> vboxdrv: disagrees about version of symbol module_layout
Greetings,

This means that your vboxdrv module is not compiled for your current
kernel version, so you will have to use module-assistant to fix that.

--
Med venlig hilsen / Best regards,
Ole Toft Jensen ole@24gold.dk


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 01-20-2010, 06:35 PM
Peter Hillier-Brook
 
Default modprobe vboxdrv failed (virtualbox-ose 3.1.2-dfsg-1+b1)

On 20/01/2010 18:39, Ole Toft Jensen wrote:

On Wed, Jan 20, 2010 at 02:37:45PM +0000, Nuno Magalhăes wrote:

Greetings,

# dmesg |tail
vboxdrv: disagrees about version of symbol module_layout

Greetings,

This means that your vboxdrv module is not compiled for your current
kernel version, so you will have to use module-assistant to fix that.


It sounds as if dkms hasn't been installed. There is a reference
somewhere on the VirtualBox web site.


Peter HB


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 01-20-2010, 07:38 PM
Florian Kriener
 
Default modprobe vboxdrv failed (virtualbox-ose 3.1.2-dfsg-1+b1)

On Wednesday 20 January 2010 20:35:15 Peter Hillier-Brook wrote:
> >> # dmesg |tail
> >> vboxdrv: disagrees about version of symbol module_layout
> >
> > Greetings,
> >
> > This means that your vboxdrv module is not compiled for your
> > current kernel version, so you will have to use module-assistant to
> > fix that.
>
> It sounds as if dkms hasn't been installed. There is a reference
> somewhere on the VirtualBox web site.

You could be wrong, because I had exactly the same problem. After a
kernel update (from ..-n to ..-n+1 - I don't know the exact versions)
the module would not load anymore. I guess it's a bug in either the
kernel package, in not raising the right version number (i.e. new
package name), or in dkms for not updating the modules. However the
problem solved itself after the next kernel update.


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 01-21-2010, 12:14 PM
Nuno MagalhĂŁes
 
Default modprobe vboxdrv failed (virtualbox-ose 3.1.2-dfsg-1+b1)

On Wed, Jan 20, 2010 at 20:38, Florian Kriener <florian@kriener.org> wrote:
> On Wednesday 20 January 2010 20:35:15 Peter Hillier-Brook wrote:
>> >> # dmesg |tail
>> >> vboxdrv: disagrees about version of symbol module_layout
>> >
>> > Greetings,
>> >
>> > This means that your vboxdrv module is not compiled for your
>> > current kernel version, so you will have to use module-assistant to
>> > fix that.

I thought that was what dkms was for.

>> It sounds as if dkms hasn't been installed. There is a reference
>> somewhere on the VirtualBox web site.

It was installed, the pastebin dump is mostly the post-script of the
dkms installation. It compiles the driver, but wont modprobe it.

> You could be wrong, because I had exactly the same problem. After a
> kernel update (from ..-n to ..-n+1 - I don't know the exact versions)
> the module would not load anymore. I guess it's a bug in either the
> kernel package, in not raising the right version number (i.e. new
> package name), or in dkms for not updating the modules. However the
> problem solved itself after the next kernel update.

That was my first guess and i tried going to the previous kernel, but
it didn't work then 'cos i didn't have dkms i guess. It's now working
with 2.6.31-1-amd64, after using dpkg-reconfigure on the dkms package.

Thanks,
Nuno

--
() ascii-rubanda kampajno - kontraĆ* html-a retpoƝto
/ ascii ribbon campaign - against html e-mail


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 01-22-2010, 12:28 PM
Jacek Politowski
 
Default modprobe vboxdrv failed (virtualbox-ose 3.1.2-dfsg-1+b1)

On Wed, Jan 20, 2010 at 09:38:58PM +0100, Florian Kriener wrote:

>> It sounds as if dkms hasn't been installed. There is a reference
>> somewhere on the VirtualBox web site.

>You could be wrong, because I had exactly the same problem. After a
>kernel update (from ..-n to ..-n+1 - I don't know the exact versions)
>the module would not load anymore.

Same here. After kernel upgrade (some time ago) vboxdrv failed to
load. Reinstalling virtualbox-ose-dkms (after purge!) didn't help
either.

I had to manually remove modules from
/lib/modules/2.6.32-trunk-686/updates/dkms/ (they weren't, removed
even on purge, neither were they updated on kernel upgrade).

After that, recompilation by dkms succeeded.


--
Jacek Politowski


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 

Thread Tools




All times are GMT. The time now is 01:25 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org