FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian User

 
 
LinkBack Thread Tools
 
Old 01-17-2010, 09:27 PM
Nuno MagalhĂŁes
 
Default Upgrade wants too many packages (X and apache).

Greetings,

My latest apt-get update; apt-get dist-upgrade wants to install too
much cruft for me, namely apache2-mpm-prefork and *all* the
xserver-xorg-video-* packages, along with some others. Usually it just
wants to install one or two, keep a few and upgrade a bunch.

I don't know why would any package depend specifically on apache
instead of on a webserver (which i have), and apt-cache rdepends
didn't show me anything interesting. The only package i have that
could remotely ring a bell would be apache2-utils (i have it for
htpasswd), but it doesn't depend on apache.

Also, i have xserver-xorg-video-nv and xserver-xorg-video-fbdev, why
would apt want to install xserver-xorg-video-all?!

TIA,
Nuno

--
() ascii-rubanda kampajno - kontraĆ* html-a retpoƝto
/ ascii ribbon campaign - against html e-mail


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 01-18-2010, 12:34 AM
Stephen Powell
 
Default Upgrade wants too many packages (X and apache).

On 2010-01-17 at 17:27:52 -0500, Nuno Magalhăes wrote:
> My latest apt-get update; apt-get dist-upgrade wants to install too
> much cruft for me, namely apache2-mpm-prefork and *all* the
> xserver-xorg-video-* packages, along with some others. Usually it just
> wants to install one or two, keep a few and upgrade a bunch.

You haven't said whether you are running Lenny, Squeeze, or Sid,
but I've heard that there has been a change in the package management
system fairly recently that will cause it to treat recommendations
as dependencies. Try the --no-install-recommends option when you run
apt-get dist-upgrade. For example,

apt-get --no-install-recommends dist-upgrade

and see if that makes a difference.


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 01-18-2010, 12:38 AM
Nuno MagalhĂŁes
 
Default Upgrade wants too many packages (X and apache).

On Mon, Jan 18, 2010 at 01:34, Stephen Powell <zlinuxman@wowway.com> wrote:
>
> You haven't said whether you are running Lenny, Squeeze, or Sid,

Oh... Sid actually.

> apt-get --no-install-recommends dist-upgrade

Nope, same result... thanks though.

--
() ascii-rubanda kampajno - kontraĆ* html-a retpoƝto
/ ascii ribbon campaign - against html e-mail


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 01-18-2010, 01:04 AM
Andrew Sackville-West
 
Default Upgrade wants too many packages (X and apache).

> On 2010-01-17 at 17:27:52 -0500, Nuno Magalhăes wrote:

> > My latest apt-get update; apt-get dist-upgrade wants to install
> > [...] *all* the xserver-xorg-video-* packages,

you should probably be using aptitude, but regardless, you have
installed, at some point, xserver-xorg-video-all, which depends on all
the video-* packages. remove that package and directly install the
drivers you actually need.

A
 
Old 01-18-2010, 12:25 PM
Nuno MagalhĂŁes
 
Default Upgrade wants too many packages (X and apache).

On Mon, Jan 18, 2010 at 02:04, Andrew Sackville-West
<andrew@farwestbilliards.com> wrote:
> you should probably be using aptitude, but regardless, you have
> installed, at some point, xserver-xorg-video-all, which depends on all
> the video-* packages. remove that package and directly install the
> drivers you actually need.

I've been meaning to change to aptitude since that's the current
default package manager (and seems to be better), but i'm considering
doing it after a fresh reinstall (i need to repartition and maybe use
lvm and raid). If i start using it now won't there be conflicts with
what apt has done so far, i.e. do aptitude and apt both agree on
dependencies and what not?

For X, because i dislike having all drivers installed, when i setup
Debian i chose no desktop task and installed X manually (having to
re/configure Xorg.conf, as usual), making sure i first installed
xserver-xorg-video-nv (as well as input stuff) before i installed the
core packages. I have no *-all installed. These are the packages i
have:
x11-xserver-utils
xserver-common
xserver-xorg
xserver-xorg-core
xserver-xorg-input-evdev
xserver-xorg-input-kbd
xserver-xorg-input-mouse
xserver-xorg-video-fbdev
xserver-xorg-video-nv

So, xserver-xorg-core should not need the *-all package. Besides, i've
been dist-upgrading for ages and X never complained, so why start now?

And packages depending directly on apache instead of on an httpd? I've
installed nagios3 and then purged it, that's where apache-utils came
from. But now i've purged them both. These would be the only ones what
would be related to a webserver.

So, if i change now to aptitude will all my problems be solved?

--
() ascii-rubanda kampajno - kontraĆ* html-a retpoƝto
/ ascii ribbon campaign - against html e-mail


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 01-18-2010, 12:35 PM
Andrei Popescu
 
Default Upgrade wants too many packages (X and apache).

On Mon,18.Jan.10, 13:25:59, Nuno Magalhăes wrote:

> So, if i change now to aptitude will all my problems be solved?

No, but it might help you find the real problem. Try

aptitude why <package>

to see why a package would be installed.

It is also safe to switch to aptitude now, it shouldn't conflict with
apt-get, but be aware that it will remove not needed auto-installed
packages, whereas apt-get will wait for you to issue an 'autoremove'.

Regards,
Andrei
--
Offtopic discussions among Debian users and developers:
http://lists.alioth.debian.org/mailman/listinfo/d-community-offtopic
 
Old 01-18-2010, 01:08 PM
Nuno MagalhĂŁes
 
Default Upgrade wants too many packages (X and apache).

Ok, i'm getting somewhere:

# aptitude why apache2-mpm-prefork
i php-mdb2 Depends php-pear (>= 5.2.0-8)
p php-pear Depends php5-common (>=
5.2.12.dfsg.1-2)
p A php5-common Recommends php5-suhosin
i A php5-suhosin Depends phpapi-20060613
p libapache2-mod-php5filter Provides phpapi-20060613
p libapache2-mod-php5filter Depends apache2-mpm-prefork (>
2.0.52) | apache2-mpm-itk

So in order to have sohosin i need to have apache?

# aptitude why xserver-xorg-video-all
i xserver-xorg Depends xserver-xorg-video-all | xserver-xorg-video-5

Why is X now depending on a virtual package that provides a bunch of
drivers, when all i need is one of them?! Anyway,
xserver-xorg-video-nv provides xserver-xorg-video-5, so this shouldn't
happen.

--
() ascii-rubanda kampajno - kontraĆ* html-a retpoƝto
/ ascii ribbon campaign - against html e-mail


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 01-18-2010, 02:26 PM
Nuno MagalhĂŁes
 
Default Upgrade wants too many packages (X and apache).

Well using aptitude safe-upgrade didn't prompt for any x- or
apache-related packages.

Thanks,
Nuno

--
() ascii-rubanda kampajno - kontraĆ* html-a retpoƝto
/ ascii ribbon campaign - against html e-mail


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 01-18-2010, 04:26 PM
"Boyd Stephen Smith Jr."
 
Default Upgrade wants too many packages (X and apache).

On Sunday 17 January 2010 16:27:52 Nuno Magalhăes wrote:
> I don't know why would any package depend specifically on apache
> instead of on a webserver (which i have), and apt-cache rdepends
> didn't show me anything interesting.

Try (aptitude why $package_it_wants_to_install) or (aptitude why-not
$package_it_wants_to_remove).

Some might only be recommendations, but its certainly possible that new
versions of packages you are currently using have added more dependencies.
--
Boyd Stephen Smith Jr. ,= ,-_-. =.
bss@iguanasuicide.net ((_/)o o(\_))
ICQ: 514984 YM/AIM: DaTwinkDaddy `-'(. .)`-'
http://iguanasuicide.net/ \_/
 
Old 01-18-2010, 07:30 PM
Tony Nelson
 
Default Upgrade wants too many packages (X and apache).

On 10-01-18 09:08:45, Nuno Magalhăes wrote:
> Ok, i'm getting somewhere:
>
> # aptitude why apache2-mpm-prefork
> i php-mdb2 Depends php-pear (>= 5.2.0-8)
> p php-pear Depends php5-common (>=
> 5.2.12.dfsg.1-2)
> p A php5-common Recommends php5-suhosin
> i A php5-suhosin Depends phpapi-20060613
> p libapache2-mod-php5filter Provides phpapi-20060613
> p libapache2-mod-php5filter Depends apache2-mpm-prefork (>
> 2.0.52) | apache2-mpm-itk
>
> So in order to have sohosin i need to have apache?
...

Or you need to not install the "recommends".

--
__________________________________________________ __________________
TonyN.:' <mailto:tonynelson@georgeanelson.com>
' <http://www.georgeanelson.com/>


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 

Thread Tools




All times are GMT. The time now is 12:57 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org