FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian User

 
 
LinkBack Thread Tools
 
Old 01-06-2008, 12:49 PM
Hugo Vanwoerkom
 
Default X warning messages, why?

Hi,

I have cleaned up my xorg.conf and now only get 2 warning messages:

(WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
Entry deleted from font path.
(WW) The directory "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
does not exist.



I do not specify a fontpath.

Anybody know why?

I attach the cleaned up xorg.conf.

Hugo
# 01/06/08 - Works with 96.43.01 but had to switch [101]
# - Cleanup of stuff that causes errors
# - Only these warnings now:
# (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
# (WW) The directory "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType" does not exist.
# |_. Device |_. Me |_. Her |
# | *Card* | PCI440 | AGP4000 |
# | *Monitor* | mon1 | mon0 |
# | *Server* | X1 | X0 |
# | *Driver* | nvidia1 | nvidia0 |
# | *Mouse* | mouse1 event6 2ndmouse | mouse0 event5 1stmouse |
# | *Keyboard* | keyboard1 event0 1st kbd | keyboard0 event1 2nd kbd |
Section "ServerLayout"
Identifier "X0"
Screen 0 "Screen X0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "ServerLayout"
Identifier "X1"
Screen 0 "Screen X1" 0 0
InputDevice "Mouse1" "CorePointer"
InputDevice "Keyboard1" "CoreKeyboard"
# Option "BlankTime" "3600"
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection

Section "ServerLayout"
Identifier "Xinerama"
Screen "Screen x0"
Screen "Screen x1" Rightof "Screen x0"
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
ModulePath "/usr/X11R6/lib/modules/"
ModulePath "/usr/lib/xorg/modules/"
EndSection

Section "Module"
Load "dbe"
# turned on 11/15/06!
Load "dri"
Load "extmod"
Load "glx"
Load "record"
Load "freetype"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "evdev"
Option "Device" "/dev/input/event1" #[101]
# Option "Phys" "isa0060/serio1/input0" #[101]
Option "XkbLayout" "us_intl"
Option "Xleds" "2 3"
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "evdev"
Option "Device" "/dev/input/event0" #[101]
# Option "Phys" "isa0060/serio0/input0" #[101]
Option "XkbLayout" "us_intl"
Option "Xleds" "2 3"
EndSection

#http://www.linux-gamers.net/modules/wiwimod/index.php?page=HOWTO+Mouse+Buttons
Section "InputDevice"
Identifier "Mouse0"
Driver "evdev"
Option "Device" "/dev/input/event5" # (cat /proc/bus/input/devices)
# Option "Device" "/dev/input/event3" # (cat /proc/bus/input/devices)
# Option "Device" "/dev/input/event4" # for vin's system
Option "Name" "A4Tech USB Optical Mouse"
Option "ZAxisMapping" "6 7 4 5"
# Option "Emulate3Buttons" "true"
Option "Buttons" "12"
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "evdev"
Option "Device" "/dev/input/event6" # (cat /proc/bus/input/devices)
# Option "Device" "/dev/input/event4" # (cat /proc/bus/input/devices)
# Option "Device" "/dev/input/event5" # for vin's system
Option "Name" "A4Tech USB Optical Mouse"
Option "ZAxisMapping" "6 7 4 5"
Option "Buttons" "12"
EndSection


Section "Monitor"
Identifier "Monitor0"
VendorName "SAM"
ModelName "1057"
Option "DPMS"
HorizSync 30.0 - 70.0
VertRefresh 50.0 - 160.0
EndSection

Section "Monitor"
Identifier "Monitor1"
VendorName "SAM"
ModelName "1057"
Option "DPMS"
HorizSync 30.0 - 70.0
VertRefresh 50.0 - 160.0
EndSection

Section "Device"
### Available Driver options are:-
### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
### [arg]: arg optional
#Option "SWcursor" # [<bool>]
#Option "HWcursor" # [<bool>]
#Option "NoAccel" # [<bool>]
#Option "ShowCache" # [<bool>]
#Option "ShadowFB" # [<bool>] HVW
#Option "UseFBDev" # [<bool>]
#Option "Rotate" "CW" # [<str>] HVW
#Option "VideoKey" # <i>
#Option "FlatPanel" # [<bool>]

Option "AllowGLXWithComposite" "On"
Option "RenderAccel" "True"

Option "NvAGP" "0"
Identifier "nvidia0"
Driver "nvidia"
# Driver "nv"
VendorName "NVidia"
# BoardName "RIVA TNT2 Model 64/Model 64 Pro"
BoardName "GeForce4 MX 4000 AGP 8x"
BusID "PCI:1:0:0"
EndSection

Section "Device"
### Available Driver options are:-
### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
### [arg]: arg optional
#Option "SWcursor" # [<bool>]
#Option "HWcursor" # [<bool>]
#Option "NoAccel" # [<bool>]
#Option "ShowCache" # [<bool>]
#Option "ShadowFB" # [<bool>] HVW
#Option "UseFBDev" # [<bool>]
#Option "Rotate" "CW" # [<str>] HVW
#Option "VideoKey" # <i>
#Option "FlatPanel" # [<bool>]

Option "AllowGLXWithComposite" "On"
Option "RenderAccel" "True"
Option "RandRRotation" "1"
Option "NvAGP" "0"

Identifier "nvidia1"
Driver "nvidia"
# Driver "nv"
VendorName "NVidia"
BoardName "GeForce4 MX 440 AGP 8x"
BusID "PCI:0:10:0"
EndSection

Section "Screen"
Identifier "Screen X0"
Device "nvidia0"
Monitor "Monitor0"
# DefaultColorDepth 16 #Added... Colors looked off...
DefaultColorDepth 24
SubSection "Display"
Depth 1
Modes "1280x1024"
EndSubSection
SubSection "Display"
Depth 4
Modes "1280x1024"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x1024"
EndSubSection
SubSection "Display"
Depth 15
Modes "1280x1024"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024"
EndSubSection
EndSection

Section "Screen"
Identifier "Screen X1"
Device "nvidia1"
Monitor "Monitor1"
# DefaultColorDepth 16 #Added... Colors looked off...
DefaultColorDepth 24
SubSection "Display"
Depth 1
Modes "1280x1024"
EndSubSection
SubSection "Display"
Depth 4
Modes "1280x1024"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x1024"
EndSubSection
SubSection "Display"
Depth 15
Modes "1280x1024"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024"
# Modes "1680x1050"
EndSubSection
EndSection
 
Old 01-06-2008, 03:36 PM
Hugo Vanwoerkom
 
Default X warning messages, why?

Hugo Vanwoerkom wrote:

Hi,

I have cleaned up my xorg.conf and now only get 2 warning messages:

(WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
Entry deleted from font path.
(WW) The directory "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
does not exist.



I do not specify a fontpath.

Anybody know why?


2nd one goes away when you install x-ttcidfont-conf and then run
mkfontdir /var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType

1st one I don't know yet.

Hugo


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 01-06-2008, 04:23 PM
Michael Shuler
 
Default X warning messages, why?

On 01/06/2008 10:36 AM, Hugo Vanwoerkom wrote:

Hugo Vanwoerkom wrote:

(WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
Entry deleted from font path.
(WW) The directory "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
does not exist.


2nd one goes away when you install x-ttcidfont-conf and then run
mkfontdir /var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType

1st one I don't know yet.


$ apt-file search /usr/share/fonts/X11/cyrillic
xfonts-cyrillic: usr/share/fonts/X11/cyrillic/crox1c.pcf.gz
(...)

--
Kind Regards,
Michael Shuler


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 

Thread Tools




All times are GMT. The time now is 01:38 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org