FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian User

 
 
LinkBack Thread Tools
 
Old 01-05-2008, 07:04 PM
David Jantzen
 
Default ATI X1600 Radeon Missing 1600x1050 Resolution After "fglrx" Upgrade

Hey All,

I installed some upgrades yesterday to my testing/unstable installation.
The relevant packages changed (as far as I understand) were:

fglrx-control
fglrx-driver
fglrx-kernel-src

Apt uninstalled my kernel module compiled for 3D support, and so I
recompiled and installed again from the new source with

m-a a-i fglrx

After reboot, my only usable resolution (1600x1050) is unavailable.
Even the Catalyst control center believes it's not there. Xorg.conf was
unchanged, so I doubt that was it.

Any ideas on the cause? Suggestions? I can certainly live without 3D
support if the solution is to revert to the kernel module from Apt,
although I'd need some direction on how to do that.

Thanks!
David


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 01-05-2008, 07:48 PM
Michael Shuler
 
Default ATI X1600 Radeon Missing 1600x1050 Resolution After "fglrx" Upgrade

On 01/05/2008 02:04 PM, David Jantzen wrote:

After reboot, my only usable resolution (1600x1050) is unavailable.


Perhaps this item from the release notes:

Known Issues
- Connecting a display device that supports 1680x1050 to a system
running Linux may result in a maximum display resolution of 1280x1024
only being available


https://a248.e.akamai.net/f/674/9206/0/www2.ati.com/drivers/linux/catalyst_712_linux.html#183417

--
Michael


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 01-06-2008, 11:29 AM
Georgi Naplatanov
 
Default ATI X1600 Radeon Missing 1600x1050 Resolution After "fglrx" Upgrade

David Jantzen wrote:

Hey All,

I installed some upgrades yesterday to my testing/unstable installation.
The relevant packages changed (as far as I understand) were:

fglrx-control
fglrx-driver
fglrx-kernel-src

Apt uninstalled my kernel module compiled for 3D support, and so I
recompiled and installed again from the new source with


m-a a-i fglrx

After reboot, my only usable resolution (1600x1050) is unavailable.
Even the Catalyst control center believes it's not there. Xorg.conf was
unchanged, so I doubt that was it.

Any ideas on the cause? Suggestions? I can certainly live without 3D
support if the solution is to revert to the kernel module from Apt,
although I'd need some direction on how to do that.

Thanks!
David




Hello, David

in case you use amd64 branch can you show your xorg.conf file, because
my X did't start after installing fglrx-driver-8.44.3-1.


It stopped with following error:

(II) fglrx(0): Supported Future Video Modes:
(II) fglrx(0): #0: hsize: 1280 vsize 720 refresh: 60 vid: 49281
(II) fglrx(0): #1: hsize: 1280 vsize 960 refresh: 60 vid: 16513
(II) fglrx(0): #2: hsize: 1152 vsize 864 refresh: 60 vid: 16497
(II) fglrx(0): #3: hsize: 1280 vsize 1024 refresh: 60 vid: 32897
(II) fglrx(0): #4: hsize: 1440 vsize 900 refresh: 60 vid: 149
(II) fglrx(0): Supported additional Video Mode:
(II) fglrx(0): clock: 106.5 MHz Image Size: 410 x 256 mm
(II) fglrx(0): h_active: 1440 h_sync: 1520 h_sync_end 1672 h_blank_end
1904 h_border: 0
(II) fglrx(0): v_active: 900 v_sync: 903 v_sync_end 909 v_blanking:
934 v_border: 0

(II) fglrx(0): Serial No: 5053D0010001
(II) fglrx(0): Ranges: V min: 56 V max: 75 Hz, H min: 31 H max: 81
kHz, PixClock max 140 MHz

(II) fglrx(0): Monitor name: L9VB4
(II) fglrx(0): EDID (in hex):
(II) fglrx(0): 00ffffffffffff005e74880301010101
(II) fglrx(0): 1410010380291a782ac905a3574b9c25
(II) fglrx(0): 125054a54b0081c08140714081809500
(II) fglrx(0): 0101010101019a29a0d0518422305098
(II) fglrx(0): 36009a001100001c000000ff00353035
(II) fglrx(0): 3344303031303030310a000000fd0038
(II) fglrx(0): 4b1f510e000a202020202020000000fc
(II) fglrx(0): 004c395642340a2020202020202000a5
(II) fglrx(0): End of Display1 EDID data --------------------
(WW) fglrx(0): Only one display is connnected,so single mode is enabled
(EE) fglrx(0): PreInitDAL failed

Regards
Georgi



--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 

Thread Tools




All times are GMT. The time now is 04:42 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org