Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Debian User (http://www.linux-archive.org/debian-user/)
-   -   X11 not displaying clearly (http://www.linux-archive.org/debian-user/28561-x11-not-displaying-clearly.html)

Patter 01-04-2008 09:59 AM

X11 not displaying clearly
 
I'm a long-time debian user, running unstable with gdm and collcted
programs from gnome & kde. I rebooted my system this morning and the X
display has gone weird (there's no better way to put this as you'll see
in the screenshot http://patter.mine.nu/screen.jpg ).

Fluxbox looks OK with the right font and by pure luck xterms
(gnome-terminal) are fine but anything else looks like a poor mosaic
(some font selections make gnome-terminal look the same).

I've run a full update with unstable & the etch security updates but
that hasn't fixed it. Does anyone have any suggestions?

--
Stephen Patterson :: steve@patter.mine.nu :: http://patter.mine.nu/
GPG: B416F0DE :: Jabber: patter@jabber.earth.li
"Don't be silly, Minnie. Who'd be walking round these cliffs with a gas oven?"


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Florian Kulzer 01-04-2008 12:12 PM

X11 not displaying clearly
 
On Fri, Jan 04, 2008 at 10:59:54 +0000, Patter wrote:
> I'm a long-time debian user, running unstable with gdm and collcted
> programs from gnome & kde. I rebooted my system this morning and the X
> display has gone weird (there's no better way to put this as you'll see
> in the screenshot http://patter.mine.nu/screen.jpg ).
>
> Fluxbox looks OK with the right font and by pure luck xterms
> (gnome-terminal) are fine but anything else looks like a poor mosaic
> (some font selections make gnome-terminal look the same).
>
> I've run a full update with unstable & the etch security updates but
> that hasn't fixed it. Does anyone have any suggestions?

Which video card and which driver are you using?

Did you try to run Xorg with the vesa driver? This might tell you
if the problem is connected to the graphics driver or if it is a general
fond rendering issue.

--
Regards, | http://users.icfo.es/Florian.Kulzer
Florian |


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

"Chris Howie" 01-04-2008 01:05 PM

X11 not displaying clearly
 
On Jan 4, 2008 8:12 AM, Florian Kulzer <florian.kulzer+debian@icfo.es> wrote:

Did you try to run Xorg with the vesa driver? This might tell you
if the problem is connected to the graphics driver or if it is a general
fond rendering issue.

I'm not so sure this is related to fonts at all, since bitmaps are being drawn with the same effect.* It looks suspiciously like someone is setting a stencil that everything gets drawn with.* (Not saying that's what it is, but that's really what comes to mind.)

--
Chris Howie
http://www.chrishowie.com
http://en.wikipedia.org/wiki/User:Crazycomputers


All times are GMT. The time now is 01:18 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.