FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian User

 
 
LinkBack Thread Tools
 
Old 11-22-2009, 02:30 PM
Martin Kraus
 
Default i915 kms, init runlevel 2 switches virtual console

Hi. I'm using debian testing with vanilla kernel 2.6.32-rc8. I've staticaly
compiled i915 with kms enabled and it acctually works. The only thing that
annoyes me is that after init runs runlevel 2, it automatically switches to vt
4 (I have only 4 vt running from init) a continues boot messages there. I'm
not sure what does that, I'm suspecting console-setup of doing that.

Is this happening to anyone else? Before I dig into console documentation to
learn how it works to fix it. I guess that is going to be time consuming.

Also, kernel switches the required video mode a bit later then vesafb did. Is
there a way to set this on the kernel command line? I've read that it is
recommended to get rid of the vga=<mode>. I've tried setting this via video=
parameter, but I guess inteldrmfb doesn't support modedb. The vga= probably
uses vesa mode that isn't part of the fbcon. However, I know almost nothing
about how that actually works. It would be just a nice thing to have the
correct mode set right from the start.

thanks for any pointers

mk


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 

Thread Tools




All times are GMT. The time now is 12:02 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org