Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Debian User (http://www.linux-archive.org/debian-user/)
-   -   asterisk-1.6.2 broken on debian squeeze (http://www.linux-archive.org/debian-user/279804-asterisk-1-6-2-broken-debian-squeeze.html)

Rustam Kovhaev 11-13-2009 07:27 AM

asterisk-1.6.2 broken on debian squeeze
 
Hello there,
It's been broken for 2 months already. Does anybody know when it's
gonna be fixed and what is the problem exactly?
Thanks!


--
Regards,
Rustam Kovhaev


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Tzafrir Cohen 11-15-2009 04:57 AM

asterisk-1.6.2 broken on debian squeeze
 
On Fri, Nov 13, 2009 at 11:27:56AM +0300, Rustam Kovhaev wrote:
> Hello there,
> It's been broken for 2 months already.

What do you mean by "broken"? Could you please be more specific?

--
Tzafrir Cohen | tzafrir@jabber.org | VIM is
http://tzafrir.org.il | | a Mutt's
tzafrir@cohens.org.il | | best
ICQ# 16849754 | | friend


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Rustam Kovhaev 11-15-2009 08:23 AM

asterisk-1.6.2 broken on debian squeeze
 
when I try to aptitude asterisk, it tells me that
package asterisk is Broken

aptitude install asterisk
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
Reading task descriptions... Done
The following packages are BROKEN:
asterisk
The following NEW packages will be installed:
asterisk-config{a} asterisk-sounds-main{a} cvs{a} dahdi{a} dahdi-linux{a}
debhelper{a} freetds-common{a} fxload{a} gettext{a} html2text{a}
intltool-debian{a} libc-client2007b{a} libfile-copy-recursive-perl{a}
libgmime-2.0-2a{a} libiksemel3{a} libmail-sendmail-perl{a} libperl5.10{a}
libpri1.4{a} libradiusclient-ng2{a} libsnmp-base{a} libsnmp15{a}
libspandsp1{a} libspeexdsp1{a} libsqlite0{a} libss7-1{a} libsybdb5{a}
libsys-hostname-long-perl{a} libtonezone2.0{a} libvpb0{a} mlock{a}
module-assistant{a} po-debconf{a} update-inetd{a} vpb-driver-source{a}
0 packages upgraded, 35 newly installed, 0 to remove and 0 not upgraded.
Need to get 17.8MB of archives. After unpacking 43.9MB will be used.
The following packages have unmet dependencies:
asterisk: Depends: libopenais2 (>= 0.83) which is a virtual package.
The following actions will resolve these dependencies:

Keep the following packages at their current version:
asterisk [Not Installed]

Leave the following dependencies unresolved:
asterisk-config recommends asterisk
asterisk-sounds-main recommends asterisk
Score is -10281

Accept this solution? [Y/n/q/?] q



On 11/15/09, Tzafrir Cohen <tzafrir@cohens.org.il> wrote:
> On Fri, Nov 13, 2009 at 11:27:56AM +0300, Rustam Kovhaev wrote:
>> Hello there,
>> It's been broken for 2 months already.
>
> What do you mean by "broken"? Could you please be more specific?
>
> --
> Tzafrir Cohen | tzafrir@jabber.org | VIM is
> http://tzafrir.org.il | | a Mutt's
> tzafrir@cohens.org.il | | best
> ICQ# 16849754 | | friend
>
>
> --
> To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
> with a subject of "unsubscribe". Trouble? Contact
> listmaster@lists.debian.org
>
>


--
Regards,
Rustam Kovhaev


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Michael Wagner 11-15-2009 03:59 PM

asterisk-1.6.2 broken on debian squeeze
 
* Rustam Kovhaev <rkovhaev@gmail.com> 15.11.2009
> when I try to aptitude asterisk, it tells me that
> package asterisk is Broken
>
> aptitude install asterisk
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> Reading extended state information
> Initializing package states... Done
> Reading task descriptions... Done
> The following packages are BROKEN:
> asterisk
> The following NEW packages will be installed:
> asterisk-config{a} asterisk-sounds-main{a} cvs{a} dahdi{a} dahdi-linux{a}
> debhelper{a} freetds-common{a} fxload{a} gettext{a} html2text{a}
> intltool-debian{a} libc-client2007b{a} libfile-copy-recursive-perl{a}
> libgmime-2.0-2a{a} libiksemel3{a} libmail-sendmail-perl{a} libperl5.10{a}
> libpri1.4{a} libradiusclient-ng2{a} libsnmp-base{a} libsnmp15{a}
> libspandsp1{a} libspeexdsp1{a} libsqlite0{a} libss7-1{a} libsybdb5{a}
> libsys-hostname-long-perl{a} libtonezone2.0{a} libvpb0{a} mlock{a}
> module-assistant{a} po-debconf{a} update-inetd{a} vpb-driver-source{a}
> 0 packages upgraded, 35 newly installed, 0 to remove and 0 not upgraded.
> Need to get 17.8MB of archives. After unpacking 43.9MB will be used.
> The following packages have unmet dependencies:
> asterisk: Depends: libopenais2 (>= 0.83) which is a virtual package.
> The following actions will resolve these dependencies:
>
> Keep the following packages at their current version:
> asterisk [Not Installed]
>
> Leave the following dependencies unresolved:
> asterisk-config recommends asterisk
> asterisk-sounds-main recommends asterisk
> Score is -10281
>
> Accept this solution? [Y/n/q/?] q

Hello Rustam,

the package 'libopenais2' exists only in the stable archiv. So put the
lines for stable in your /etc/apt/sources.list and try to install again.
And if you have problems like the above one, you can always try another
solution from aptitude. Don't hit 'q', but hit the 'n' key and aptitude
will suggest you another solution.

Hth Michael

PS: Please don't top post.

--
I don't use drugs, my dreams are frightening enough.
M.C. Escher

Frank Lin PIAT 11-16-2009 07:11 AM

asterisk-1.6.2 broken on debian squeeze
 
Hello Rustam,

On Sun, 2009-11-15 at 17:59 +0100, Michael Wagner wrote:
> * Rustam Kovhaev <rkovhaev@gmail.com> 15.11.2009
> > when I try to aptitude asterisk, it tells me that
> > package asterisk is Broken
> >
> > aptitude install asterisk
[..]
> > The following packages have unmet dependencies:
> > asterisk: Depends: libopenais2 (>= 0.83) which is a virtual package.

>
> the package 'libopenais2' exists only in the stable archiv. So put the
> lines for stable in your /etc/apt/sources.list and try to install again.
> And if you have problems like the above one, you can always try another
> solution from aptitude. Don't hit 'q', but hit the 'n' key and aptitude
> will suggest you another solution.

FYI,

You can search for you package in
http://packages.debian.org

Then you can compare the dependencies in stable/squeeze/sid.
As you can see, the maintainer is working on a new version in unstable,
which don't depends on 'libopenais2' (but 'libopenais3').

Now, if you wonder why that version isn't in squeeze yet, you should
click on the link "Developer Information (PTS)". On that page, click on
the link "Check Why" (in the "problems" section). That page[2]
explains that the new version of asterisk is waiting for package uw-imap
(because asterisk depends on libc-client2007e).
uw-imap can only enter squeeze only once all packages that depends on
it's library have been updated to use the new version.

Unfortunately, some packages haven't been updated and uploaded yet (And
once all those new packages are 10 days old, the transition will be able
to occur).

Franklin

[2] http://release.debian.org/migration/testing.pl?package=asterisk


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org


All times are GMT. The time now is 07:08 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.