Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Debian User (http://www.linux-archive.org/debian-user/)
-   -   aptitude tries to reach mirrors via IPv6 (http://www.linux-archive.org/debian-user/276508-aptitude-tries-reach-mirrors-via-ipv6.html)

Vasiliy Faronov 11-07-2009 01:15 PM

aptitude tries to reach mirrors via IPv6
 
(I am not subscribed to this list. Please Cc me when replying.)

Hello,

I have IPv4 only connectivity, and IPv6 is entirely disabled in my
systems, by aliasing "ipv6" to "off" in /etc/modprobe.d/aliases and by
blacklisting "ipv6" in /etc/modprobe.d/blacklist. The IPv6-related
entries in /etc/hosts have been removed.

However, if I use a Debian archive mirror with IPv6 addresses, aptitude
sometimes tries to reach that mirror (for package list updates or
package downloads) via IPv6, fails with a message like "could not open
socket", and does not re-try on other (IPv4) addresses. Thereby the
entire download operation fails. This doesn't happen every time; the
choice of the address to download from seems to be somewhat random.

I don't know if this also affects apt-get, because I generally don't use
apt-get, and the problem is hard to reproduce. However, I have no other
IPv6-related problems on my systems. (I mainly use the GNOME desktop.)

Is it possible to prevent aptitude from trying IPv6?

--
Vasiliy Faronov


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Barış Balta 12-29-2009 02:14 PM

aptitude tries to reach mirrors via IPv6
 
Hi,

Just remove ipv6 specific lines in /etc/hosts file and try again.

I had the same problem and this worked for me.

Regards

Barış Balta


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Vasiliy Faronov 12-30-2009 09:30 AM

aptitude tries to reach mirrors via IPv6
 
On Втр, 2009-12-29 at 17:14 +0200, Barış Balta wrote:
> Just remove ipv6 specific lines in /etc/hosts file and try again.
>
> I had the same problem and this worked for me.

Thank you for your suggestion, Barış.

However, I don't have any IPv6 entries in my /etc/hosts.
I removed them shortly after installing the system.

--
Vasiliy Faronov


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org


All times are GMT. The time now is 08:15 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.