FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian User

 
 
LinkBack Thread Tools
 
Old 01-03-2008, 12:32 PM
Hugo Vanwoerkom
 
Default Workaround for bug 44477: xserver-xorg: "Xorg crashes with nvidia proprietary driver (during allocation)"

Hi,

In trying to solve my mouse foibles (previous post) I upgraded
xserver-xorg-core on my Sid box.


That upgrades xorg to 7.3.

Starting X with the proprietary Nvidia driver 9631 one runs into bug 44477.

The answer that was given to that bug ("don't use that driver") gets
tiresome: I don't use 9631 because I like to, but because I have to, and
we can go OT on that: nv does not compare to nvidia in most situations
but the simplest.


For those getting the message:

(EE) NVIDIA(0): ============= WARNING WARNING WARNING WARNING =============
(EE) NVIDIA(0): This server has a video driver ABI version of 2.0 but this
(EE) NVIDIA(0): driver is designed to work with versions before 2.0.
(EE) NVIDIA(0): Please check http://www.nvidia.com/ for driver
updates or

(EE) NVIDIA(0): downgrade to an X server with a supported driver ABI.
(EE) NVIDIA(0): ================================================== =========

a reported workaround is starting X with the option -ignoreABI.

I'll report back if that is true.

Hugo


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 01-06-2008, 11:47 AM
Hugo Vanwoerkom
 
Default Workaround for bug 44477: xserver-xorg: "Xorg crashes with nvidia proprietary driver (during allocation)"

Hugo Vanwoerkom wrote:

Hi,

In trying to solve my mouse foibles (previous post) I upgraded
xserver-xorg-core on my Sid box.


That upgrades xorg to 7.3.

Starting X with the proprietary Nvidia driver 9631 one runs into bug 44477.

The answer that was given to that bug ("don't use that driver") gets
tiresome: I don't use 9631 because I like to, but because I have to, and
we can go OT on that: nv does not compare to nvidia in most situations
but the simplest.


For those getting the message:

(EE) NVIDIA(0): ============= WARNING WARNING WARNING WARNING =============
(EE) NVIDIA(0): This server has a video driver ABI version of 2.0 but this
(EE) NVIDIA(0): driver is designed to work with versions before 2.0.
(EE) NVIDIA(0): Please check http://www.nvidia.com/ for driver
updates or

(EE) NVIDIA(0): downgrade to an X server with a supported driver ABI.
(EE) NVIDIA(0): ================================================== =========

a reported workaround is starting X with the option -ignoreABI.



That turned out to be false. But it got resolved by installing the
latest legacy driver:

ftp://download.nvidia.com/XFree86/Linux-x86/96.43.01

and I had to modify the keyboard input section for the evdev driver from
"Phys" to "Device", who know why.


Hugo


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 

Thread Tools




All times are GMT. The time now is 01:03 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org