FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian User

 
 
LinkBack Thread Tools
 
Old 01-03-2008, 10:02 AM
Florian Kulzer
 
Default mutt and utf-8 (was: character encoding)

On Thu, Jan 03, 2008 at 13:50:59 +1300, Chris Bannister wrote:

[...]

> I've found that if I generate an utf-8 locale it messes up the little
> arrows in mutt's index.

Sometimes the locale settings do not get passed on to mutt correctly,
depending on how mutt is started. I think the best test is to use "!" to
run "locale" from within mutt. Does that show all settings are correct?

> Also a lot of manpages don't show correctly.

That could be a terminal or font problem (see below); sometimes,
however, the manpages themselves are to blame.

> I have to set LC_CTYPE to a non utf-8 locale.
>
> But I wonder if it is also the choice of console font.

Try these simple tests:

echo -e "303244"

should give you an "ä" (lowercase a-umlaut) on a utf-8 terminal. If you
see two characters instead it means that your terminal does not use
utf-8. If you get one "placeholder" symbol, e.g. an empty square or a
question mark, then your font does not provide the a-umlaut character.

The a-umlaut is not a particularly fancy character, so you should also
try this:

echo -e "342224224342224200076"

should give you "└─>" (mutt's arrow showing a reply in a thread).

--
Regards, | http://users.icfo.es/Florian.Kulzer
Florian |
 

Thread Tools




All times are GMT. The time now is 05:11 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org