FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian User

 
 
LinkBack Thread Tools
 
Old 11-22-2007, 02:59 AM
"David Fox"
 
Default ffmpeg encoding issues & AAC

Guys,

I do quite a bit of video encoding / audio encoding in debian lenny,
and oftentimes I use tovid (tovid.sourceforge.net) to do the encoding,
usually with good results.

But recently I have had a problem with ffmpeg when I attempt to encode
what looks like a 5.1 channel aac file that's part of an mp4 video, it
tells me that it can't do the encode, that encoding more than 2
channels is not supported. The upshot is that I may have to find
another tool to extract the audio portion of the mp4 file, and then
downmix it to two channels, then resample to ac3 dvd standard audio
format.

So are there any ffrmpeg experts that can help me ?

First, ffmpeg is on lenny, like so:


dfox@m206-157:/tmp/Star Trek 8 - First Contact
[x264.AAC.5.1.subs.DrJ]$ apt-cache policy ffmpeg
ffmpeg:
Installed: 3:20070917-0.0
Candidate: 3:20070917-0.0
Version table:
*** 3:20070917-0.0 0
990 http://debian-multimedia.org testing/main Packages
100 /var/lib/dpkg/status
0.cvs20070307-6 0
990 http://ftp.debian.org testing/main Packages
600 http://ftp.debian.org sid/main Packages

dfox@m206-157:/tmp/Star Trek 8 - First Contact [x264.AAC.5.1.subs.DrJ]$


ffmpeg is called thusly:


dfox@m206-157:/tmp/Star Trek 8 - First Contact
[x264.AAC.5.1.subs.DrJ]$ ffmpeg -i Star Trek 8 - First Contact
[x264.AAC.5.1.subs.DrJ].mp4 -vn -ab 224k -ar 48000 -acodec ac3 -y
foo.ac3
FFmpeg version SVN-rUNKNOWN, Copyright (c) 2000-2007 Fabrice Bellard, et al.
configuration: --prefix=/usr --libdir=${prefix}/lib
--shlibdir=${prefix}/lib --incdir=${prefix}/include/ffmpeg
--enable-shared --enable-libmp3lame --enable-gpl --enable-libfaad
--mandir=${prefix}/share/man --enable-libvorbis --enable-pthreads
--enable-libfaac --enable-libxvid --enable-pp --enable-libamr-nb
--enable-libamr-wb --enable-x11grab --enable-libogg --enable-libgsm
--enable-libx264 --enable-liba52 --enable-libtheora
--extra-cflags=-Wall -g -fPIC -DPIC --cc=ccache cc --enable-swscaler
libavutil version: 49.5.0
libavcodec version: 51.44.0
libavformat version: 51.13.3
built on Sep 17 2007 15:29:56, gcc: 4.2.1 (Debian 4.2.1-5)
Input #0, mov,mp4,m4a,3gp,3g2,mj2, from 'Star Trek 8 - First Contact
[x264.AAC.5.1.subs.DrJ].mp4':
Duration: 01:46:09.1, start: 0.000000, bitrate: 1390 kb/s
Stream #0.0(und): Video: h264, yuv420p, 704x416, 25.00 fps(r)
Stream #0.1(eng): Audio: mpeg4aac, 48000 Hz, 5:1
Stream #0.2(ger): Audio: mpeg4aac, 48000 Hz, 5:1
Stream #0.3(eng): Data: tx3g / 0x67337874
Stream #0.4(ger): Data: tx3g / 0x67337874
Stream #0.5(dan): Data: tx3g / 0x67337874
Stream #0.6(dut): Data: tx3g / 0x67337874
Stream #0.7(fin): Data: tx3g / 0x67337874
Stream #0.8(ces): Audio: mpeg4aac, 48000 Hz, stereo
Stream #0.9(hun): Audio: mpeg4aac, 48000 Hz, stereo
Stream #0.10(nor): Data: tx3g / 0x67337874
Stream #0.11(swe): Data: tx3g / 0x67337874
Stream #0.12(tur): Data: tx3g / 0x67337874
Stream #0.13(pol): Audio: mpeg4aac, 48000 Hz, stereo
Resampling with input channels greater than 2 unsupported.Can't resample. Abort

I think the AAC may be part of the problem here?


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 

Thread Tools




All times are GMT. The time now is 07:14 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org