FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian User

 
 
LinkBack Thread Tools
 
Old 03-02-2009, 07:46 PM
"Boyd Stephen Smith Jr."
 
Default Disappearing Devices

On Monday 02 March 2009 12:26:54 Robert Latest wrote:
> Another curious thing: I tried to make some framebuffer devices in
> /dev (as described in the HOWTO), but they get deleted on reboot!
> Since when gets stuff deleted from /dev?

On modern Linux systems (using udev), /dev is generally mounted as tmpfs so
it only exists in RAM and goes away each boot. You should be able to write
udev rules to create "static" devices on udev startup, but I'm not sure.
Most udev rules are responsible for creating device nodes based on hardware
discovery.

> Did my system go haywire somehow, or could this have to do with its
> being the "testing" branch?

I used udev with Etch, so it did not surprise me during the move to Lenny.
(I doubt it has changed in Squeeze; "udev" is quite powerful and I haven't
heard of any upcoming replacements.)

I'm not sure if Etch required the use of udev, but I'm fairly sure Lenny
does.
--
Boyd Stephen Smith Jr. ,= ,-_-. =.
bss@iguanasuicide.net ((_/)o o(\_))
ICQ: 514984 YM/AIM: DaTwinkDaddy `-'(. .)`-'
http://iguanasuicide.net/ \_/
 

Thread Tools




All times are GMT. The time now is 12:15 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org