FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian User

 
 
LinkBack Thread Tools
 
Old 02-11-2009, 08:21 PM
Harry Putnam
 
Default VirtualBox on lenny

Googling about virtualbox on debian.. I see only older information.
Looks like the wiki at http://wiki.debian.org/VirtualBox
Appear to be somewhat old too and only goes up to etch. Other stuff
shows its from 2007. I know VirtualBox is under very active
development so wondered if things may have changed since that wiki was
posted.

aptitude search virtualbox shows a bewildering array of packages with
virutalbox in the name... but I see no version numbers.

Anyway, is there a recent outline about how to do this somewhere?

Or any posters here have VirtualBox running on lenny that can say how
they did it?



--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 02-22-2009, 04:28 AM
Paul Fraser
 
Default VirtualBox on lenny

On Thu, Feb 12, 2009 at 07:21, Harry Putnam <reader@newsguy.com> wrote:
> Or any posters here have VirtualBox running on lenny that can say how
> they did it?

I'd recommend installing VirtualBox from experimental -- 2.1.2 is the
latest version, as opposed to 1.6.6 available elsewhere.


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 02-22-2009, 05:24 AM
Harry Putnam
 
Default VirtualBox on lenny

Paul Fraser <pfraser@zone12.net> writes:

> On Thu, Feb 12, 2009 at 07:21, Harry Putnam <reader@newsguy.com> wrote:
>> Or any posters here have VirtualBox running on lenny that can say how
>> they did it?
>
> I'd recommend installing VirtualBox from experimental -- 2.1.2 is the
> latest version, as opposed to 1.6.6 available elsewhere.

Sorry to be so thick, but can you point me to something that explains
how to access `experimental'

And further... what packages are required? I noticed quite a long
list with aptitude search


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 02-22-2009, 07:06 AM
Umarzuki Mochlis
 
Default VirtualBox on lenny

2009/2/22 Harry Putnam <reader@newsguy.com>

Paul Fraser <pfraser@zone12.net> writes:



> On Thu, Feb 12, 2009 at 07:21, Harry Putnam <reader@newsguy.com> wrote:

>> Or any posters here have VirtualBox running on lenny that can say how

>> they did it?

>

> I'd recommend installing VirtualBox from experimental -- 2.1.2 is the

> latest version, as opposed to 1.6.6 available elsewhere.



Sorry to be so thick, but can you point me to something that explains

how to access `experimental'



And further... what packages are required? *I noticed quite a long

list with aptitude searchTry installing from virtualbox own repo to get the latest (2.1.4). Check http://www.virtualbox.org/wiki/Linux_Downloads







--

To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org

with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org





--
Regards,

Umarzuki Mochlis
http://gameornot.net
 
Old 02-22-2009, 10:28 AM
Magnus Therning
 
Default VirtualBox on lenny

Harry Putnam wrote:
> Googling about virtualbox on debian.. I see only older information.
> Looks like the wiki at http://wiki.debian.org/VirtualBox
> Appear to be somewhat old too and only goes up to etch. Other stuff
> shows its from 2007. I know VirtualBox is under very active
> development so wondered if things may have changed since that wiki was
> posted.
>
> aptitude search virtualbox shows a bewildering array of packages with
> virutalbox in the name... but I see no version numbers.
>
> Anyway, is there a recent outline about how to do this somewhere?
>
> Or any posters here have VirtualBox running on lenny that can say how
> they did it?

Depending on where you land on the proprietary vs. free scale you might
be comfortable with using the proprietary version of VirtualBox (after
reading the license carefully so you know whether your usage is covered,
of course). They have a repo for it:

deb http://download.virtualbox.org/virtualbox/debian lenny non-free

/M

--
Magnus Therning (OpenPGP: 0xAB4DFBA4)
magnus´╝*therning´╝Äorg Jabber: magnus´╝*therning´╝Äorg
http://therning.org/magnus identi.ca|twitter: magthe

Haskell is an even 'redder' pill than Lisp or Scheme.
-- PaulPotts
 
Old 02-22-2009, 11:16 AM
Alex Samad
 
Default VirtualBox on lenny

On Sun, Feb 22, 2009 at 04:06:55PM +0800, Umarzuki Mochlis wrote:
> 2009/2/22 Harry Putnam <reader@newsguy.com>
>
> > Paul Fraser <pfraser@zone12.net> writes:
> >
> > > On Thu, Feb 12, 2009 at 07:21, Harry Putnam <reader@newsguy.com> wrote:
> > >> Or any posters here have VirtualBox running on lenny that can say how
> > >> they did it?
> > >
> > > I'd recommend installing VirtualBox from experimental -- 2.1.2 is the
> > > latest version, as opposed to 1.6.6 available elsewhere.
> >
> > Sorry to be so thick, but can you point me to something that explains
> > how to access `experimental'
> >
> > And further... what packages are required? I noticed quite a long
> > list with aptitude search
>
> Try installing from virtualbox own repo to get the latest (2.1.4). Check
> http://www.virtualbox.org/wiki/Linux_Downloads

I would have to agree, the one from virtualbox is the non ose version,
usb interface works.

>
> >
> >
> >
> > --
> > To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
> > with a subject of "unsubscribe". Trouble? Contact
> > listmaster@lists.debian.org
> >
> >
>
>
> --
> Regards,
>
> Umarzuki Mochlis
> http://gameornot.net

--
"I would have to ask the questioner. I haven't had a chance to ask the questioners the question they've been questioning. On the other hand, I firmly believe she'll be a fine secretary of labor. And I've got confidence in Linda Chavez. She is a´┐Żshe'll bring an interesting perspective to the Labor Department."

- George W. Bush
01/08/2001
Austin, TX
 
Old 02-23-2009, 02:57 PM
Harry Putnam
 
Default VirtualBox on lenny

Umarzuki Mochlis <umarzuki@gmail.com> writes:

>> And further... what packages are required? I noticed quite a long
>> list with aptitude search
>
> Try installing from virtualbox own repo to get the latest (2.1.4). Check
> http://www.virtualbox.org/wiki/Linux_Downloads

You mean to circumvent the apt tools right?
Done that way, does it matter which compiler you have installed?

I ask because I know on gentoo the VirtualBox package gives warning to
use something earlier than gcc-4.3. Just made me wonder if other
versions may be a problem too.

I'm going to try that install sometime today, but do you have any
other advice from experience with installing VirtualBox?


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 02-23-2009, 03:40 PM
Raquel
 
Default VirtualBox on lenny

On Mon, 23 Feb 2009 09:57:58 -0600
Harry Putnam <reader@newsguy.com> wrote:

> > Try installing from virtualbox own repo to get the latest
> > (2.1.4). Check http://www.virtualbox.org/wiki/Linux_Downloads
>
> You mean to circumvent the apt tools right?
> Done that way, does it matter which compiler you have installed?

I don't think that Umarzuki was saying to "circumvent the apt
tools". If you go to the site he indicated, you'll see that the
downloads are ".deb" files, so aptitude/apt would be used to install
VirtualBox from virtualbox.org.

--
Raquel
http://www.byraquel.com
================================================== ==========
I watched my country turn into a coast-to-coast strip mall and I
cried out in a song: if we could do all that in thirty years, then
please tell me, you all -- why does good change take so long? Why
does the color of your skin or who you choose to love still lead to
such anger and pain?

--Greg Brown, "The Poet Game"


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 02-23-2009, 04:12 PM
Tzafrir Cohen
 
Default VirtualBox on lenny

On Mon, Feb 23, 2009 at 08:40:52AM -0800, Raquel wrote:
> On Mon, 23 Feb 2009 09:57:58 -0600
> Harry Putnam <reader@newsguy.com> wrote:
>
> > > Try installing from virtualbox own repo to get the latest
> > > (2.1.4). Check http://www.virtualbox.org/wiki/Linux_Downloads
> >
> > You mean to circumvent the apt tools right?
> > Done that way, does it matter which compiler you have installed?
>
> I don't think that Umarzuki was saying to "circumvent the apt
> tools". If you go to the site he indicated, you'll see that the
> downloads are ".deb" files, so aptitude/apt would be used to install
> VirtualBox from virtualbox.org.

What happens on 'apt-get dist-upgrade' #?

What should happen?

--
Tzafrir Cohen | tzafrir@jabber.org | VIM is
http://tzafrir.org.il | | a Mutt's
tzafrir@cohens.org.il | | best
ICQ# 16849754 | | friend


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 02-23-2009, 04:24 PM
Raquel
 
Default VirtualBox on lenny

On Mon, 23 Feb 2009 17:12:42 +0000
Tzafrir Cohen <tzafrir@cohens.org.il> wrote:

> On Mon, Feb 23, 2009 at 08:40:52AM -0800, Raquel wrote:
> >
> > I don't think that Umarzuki was saying to "circumvent the apt
> > tools". If you go to the site he indicated, you'll see that the
> > downloads are ".deb" files, so aptitude/apt would be used to
> > install VirtualBox from virtualbox.org.
>
> What happens on 'apt-get dist-upgrade' #?
>
> What should happen?
>

You have downloaded to your machine and pointed to the appropriate
location in sources.list. It is up to you to make sure you have the
most current version available and saved to the same place
everytime. Then "dist-upgrade" works just the same as when pointing
to a Debian distro mirror.

--
Raquel
http://www.byraquel.com
================================================== ==========
I watched my country turn into a coast-to-coast strip mall and I
cried out in a song: if we could do all that in thirty years, then
please tell me, you all -- why does good change take so long? Why
does the color of your skin or who you choose to love still lead to
such anger and pain?

--Greg Brown, "The Poet Game"


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 

Thread Tools




All times are GMT. The time now is 12:57 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ę2007 - 2008, www.linux-archive.org