FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian User

 
 
LinkBack Thread Tools
 
Old 02-19-2009, 12:39 AM
Alejandro Rodriguez Luna
 
Default strange behavior aptitude

HI all!,

I just installed Debian Lenny, and after reboot, I
update my apt database (aptitude update), then i wanted to install vim
(aptitude install vim), but the message that appeared was

0 packages upgraded, 0 newly installed, 177 to remove and 0 not upgraded.
Need to get 0B of archives. After unpacking 495MB will be freed.
Do you want to continue? [Y/n/?] ^C

Why lenny wants remove the packages?

Regards.

__________________________________________________
Correo Yahoo!
Espacio para todos tus mensajes, antivirus y antispam ¡gratis!
Regístrate ya - http://correo.yahoo.com.mx/
 
Old 02-19-2009, 12:42 AM
Ron Johnson
 
Default strange behavior aptitude

On 02/18/2009 07:39 PM, Alejandro Rodriguez Luna wrote:


HI all!,

I just installed Debian Lenny, and after reboot, I update my apt
database (aptitude update), then i wanted to install vim (aptitude
install vim), but the message that appeared was


0 packages upgraded, 0 newly installed, 177 to remove and 0 not upgraded.
Need to get 0B of archives. After unpacking 495MB will be freed.
Do you want to continue? [Y/n/?] ^C

Why lenny wants remove the packages?


More details, please.

--
Ron Johnson, Jr.
Jefferson LA USA

Supporting World Peace Through Nuclear Pacification


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 02-19-2009, 12:49 AM
Alejandro Rodriguez Luna
 
Default strange behavior aptitude

machine: # aptitude install vim
Reading package lists... Done
Building dependency tree******
Reading state information... Done
Reading extended state information******
Initializing package states... Done
Reading task descriptions... Done*
The following NEW packages will be installed:
* vim vim-runtime{a}
The following packages will be REMOVED:
* alacarte{u} app-install-data{u} arj{u} aspell{u} bluez-gnome{u} bzip2{u} capplets-data{u} cdrdao{u} cheese{u} deskbar-applet{u}
* desktop-file-utils{u} dmz-cursor-theme{u} dvd+rw-tools{u} ekiga{u} eog{u} evince{u} evolution-exchange{u}
* fast-user-switch-applet{u} file-roller{u} finger{u} gcalctool{u} gconf-editor{u} gdm{u} gdm-themes{u} gedit{u} gedit-common{u}
* genisoimage{u}
gnome-about{u} gnome-app-install{u} gnome-applets{u} gnome-applets-data{u} gnome-backgrounds{u}
* gnome-cards-data{u} gnome-control-center{u} gnome-core{u} gnome-games{u} gnome-games-data{u} gnome-media{u} gnome-media-common{u}
* gnome-menus{u} gnome-netstatus-applet{u} gnome-nettool{u} gnome-network-admin{u} gnome-panel{u} gnome-panel-data{u}
* gnome-power-manager{u} gnome-screensaver{u} gnome-session{u} gnome-settings-daemon{u} gnome-spell{u} gnome-system-monitor{u}
* gnome-system-tools{u} gnome-themes{u} gnome-themes-extras{u} gnome-user-guide{u} gnome-vfs-obexftp{u} gnome-volume-manager{u}
* gnuchess{u} gstreamer0.10-gnomevfs{u} gstreamer0.10-tools{u} gtk2-engines{u} gtk2-engines-pixbuf{u} gucharmap{u}
* guile-1.8-libs{u} libao2{u} libapm1{u} libavahi-ui0{u} libdmx1{u} libepc-1.0-1{u} libepc-ui-1.0-1{u} libexempi3{u} libgalago3{u}
* libgda3-3{u} libgda3-common{u} libgdl-1-0{u}
libgdl-1-common{u} libggz2{u} libggzcore9{u} libggzmod4{u} libgksu1.2-0{u}
* libgksuui1.0-1{u} libgmyth0{u} libgnome-media0{u} libgnome-window-settings1{u} libgnomecups1.0-1{u} libgnomekbd-common{u}
* libgnomekbd2{u} libgnomekbdui2{u} libgnomeprint2.2-0{u} libgnomeprint2.2-data{u} libgnomeprintui2.2-0{u}
* libgnomeprintui2.2-common{u} libgnomevfs2-bin{u} libgpgme11{u} libgpod3{u} libgtk-vnc-1.0-0{u} libgtksourceview-common{u}
* libgtksourceview1.0-0{u} libgtksourceview2.0-0{u} libgtksourceview2.0-common{u} libgucharmap6{u} libgweather-common{u}
* libgweather1{u} libhtml-parser-perl{u} libhtml-tagset-perl{u} libhtml-tree-perl{u} libkpathsea4{u} liblircclient0{u}
* libmetacity0{u} libmtp7{u} libmusicbrainz4c2a{u} libmysqlclient15off{u} libnautilus-burn4{u} libnet-dbus-perl{u} liboobs-1-4{u}
* libopal-2.2{u} libopenobex1{u} libpt-1.10.10{u} libpt-1.10.10-plugins-alsa{u}
libpt-1.10.10-plugins-v4l{u} libpth20{u}
* libsdl1.2debian{u} libsdl1.2debian-alsa{u} libslab0{u} libspectre1{u} libspeexdsp1{u} libsvga1{u} libtotem-plparser10{u}
* libtrackerclient0{u} liburi-perl{u} libvorbisfile3{u} libwww-perl{u} libxklavier12{u} libxml-parser-perl{u} libxml-twig-perl{u}
* metacity{u} metacity-common{u} mysql-common{u} nautilus{u} nautilus-cd-burner{u} nautilus-data{u} p7zip{u} pkg-config{u}
* python-4suite-xml{u} python-eggtrayicon{u} python-gdata{u} python-gdbm{u} python-gmenu{u} python-gnome2-desktop{u}
* python-gnome2-extras{u} python-gst0.10{u} python-gtkhtml2{u} python-gtkmozembed{u} python-gtksourceview2{u} python-notify{u}
* python-sexy{u} python-xdg{u} rhythmbox{u} seahorse{u} serpentine{u} sound-juicer{u} svgalibg1{u} swfdec-gnome{u}
* system-config-printer{u} system-tools-backends{u} totem-common{u} totem-gstreamer{u} totem-mozilla{u} totem-plugins{u}

* transmission-common{u} transmission-gtk{u} unzip{u} vinagre{u} vino{u} wodim{u} zenity{u} zip{u}
0 packages upgraded, 2 newly installed, 177 to remove and 0 not upgraded.
Need to get 6371kB of archives. After unpacking 470MB will be freed.
Do you want to continue? [Y/n/?]

--- El mié 18-feb-09, Ron Johnson <ron.l.johnson@cox.net> escribió:
De:: Ron Johnson <ron.l.johnson@cox.net>
Asunto: Re: strange behavior aptitude
A: debian-user@lists.debian.org
Fecha: miércoles, 18 febrero, 2009, 6:42 pm

On 02/18/2009 07:39 PM, Alejandro Rodriguez Luna wrote:
>
> HI all!,
>
> I just installed Debian Lenny, and after reboot, I update my apt database
(aptitude update), then i wanted to install vim (aptitude install vim), but the
message that appeared was
>

> 0 packages upgraded, 0 newly installed, 177 to remove and 0 not upgraded.
> Need to get 0B of archives. After unpacking 495MB will be freed.
> Do you want to continue? [Y/n/?] ^C
>
> Why lenny wants remove the packages?

More details, please.

-- Ron Johnson, Jr.
Jefferson LA USA

Supporting World Peace Through Nuclear Pacification


-- To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org with a subject
of "unsubscribe". Trouble? Contact listmaster@lists.debian.org


__________________________________________________
Correo Yahoo!
Espacio para todos tus mensajes, antivirus y antispam ¡gratis!
Regístrate ya - http://correo.yahoo.com.mx/
 
Old 02-19-2009, 03:03 AM
Daniel Burrows
 
Default strange behavior aptitude

On Wed, Feb 18, 2009 at 05:49:00PM -0800, Alejandro Rodriguez Luna <el_alexluna@yahoo.com.mx> was heard to say:
> The following packages will be REMOVED:

It looks like you removed the "gnome" metapackage, so aptitude
figures you don't want anything in gnome. I would suggest running
"aptitude install gnome"; you could also run "aptitude keep-all", but
that will throw away all the automatic flags for these packages. That
means that when gnome stops using them (e.g., because libgnomecups1.0-1
has been superseded by a newer version), aptitude won't remove them
automatically.

Dnaiel


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 

Thread Tools




All times are GMT. The time now is 02:25 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org