FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian User

 
 
LinkBack Thread Tools
 
Old 02-17-2009, 01:18 AM
JoeHill
 
Default Can't update Testing system

Came back tonight and of course I've got 200 or so packages to update after
Saturday's release of Lenny.

The update errors out, however, and tells me to run aptitude install -f to
correct the problem, but that results in:

node1:/home/joehill# aptitude install -f
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
Writing extended state information... Done
Reading task descriptions... Done
The following packages are BROKEN:
libsox-dev libsox-fmt-ao libsox-fmt-ffmpeg libsox-fmt-mp3
The following packages will be REMOVED:
abiword{u} abiword-common{u} abiword-help{u} abiword-plugin-goffice{u}
abiword-plugin-grammar{u} abiword-plugin-mathview{u} gcc-3.4-base{u}
gnumeric-common{u} inkscape{u} latex-xft-fonts{u}
libaiksaurus-1.2-0c2a{u} libaiksaurus-1.2-data{u}
libaiksaurusgtk-1.2-0c2a{u} libgdome2-0{u} libgdome2-cpp-smart0c2a{u}
libgoffice-0-4{u} libgoffice-0-6{u} libgoffice-0-6-common{u}
libgoffice-0-common{u} libgtkmathview0c2a{u} liblink-grammar4{u}
libmagick++10{u} libots0{u} libplot2c2{u} libportaudio0{u}
libpstoedit0c2a{u} libsox-fmt-gsm{u} libsox-fmt-sndfile{u} libwmf-bin{u}
libwv-1.2-3{u} link-grammar-dictionaries-en{u} mkisofs{u} planner{u}
pmount{u} pstoedit{u} ttf-opensymbol{u}
The following partially installed packages will be configured:
libsox-fmt-all
0 packages upgraded, 0 newly installed, 36 to remove and 242 not upgraded.
Need to get 0B of archives. After unpacking 132MB will be freed.
The following packages have unmet dependencies:
libsox-dev: Depends: libsox1 (= 14.2.0-1) but it is not installable
libsox-fmt-ao: Depends: libsox1 (>= 14.2.0) but it is not installable
libsox-fmt-ffmpeg: Depends: libsox1 (>= 14.2.0) but it is not installable
libsox-fmt-mp3: Depends: libsox1 (>= 14.2.0) but it is not installable
The following actions will resolve these dependencies:

Remove the following packages:
libsox0

Install the following packages:
libsox1 [14.2.0-1 (testing)]

Upgrade the following packages:
libsox-fmt-alsa [14.0.1-2+b1 (now) -> 14.2.0-1 (testing)]
libsox-fmt-base [14.0.1-2+b1 (now) -> 14.2.0-1 (testing)]
libsox-fmt-oss [14.0.1-2+b1 (now) -> 14.2.0-1 (testing)]
sox [14.0.1-2+b1 (now) -> 14.2.0-1 (testing)]

Score is -150

Accept this solution? [Y/n/q/?] y
The following NEW packages will be installed:
libsox1{a}
The following packages will be REMOVED:
abiword{u} abiword-common{u} abiword-help{u} abiword-plugin-goffice{u}
abiword-plugin-grammar{u} abiword-plugin-mathview{u} gcc-3.4-base{u}
gnumeric-common{u} inkscape{u} latex-xft-fonts{u}
libaiksaurus-1.2-0c2a{u} libaiksaurus-1.2-data{u}
libaiksaurusgtk-1.2-0c2a{u} libgdome2-0{u} libgdome2-cpp-smart0c2a{u}
libgoffice-0-4{u} libgoffice-0-6{u} libgoffice-0-6-common{u}
libgoffice-0-common{u} libgtkmathview0c2a{u} liblink-grammar4{u}
libmagick++10{u} libots0{u} libplot2c2{u} libportaudio0{u}
libpstoedit0c2a{u} libsox-fmt-gsm{u} libsox-fmt-sndfile{u} libsox0{a}
libwmf-bin{u} libwv-1.2-3{u} link-grammar-dictionaries-en{u} mkisofs{u}
planner{u} pmount{u} pstoedit{u} ttf-opensymbol{u}
The following packages will be upgraded:
libsox-fmt-alsa libsox-fmt-base libsox-fmt-oss sox
The following partially installed packages will be configured:
libsox-dev libsox-fmt-all libsox-fmt-ao libsox-fmt-ffmpeg libsox-fmt-mp3
4 packages upgraded, 1 newly installed, 37 to remove and 238 not upgraded.
Need to get 0B/564kB of archives. After unpacking 131MB will be freed.
Do you want to continue? [Y/n/?] y
Writing extended state information... Done
(Reading database ... 179969 files and directories currently installed.)
Preparing to replace libsox-fmt-base 14.0.1-2+b1
(using .../libsox-fmt-base_14.2.0-1_i386.deb) ... Unpacking replacement
libsox-fmt-base ... Replacing files in old package libsox-fmt-gsm ...
dpkg: error
processing /var/cache/apt/archives/libsox-fmt-base_14.2.0-1_i386.deb
(--unpack): trying to overwrite `/usr/lib/sox/libsox_fmt_sndfile.so', which is
also in package libsox-fmt-sndfile dpkg-deb: subprocess paste killed by signal
(Broken pipe) Errors were encountered while
processing: /var/cache/apt/archives/libsox-fmt-base_14.2.0-1_i386.deb E:
Sub-process /usr/bin/dpkg returned an error code (1) A package failed to
install. Trying to recover: dpkg: dependency problems prevent configuration of
libsox-dev: libsox-dev depends on libsox1 (= 14.2.0-1); however:
Package libsox1 is not installed.
dpkg: error processing libsox-dev (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libsox-fmt-ao:
libsox-fmt-ao depends on libsox1 (>= 14.2.0); however:
Package libsox1 is not installed.
dpkg: error processing libsox-fmt-ao (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libsox-fmt-ffmpeg:
libsox-fmt-ffmpeg depends on libsox1 (>= 14.2.0); however:
Package libsox1 is not installed.
dpkg: error processing libsox-fmt-ffmpeg (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libsox-fmt-mp3:
libsox-fmt-mp3 depends on libsox1 (>= 14.2.0); however:
Package libsox1 is not installed.
dpkg: error processing libsox-fmt-mp3 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libsox-fmt-all:
libsox-fmt-all depends on libsox-fmt-ffmpeg; however:
Package libsox-fmt-ffmpeg is not configured yet.
libsox-fmt-all depends on libsox-fmt-mp3; however:
Package libsox-fmt-mp3 is not configured yet.
libsox-fmt-all depends on libsox-fmt-ao; however:
Package libsox-fmt-ao is not configured yet.
dpkg: error processing libsox-fmt-all (--configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
libsox-dev
libsox-fmt-ao
libsox-fmt-ffmpeg
libsox-fmt-mp3
libsox-fmt-all
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
Writing extended state information... Done
Reading task descriptions... Done

node1:/home/joehill#

Not sure how to proceed. This is my first encounter with this process ever, so
I really don't want to go messing with it unless I've got some guidance :-)

Thanks!

--
J


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 02-17-2009, 04:23 AM
Daniel Burrows
 
Default Can't update Testing system

On Mon, Feb 16, 2009 at 09:18:55PM -0500, JoeHill <joehill@teksavvy.com> was heard to say:
> dpkg: error
> processing /var/cache/apt/archives/libsox-fmt-base_14.2.0-1_i386.deb
> (--unpack): trying to overwrite `/usr/lib/sox/libsox_fmt_sndfile.so', which is
> also in package libsox-fmt-sndfile

That's your bug. It looks like the old libsox-fmt-sndfile (which
seems to have been removed from the archive) conflicts with
libsox-fmt-base. I'd suggest just removing it by hand with dpkg
(aptitude was going to remove it anyway), and then filing a bug on
libsox-fmt-sndbase, severity serious or greater: it should conflict
with and replace libsox-fmt-sndfile (IMO).

Daniel


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 02-17-2009, 04:30 PM
JoeHill
 
Default Can't update Testing system

Daniel Burrows wrote:

> On Mon, Feb 16, 2009 at 09:18:55PM -0500, JoeHill <joehill@teksavvy.com> was
> heard to say:
> > dpkg: error
> > processing /var/cache/apt/archives/libsox-fmt-base_14.2.0-1_i386.deb
> > (--unpack): trying to overwrite `/usr/lib/sox/libsox_fmt_sndfile.so', which
> > is also in package libsox-fmt-sndfile
>
> That's your bug. It looks like the old libsox-fmt-sndfile (which
> seems to have been removed from the archive) conflicts with
> libsox-fmt-base. I'd suggest just removing it by hand with dpkg
> (aptitude was going to remove it anyway), and then filing a bug on
> libsox-fmt-sndbase, severity serious or greater: it should conflict
> with and replace libsox-fmt-sndfile (IMO).

Looks like just removing it worked like you said. As far as filing the bug, I'm
assuming you mean filing one with the Debian packager? Or do you mean with the
developer?

Many thanks, for the help!

--
J


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 02-18-2009, 05:47 AM
Daniel Burrows
 
Default Can't update Testing system

On Tue, Feb 17, 2009 at 12:30:37PM -0500, JoeHill <joehill@teksavvy.com> was heard to say:
> Daniel Burrows wrote:
>
> > On Mon, Feb 16, 2009 at 09:18:55PM -0500, JoeHill <joehill@teksavvy.com> was
> > heard to say:
> > > dpkg: error
> > > processing /var/cache/apt/archives/libsox-fmt-base_14.2.0-1_i386.deb
> > > (--unpack): trying to overwrite `/usr/lib/sox/libsox_fmt_sndfile.so', which
> > > is also in package libsox-fmt-sndfile
> >
> > That's your bug. It looks like the old libsox-fmt-sndfile (which
> > seems to have been removed from the archive) conflicts with
> > libsox-fmt-base. I'd suggest just removing it by hand with dpkg
> > (aptitude was going to remove it anyway), and then filing a bug on
> > libsox-fmt-sndbase, severity serious or greater: it should conflict
> > with and replace libsox-fmt-sndfile (IMO).
>
> Looks like just removing it worked like you said. As far as filing the bug, I'm
> assuming you mean filing one with the Debian packager? Or do you mean with the
> developer?

Yeah, I mean the Debian package. It needs to pass some extra hints
to the package manager for upgrades to work cleanly. In fact, it looks
like someone *tried* to do this with a "Replaces: libsox-fmt-libsndfile",
but the actual package name is "libsox-fmt-sndfile", so that Replaces
has no effect.

Daniel


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 

Thread Tools




All times are GMT. The time now is 08:46 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org