FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian User

 
 
LinkBack Thread Tools
 
Old 02-06-2009, 08:29 AM
SOliver
 
Default bug in pkg-fglrx 156

hello,

when i make an .deb for fglrx-driver 9-1-2 with the svn version
Current directory: [pkg-fglrx]
Current revision: 156
there is no problems to build the pakage, but when i install it on my debian
lenny there gives me
the following error

/var/lib/dpkg/info/fglrx-driver.config: line 12: syntax error near unexpected
token `else'

this i have been fix in debian/fglrx-driver.config in line 12 from

if `laptop-detect > /dev/null`;

to

if `laptop-detect > /dev/null`; then


but then i have an new error

/var/lib/dpkg/info/fglrx-driver.config: line 9: [: missing `]'

this i have been fix in debian/fglrx-driver.config in line 9 from

if [ "$RET" != "true" && "$RET" != "false" && -x `which laptop-detect` ]; then

to

if [ "$RET" != "true" ] && [ "$RET" != "false" ] && [ -x `which
laptop-detect` ]; then


it seems to be fixed the problems when i install my new pakete there was no
error.

i provided and send one patch for these.


sorry for my bad english, i hope you will understand my text


PS:
i have also changed the Depends for xserver-xorg in debian/control from
xserver-xorg (>= 1:7.4) to xserver-xorg (>= 1:7.3), to run it for the default
xserver-xorg in debian lenny.
 

Thread Tools




All times are GMT. The time now is 11:57 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org