FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian User

 
 
LinkBack Thread Tools
 
Old 01-25-2009, 02:53 PM
Francesco Pietra
 
Default XIO: fatal error 104

Hi:
I have little familiarity with X11, in particular on my computing
multisocket with amd64 lenny, where it is seldom used. Now that it is
needed, it does not work any more.

Command startx or X (as user) reports:

X.Org X Server 1.4.2
Release Date: 11 June 2008
X Protocol Version 11, Revision 0
Build Operating System: Linux Debian (xorg-server 2:1.4.2-10)
Current Operating System: Linux deb64 2.6.24-1-amd64 #1 SMP Sat May 10
09:28:10 UTC 2008 x86_64
Build Date: 09 January 2009 02:16:05AM

Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sun Jan 25 15:47:02 2009
(==) Using config file: "/etc/X11/xorg.conf"
(II) Module "ddc" already built-in
(II) Module "ddc" already built-in
(II) Module "ramdac" already built-in
(II) Module "i2c" already built-in

Backtrace:
0: /usr/bin/X11/X(xf86SigHandler+0x6a) [0x48dd0a]
1: /lib/libc.so.6 [0x2ab82827df60]

Fatal server error:
Caught signal 11. Server aborting

XIO: fatal IO error 104 (Connection reset by peer) on X server ":0.0"

after 0 requests (0 known processed) with 0 events remaining.
=====
Other information:

(WW) The directory "/usr/X11R6/lib/X11/fonts/misc" does not exist.
(WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
(WW) The directory "/usr/X11R6/lib/X11/fonts/cyrillic" does not exist.
(WW) The directory "/usr/X11R6/lib/X11/fonts/100dpi/" does not exist.
(WW) The directory "/usr/X11R6/lib/X11/fonts/75dpi/" does not exist.
(WW) The directory "/usr/X11R6/lib/X11/fonts/Type1" does not exist.
(WW) The directory "/usr/X11R6/lib/X11/fonts/100dpi" does not exist.
(WW) The directory "/usr/X11R6/lib/X11/fonts/75dpi" does not exist.
(WW) The directory "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
does not exist.
(WW) MACH64(0): Cannot shadow an accelerated frame buffer.
============

Section "Module"
Load "bitmap"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "vbe"
EndSection
Section "Device"
Identifier "ATI Technologies Inc Rage XL"
Driver "ati"
BusID "PCI:3:1:0"
EndSection
=================

03:01.0 VGA compatible controller: ATI Technologies Inc Rage XL (rev 27)
===============

I tried

#dpkg-reconfigure xserver -xorg

setting:

kernel framebuffer device interface: yes

Keyboard layout: pc104

but id did not help.

Thanks for helping

francesco pietra


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 

Thread Tools




All times are GMT. The time now is 12:02 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org