Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Debian User (http://www.linux-archive.org/debian-user/)
-   -   fetchmail and exchange 2007 (http://www.linux-archive.org/debian-user/232440-fetchmail-exchange-2007-a.html)

Stephan Seitz 01-22-2009 01:40 PM

fetchmail and exchange 2007
 
On Thu, Jan 22, 2009 at 10:27:45AM -0400, tyler wrote:

fetchmail: Trying to connect to 132.206.153.2/110...connection failed.


Isn’t the error message self explaining? Fetchmail can’t get a connection
to this host using port 110. Port 110 is the unsecure POP3 port (no ssl
encryption). Testing it I see that the ports 993 (imap over ssl) and 995
(pop3 over ssl) are open. So you have to change your .fetchmailrc to use
SSL. Look for the ssl keyword in the fetchmail manpage.


Shade and sweet water!

Stephan

--
| Stephan Seitz E-Mail: stse@fsing.rootsland.net |
| PGP Public Keys: http://fsing.rootsland.net/~stse/pgp.html |

Ron Johnson 01-22-2009 01:41 PM

fetchmail and exchange 2007
 
On 01/22/2009 08:27 AM, tyler wrote:

Hi,

My University just transferred my mail account to MS Exchange 2007. I
had been accessing my old account via fetchmail, using the following:

poll NON.EXCHANGE.SERVER with proto POP3 and options no dns uidl
user 'MYUSERNAME' there with password 'MYPASSWORD' is 'tyler' here options fetchall


That was fine, but now it doesn't work - from my current .fetchmailrc:

poll exchange.mcgill.ca with proto POP3 and options no dns uidl
user 'MYUSERNAME' there with password 'MYPASSWORD' is 'tyler' here options fetchall


I get the following errors in fetchmailconf:

fetchmail: 6.3.9-rc2 querying exchange.mcgill.ca (protocol POP3) at Thu 22 Jan 2009 10:08:10 AM AST: poll started
fetchmail: Trying to connect to 132.206.153.2/110...connection failed.
fetchmail: connection to exchange.mcgill.ca:pop3 [132.206.153.2/110] failed: Connection timed out.
fetchmail: POP3 connection to exchange.mcgill.ca failed: Connection timed out
fetchmail: 6.3.9-rc2 querying exchange.mcgill.ca (protocol POP3) at Thu 22 Jan 2009 10:11:19 AM AST: poll completed
fetchmail: Query status=2 (SOCKET)

I've asked google, which gave me a lot of info, most of which I don't
understand. Can anyone give me some pointers for how to fix this? I'm
just working with a single laptop here, exchange.mcgill.ca to fetchmail
to emacs vm for receiving mail, exim to ISP for sending.


If the Uni admins have enabled IMAP, then you need to change the
proto from POP3 to IMAP4.


http://www.catb.org/~esr/fetchmail/fetchmail-FAQ.html#S2

Don't know if Debian fetchmail has NTLM activated or not.

Your best bet might be to migrate to Evolution.

--
Ron Johnson, Jr.
Jefferson LA USA

"I am not surprised, for we live long and are celebrated poopers."


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org


All times are GMT. The time now is 02:49 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.