FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian User

 
 
LinkBack Thread Tools
 
Old 01-15-2009, 03:54 AM
Stephen Dewey
 
Default essential packages getting deleted when switching to testing libc6

On Wed, Jan 14, 2009 at 11:45 PM, Ron Johnson <ron.l.johnson@cox.net> wrote:
>>
>> I am having trouble with the libfaac0 package, and have been hoping to
>> upgrade it the hope that a bug fix has been released for my problem.
>> The libfaac0 package requires libc6 >= 2.7-1 but etch only has
>> 2.3.6.ds1-13etch8, so I've added a testing distribution to my sources
>> list.
>>
> [snip]
>>
>>
>> Any ideas?
>
> Sure. Don't mix Stable and Testing. This close to Stable becoming
> Oldstable, Etch and Lenny have very different dependencies.
>

Ok. I am OK with moving to Lenny. Would it then be OK for me to simply
upgrade to Lenny via the below?

apt-get update
apt-get -t stable upgrade
apt-get -t stable dist-upgrade
apt-get -t testing upgrade
apt-get -t testing dist-upgrade

(I am getting this from
http://www.debian.org/doc/manuals/reference/ch-woody.en.html - I
assume based on my reading of the apt_preferences 5 man page that this
will move me in the correct order.)

Thanks...
Stephen


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 01-15-2009, 04:01 AM
Ron Johnson
 
Default essential packages getting deleted when switching to testing libc6

On 01/14/09 22:54, Stephen Dewey wrote:

On Wed, Jan 14, 2009 at 11:45 PM, Ron Johnson <ron.l.johnson@cox.net> wrote:

I am having trouble with the libfaac0 package, and have been hoping to
upgrade it the hope that a bug fix has been released for my problem.
The libfaac0 package requires libc6 >= 2.7-1 but etch only has
2.3.6.ds1-13etch8, so I've added a testing distribution to my sources
list.


[snip]


Any ideas?

Sure. Don't mix Stable and Testing. This close to Stable becoming
Oldstable, Etch and Lenny have very different dependencies.



Ok. I am OK with moving to Lenny. Would it then be OK for me to simply
upgrade to Lenny via the below?

apt-get update
apt-get -t stable upgrade
apt-get -t stable dist-upgrade
apt-get -t testing upgrade
apt-get -t testing dist-upgrade

(I am getting this from
http://www.debian.org/doc/manuals/reference/ch-woody.en.html - I
assume based on my reading of the apt_preferences 5 man page that this
will move me in the correct order.)


You'll have to modify your sources.list first, replacing "etch" or
"stable" with "lenny".


--
Ron Johnson, Jr.
Jefferson LA USA

"I am not surprised, for we live long and are celebrated poopers."


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 01-15-2009, 08:34 AM
Stephen Dewey
 
Default essential packages getting deleted when switching to testing libc6

>> Ok. I am OK with moving to Lenny. Would it then be OK for me to simply
>> upgrade to Lenny via the below?
>>
>> apt-get update
>> apt-get -t stable upgrade
>> apt-get -t stable dist-upgrade
>> apt-get -t testing upgrade
>> apt-get -t testing dist-upgrade
>>
>> (I am getting this from
>> http://www.debian.org/doc/manuals/reference/ch-woody.en.html - I
>> assume based on my reading of the apt_preferences 5 man page that this
>> will move me in the correct order.)
>
> You'll have to modify your sources.list first, replacing "etch" or "stable"
> with "lenny".
>

Ok. I did this and I have been able to move to the testing
distribution. Unfortuantely, I encountered an error when running
dist-upgrade on that distribution. I got a pop-up box that states,

"You are currently upgrading udev to a version that is not compatible
with the currently running kernel. You MUST install a compatible
kernel version (2.6.18 or newer) before upgrading, otherwise the
system may become UNUSABLE. Packages with a name starting with
"linux-image-2.6-" provide a kernel image usable with this new udev
version."

I ran uname -r and got my kernel version as "2.6.16.29-xen", but
dist-upgrade doesn't look like it will upgrade the kernel version for
me.

Also, now when I run apt-get dist-upgrade, I am seeing "75 not fully
installed or removed." because the last install stopped on the udev
problem... how can I keep this from being a problem?

Thanks for your help.
Stephen


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 01-15-2009, 08:46 AM
Ron Johnson
 
Default essential packages getting deleted when switching to testing libc6

On 01/15/09 03:34, Stephen Dewey wrote:

Ok. I am OK with moving to Lenny. Would it then be OK for me to simply
upgrade to Lenny via the below?

apt-get update
apt-get -t stable upgrade
apt-get -t stable dist-upgrade
apt-get -t testing upgrade
apt-get -t testing dist-upgrade

(I am getting this from
http://www.debian.org/doc/manuals/reference/ch-woody.en.html - I
assume based on my reading of the apt_preferences 5 man page that this
will move me in the correct order.)

You'll have to modify your sources.list first, replacing "etch" or "stable"
with "lenny".



Ok. I did this and I have been able to move to the testing
distribution. Unfortuantely, I encountered an error when running
dist-upgrade on that distribution. I got a pop-up box that states,

"You are currently upgrading udev to a version that is not compatible
with the currently running kernel. You MUST install a compatible
kernel version (2.6.18 or newer) before upgrading, otherwise the
system may become UNUSABLE. Packages with a name starting with
"linux-image-2.6-" provide a kernel image usable with this new udev
version."

I ran uname -r and got my kernel version as "2.6.16.29-xen", but
dist-upgrade doesn't look like it will upgrade the kernel version for
me.

Also, now when I run apt-get dist-upgrade, I am seeing "75 not fully
installed or removed." because the last install stopped on the udev
problem... how can I keep this from being a problem?


Try:
# apt-get install linux-image-2.6-686

--
Ron Johnson, Jr.
Jefferson LA USA

"I am not surprised, for we live long and are celebrated poopers."


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 01-15-2009, 08:56 AM
Johannes Wiedersich
 
Default essential packages getting deleted when switching to testing libc6

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Stephen Dewey wrote:
> On Wed, Jan 14, 2009 at 11:45 PM, Ron Johnson <ron.l.johnson@cox.net> wrote:
>>> I am having trouble with the libfaac0 package, and have been hoping to
>>> upgrade it the hope that a bug fix has been released for my problem.
>>> The libfaac0 package requires libc6 >= 2.7-1 but etch only has
>>> 2.3.6.ds1-13etch8, so I've added a testing distribution to my sources
>>> list.
>>>
>> [snip]
>>>
>>> Any ideas?
>> Sure. Don't mix Stable and Testing. This close to Stable becoming
>> Oldstable, Etch and Lenny have very different dependencies.
>>
>
> Ok. I am OK with moving to Lenny. Would it then be OK for me to simply
> upgrade to Lenny via the below?
>
> apt-get update
> apt-get -t stable upgrade
> apt-get -t stable dist-upgrade
> apt-get -t testing upgrade
> apt-get -t testing dist-upgrade
>
> (I am getting this from
> http://www.debian.org/doc/manuals/reference/ch-woody.en.html - I

That seems to have been the prefered way of upgrading from potato to
woody. Debian GNU/Linux 3.0 (a.k.a. woody) was released on 19th of July,
*2002*.

I followed the recommendations for lenny from
http://lists.debian.org/debian-devel-announce/2008/10/msg00000.html
and it worked for me without problems.

> * If you are running stable (aka "Etch"), you could consider
> upgrading to "Lenny" and see, if everything works fine. Currently there
> are no detailed release notes documenting the procedure, so you best
> way to test upgrades are to:
>
> 1. Make backups
> 2. Change your /etc/apt/sources.list
> 3. Run aptitude update to get information about new packages
> 4. Run aptitude install dpkg aptitude apt to install the newest package
> management
> 5. Run aptitude full-upgrade
>
> If something goes wrong / something unexpected happens, please report
> it. If you already know a specific package, report a bug against that
> package. If you don't know, please report a bug describing the problem
> you experienced to the upgrade-reports package. If your problem is
> something, which can't be fixed properly, but should be documented
> (e.g. hardware support regressions, packages no longer available)
> please report a bug against the release-notes package (Bonus points if
> you not only report the bug, but also supply a paragraph to be added to
> the release notes).


The main difference is that aptitude is now prefered over apt-get.

YMMV,

Johannes
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iEYEARECAAYFAklvCGYACgkQC1NzPRl9qEV/tgCfUI3WjH5740dC2Aoks1T1wKeG
HusAnj078EBSq5wPdjJ9Ow2AElRcpnzr
=+mxl
-----END PGP SIGNATURE-----


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 01-15-2009, 10:59 AM
André Neves
 
Default essential packages getting deleted when switching to testing libc6

> The main difference is that aptitude is now prefered over apt-get.

Sorry, preferred by who?

André


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 01-15-2009, 12:21 PM
Johannes Wiedersich
 
Default essential packages getting deleted when switching to testing libc6

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

André Neves wrote:
>> The main difference is that aptitude is now prefered over apt-get.
>
> Sorry, preferred by who?

By the debian developers. From
/usr/share/doc/aptitude/README

> What is this aptitude thing, anyway?
>
> aptitude is a featureful package manager for Debian GNU/Linux systems, based on
> the renowned apt package management infrastructure. aptitude provides the
> functionality of dselect and apt-get, as well as many additional features not
> found in either program.

IIRC, it's mainly the better algorithms to resolve dependencies and the
ability to distinguish between packages that are automatically installed
vs manually installed, that have been introduced in aptitude, but not in
apt-get.

Cheers,
Johannes
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iEYEARECAAYFAklvOHEACgkQC1NzPRl9qEWoGQCcCuxAvcmhhv OeWhbmoyvJcP1E
o3YAnjRR2/BKJJIqIKUUd6ToC1yWJo3+
=T2kG
-----END PGP SIGNATURE-----


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 01-15-2009, 12:46 PM
André Neves
 
Default essential packages getting deleted when switching to testing libc6

> IIRC, it's mainly the better algorithms to resolve dependencies and the
> ability to distinguish between packages that are automatically installed
> vs manually installed, that have been introduced in aptitude, but not in
> apt-get.

Thanks for the info. I might turn aptitude into the canonical way of
dealing with packages now.


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 01-15-2009, 12:51 PM
Ron Johnson
 
Default essential packages getting deleted when switching to testing libc6

On 01/15/09 07:21, Johannes Wiedersich wrote:
[snip]


IIRC, it's mainly the better algorithms to resolve dependencies and the
ability to distinguish between packages that are automatically installed
vs manually installed, that have been introduced in aptitude, but not in
apt-get.


From memory and the fact that now apt regularly nags me that
certain packages aren't needed anymore, and can be dropped with
'apt-get autoremove', I *think* that the same (or similar)
algorithms were implemented in apt,


--
Ron Johnson, Jr.
Jefferson LA USA

"I am not surprised, for we live long and are celebrated poopers."


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 01-15-2009, 02:51 PM
André Neves
 
Default essential packages getting deleted when switching to testing libc6

On Thu, Jan 15, 2009 at 11:51, Ron Johnson <ron.l.johnson@cox.net> wrote:
> From memory and the fact that now apt regularly nags me that certain packages aren't needed anymore, and can be dropped with 'apt-get autoremove', I *think* that the same (or similar) algorithms were implemented in apt,

I disagree. I had always used apt-get in my system, doing autoremove
whenever it suggested there were unneeded packages installed. One day
I ran aptitude out of curiosity, and well, it suggested to uninstall
almost 300 unneeded packages! After (not so) careful reviewing of the
packages, I decided to let it go ahead, and the result is that I still
haven't felt any effects, good or bad, from aptitude's cleanup.

André


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 

Thread Tools




All times are GMT. The time now is 03:38 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org