Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Debian User (http://www.linux-archive.org/debian-user/)
-   -   creative xmod sound card (http://www.linux-archive.org/debian-user/208999-creative-xmod-sound-card.html)

Arc Roca 12-09-2008 07:46 PM

creative xmod sound card
 
Has anybody been able to use creative xmod usb sound card?, I am having a tough time trying to make it work. It recognizes it if you plug/unplug it, even the volume buttom works (in the sense that the applet shows the master going up or down, to the other sound card) but if you try to use it with say, aplay -d Xmod song.ogg, it will not work.

Arc Roca 12-10-2008 03:24 PM

creative xmod sound card
 
Following the instructions in
/usr/share/doc/alsa-base/README.Debian.gz

I added a line to my /etc/modprobe.d/sound which now looks like this

alias snd-card-0 snd-hda-intel
options snd-hda-intel index=0
alias snd-card-1*** snd-usb-audio
options snd-usb-audio index=1

since after pluging it it shows as follows

arc@tosh:~$ cat /proc/asound/cards
*0 [Intel********* ]: HDA-Intel - HDA Intel
********************* HDA Intel at 0xfc500000 irq 22
*1 [Xmod********** ]: USB-Audio - Creative
Xmod
********************* Creative Technology Ltd Creative Xmod at usb-0000:00:1d.2-2, full speed

or

arc@tosh:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC268 Analog [ALC268 Analog]
* Subdevices: 1/1
* Subdevice #0: subdevice #0
card 1: Xmod [Creative Xmod], device 0: USB Audio [USB Audio]
* Subdevices: 1/1
* Subdevice #0: subdevice #0

However, this is what I get now, same as before:

arc@tosh:~/música/JoanManuelSerrat$ alsaplayer -d Xmod Benito.ogg
ALSA lib pcm.c:2144:(snd_pcm_open_noupdate) Unknown PCM Xmod
snd_pcm_open: No such file or directory (Xmod)
Failed to initialize plugin!
Failed to register plugin: /usr/lib/alsaplayer/output/libalsa_out.so
Failed to load output plugin "alsa". Trying defaults.
ALSA
lib pcm.c:2144:(snd_pcm_open_noupdate) Unknown PCM Xmod
snd_pcm_open: No such file or directory (Xmod)
Failed to initialize plugin!
/usr/lib/alsaplayer/output/libalsa_out.so failed to load
jack: server not running?
/usr/lib/alsaplayer/output/libjack_out.so failed to load
error opening /dev/dsp
Failed to initialize plugin!
/usr/lib/alsaplayer/output/liboss_out.so failed to load
No $AUDIOSERVER, falling back on $DISPLAY
NAS server not available
Failed to initialize plugin!
/usr/lib/alsaplayer/output/libnas_out.so failed to load
/dev/dsp: No such file or directory
Failed to initialize plugin!
/usr/lib/alsaplayer/output/libesound_out.so failed to load
NOTE: THIS IS THE NULL PLUGIN.***** YOU WILL NOT HEAR SOUND!!
Segmentation fault

=============================

Is the conclusion at
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=491196
right, or am I doind
something wrong?

Any ideas? Thanks in advance.

Florian Kulzer 12-10-2008 05:52 PM

creative xmod sound card
 
On Wed, Dec 10, 2008 at 08:24:50 -0800, Arc Roca wrote:
>
> Following the instructions in
> /usr/share/doc/alsa-base/README.Debian.gz
>
> I added a line to my /etc/modprobe.d/sound which now looks like this
>
> alias snd-card-0 snd-hda-intel
> options snd-hda-intel index=0
> alias snd-card-1*** snd-usb-audio
> options snd-usb-audio index=1
>
> since after pluging it it shows as follows
>
> arc@tosh:~$ cat /proc/asound/cards
> *0 [Intel********* ]: HDA-Intel - HDA Intel
> ********************* HDA Intel at 0xfc500000 irq 22
> *1 [Xmod********** ]: USB-Audio - Creative Xmod

That looks good to me.

> arc@tosh:~$ aplay -l
> **** List of PLAYBACK Hardware Devices ****
> card 0: Intel [HDA Intel], device 0: ALC268 Analog [ALC268 Analog]
> * Subdevices: 1/1
> * Subdevice #0: subdevice #0
> card 1: Xmod [Creative Xmod], device 0: USB Audio [USB Audio]
> * Subdevices: 1/1
> * Subdevice #0: subdevice #0

You have to use "aplay -L" (which is the same as "aplay --list-pcms") to
get a list of the known PCM names.

> However, this is what I get now, same as before:
>
> arc@tosh:~/música/JoanManuelSerrat$ alsaplayer -d Xmod Benito.ogg
> ALSA lib pcm.c:2144:(snd_pcm_open_noupdate) Unknown PCM Xmod

I think you are using the wrong device string; AFAIK, it has be a known
PCM name (see above). For example, on my system the correct alsaplayer
device string of the built-in Intel sound card is "default:CARD=Intel";
"Intel" or "HDA Intel" do not work.

--
Regards, | http://users.icfo.es/Florian.Kulzer
Florian |


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Arc Roca 12-10-2008 07:54 PM

creative xmod sound card
 
Thank you Florian, that was the whole problem! Now I have both working (I left xmod as default)
aplay -L was the key to determine the correct name.
alsaplayer -d "default:CARD=Xmod" file.ogg
works.
Now I have to solve the volume button issue, which is not properly controlled.

--- On Wed, 12/10/08, Florian Kulzer <florian.kulzer+debian@icfo.es> wrote:
From: Florian Kulzer <florian.kulzer+debian@icfo.es>
Subject: Re: creative xmod sound card
To: debian-user@lists.debian.org
Date: Wednesday, December 10, 2008, 1:52 PM

You have to use "aplay -L" (which is the same as "aplay
--list-pcms") to
get a list of the known PCM names.

> However, this is what I get now, same as before:
>

> arc@tosh:~/música/JoanManuelSerrat$ alsaplayer -d Xmod Benito.ogg
> ALSA lib pcm.c:2144:(snd_pcm_open_noupdate) Unknown PCM Xmod

I think you are using the wrong device string; AFAIK, it has be a known
PCM name (see above). For example, on my system the correct alsaplayer
device string of the built-in Intel sound card is
"default:CARD=Intel";
"Intel" or "HDA Intel" do not work.


All times are GMT. The time now is 03:02 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.