FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian User

 
 
LinkBack Thread Tools
 
Old 12-09-2008, 10:20 AM
Ólafur Jens Siguršsson
 
Default rendering problem with iceweasel in sid

Hi, I have a strange rendering problem in Iceweasel 3.0.4-1, when I
look at a page in the Icelandic wikipedia that contains some math
functions then there is a half box around the equation (the left and
top side of the box show, see for example
http://is.wikipedia.org/wiki/Logri) and when I look at some tables
like in
http://is.wikipedia.org/wiki/Listi_yfir_lönd_og_śtliggjandi_yfirrįšasvęši_eftir _stęrš
then there is a seperator between lines sometimes missing, like
between lines 25 and 26, 37 and 38, 49 and 50 and more.

Anyone else see this or have any idea of what could be wrong?

Cheers

Oli


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 12-09-2008, 11:15 AM
Sven Joachim
 
Default rendering problem with iceweasel in sid

On 2008-12-09 12:20 +0100, Ólafur Jens Siguršsson wrote:

> Hi, I have a strange rendering problem in Iceweasel 3.0.4-1, when I
> look at a page in the Icelandic wikipedia that contains some math
> functions then there is a half box around the equation (the left and
> top side of the box show, see for example
> http://is.wikipedia.org/wiki/Logri) and when I look at some tables
> like in
> http://is.wikipedia.org/wiki/Listi_yfir_lönd_og_śtliggjandi_yfirrįšasvęši_eftir _stęrš
> then there is a seperator between lines sometimes missing, like
> between lines 25 and 26, 37 and 38, 49 and 50 and more.
>
> Anyone else see this or have any idea of what could be wrong?

These pages look perfectly fine here. Which video driver do you use and
what are the default fonts in Iceweasel?

Sven


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 12-09-2008, 12:03 PM
Ólafur Jens Siguršsson
 
Default rendering problem with iceweasel in sid

On Tue, Dec 09, 2008 at 01:15:07PM +0100, Sven Joachim wrote:
> On 2008-12-09 12:20 +0100, Ólafur Jens Siguršsson wrote:
>
> > Hi, I have a strange rendering problem in Iceweasel 3.0.4-1, when I
> > look at a page in the Icelandic wikipedia that contains some math
> > functions then there is a half box around the equation (the left and
> > top side of the box show, see for example
> > http://is.wikipedia.org/wiki/Logri) and when I look at some tables
> > like in
> > http://is.wikipedia.org/wiki/Listi_yfir_lönd_og_śtliggjandi_yfirrįšasvęši_eftir _stęrš
> > then there is a seperator between lines sometimes missing, like
> > between lines 25 and 26, 37 and 38, 49 and 50 and more.
> >
> > Anyone else see this or have any idea of what could be wrong?
>
> These pages look perfectly fine here. Which video driver do you use and
> what are the default fonts in Iceweasel?

The device section in my xorg.conf is

Section "Device"
Identifier "Intel Corporation 82865G Integrated Graphics Controller"
Driver "i810"
BusID "PCI:0:2:0"
EndSection

lspci says

00:02.0 VGA compatible controller: Intel Corporation 82865G Integrated
Graphics Controller (rev 02)

Default font in Iceweasel is serif according to Preferences -> Content

Tia

Oli


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 12-09-2008, 12:30 PM
Sven Joachim
 
Default rendering problem with iceweasel in sid

On 2008-12-09 14:03 +0100, Ólafur Jens Siguršsson wrote:

> The device section in my xorg.conf is
>
> Section "Device"
> Identifier "Intel Corporation 82865G Integrated Graphics Controller"
> Driver "i810"
> BusID "PCI:0:2:0"
> EndSection
>
> lspci says
>
> 00:02.0 VGA compatible controller: Intel Corporation 82865G Integrated
> Graphics Controller (rev 02)

Do you use EXA or XAA? Many problems have been reported in the Intel
video driver, the closest I could find for your problem is #491871¹.

> Default font in Iceweasel is serif according to Preferences -> Content

And what is used for serif (use the "Advanced..." button to see it)?

Sven


¹ http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=491871


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 12-09-2008, 11:06 PM
Ólafur Jens Siguršsson
 
Default rendering problem with iceweasel in sid

On Tue, Dec 09, 2008 at 02:30:12PM +0100, Sven Joachim wrote:
> On 2008-12-09 14:03 +0100, Ólafur Jens Siguršsson wrote:
>
> > The device section in my xorg.conf is
> >
> > Section "Device"
> > Identifier "Intel Corporation 82865G Integrated Graphics Controller"
> > Driver "i810"
> > BusID "PCI:0:2:0"
> > EndSection
> >
> > lspci says
> >
> > 00:02.0 VGA compatible controller: Intel Corporation 82865G Integrated
> > Graphics Controller (rev 02)
>
> Do you use EXA or XAA? Many problems have been reported in the Intel
> video driver, the closest I could find for your problem is #491871¹.

Nope, neither of those options are set in my xorg.conf file.

>
> > Default font in Iceweasel is serif according to Preferences -> Content
>
> And what is used for serif (use the "Advanced..." button to see it)?

What it says there is:

Fonts for: Western

Proportional Serif Size 16
Serif Serif
Sans-serif sans-serif
Monospace monospace size 12

Minimum font-size None

I have the "allow pages to choose their own fonts, instead of my
selection above" checked

Default character encoding is Western (ISO-8859-1)

Tia

Oli


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 12-10-2008, 07:29 PM
Ólafur Jens Siguršsson
 
Default rendering problem with iceweasel in sid

On Tue, Dec 09, 2008 at 02:30:12PM +0100, Sven Joachim wrote:
> On 2008-12-09 14:03 +0100, Ólafur Jens Siguršsson wrote:
>
> > The device section in my xorg.conf is
> >
> > Section "Device"
> > Identifier "Intel Corporation 82865G Integrated Graphics Controller"
> > Driver "i810"
> > BusID "PCI:0:2:0"
> > EndSection
> >
> > lspci says
> >
> > 00:02.0 VGA compatible controller: Intel Corporation 82865G Integrated
> > Graphics Controller (rev 02)
>
> Do you use EXA or XAA? Many problems have been reported in the Intel
> video driver, the closest I could find for your problem is #491871¹.
>

Interesting thing happened, I just dist-upgraded my machine and it
pulled in a new kernel which made my X unusable. I asked someone on
irc about it and s/he suggested that I add the following options to
xorg.conf

Option "AccelMethod" "exa"
Option "MigrationHeuristic" "greedy"
Option "ExaNoComposite" "true"

That did not help with my X so I changed back to my old kernel
(2.6.25-2) and with those options in my xorg.conf and switching to the
intel driver instead of i810 I no longer see those boxes around
equations in the wiki but I am still missing a few lines in that long
list.

Cheers

Oli


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 12-10-2008, 08:17 PM
Frank McCormick
 
Default rendering problem with iceweasel in sid

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Ólafur Jens Siguršsson wrote:
> On Tue, Dec 09, 2008 at 02:30:12PM +0100, Sven Joachim wrote:
>> On 2008-12-09 14:03 +0100, Ólafur Jens Siguršsson wrote:
>>
>>> The device section in my xorg.conf is
>>>
>>> Section "Device"
>>> Identifier "Intel Corporation 82865G Integrated Graphics Controller"
>>> Driver "i810"
>>> BusID "PCI:0:2:0"
>>> EndSection
>>>
>>> lspci says
>>>
>>> 00:02.0 VGA compatible controller: Intel Corporation 82865G Integrated
>>> Graphics Controller (rev 02)
>> Do you use EXA or XAA? Many problems have been reported in the Intel
>> video driver, the closest I could find for your problem is #491871¹.
>>
>
> Interesting thing happened, I just dist-upgraded my machine and it
> pulled in a new kernel which made my X unusable. I asked someone on
> irc about it and s/he suggested that I add the following options to
> xorg.conf
>
> Option "AccelMethod" "exa"
> Option "MigrationHeuristic" "greedy"
> Option "ExaNoComposite" "true"
>
> That did not help with my X so I changed back to my old kernel
> (2.6.25-2) and with those options in my xorg.conf and switching to the
> intel driver instead of i810 I no longer see those boxes around
> equations in the wiki but I am still missing a few lines in that long
> list.


Try the intel driver instead of the i810. With your graphics chip it
seems to de a better job. YMMV


Cheers




-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iEYEARECAAYFAklAMeEACgkQnQV1aTcQlJsDhgCfZHTNgQJoeM Ja7xWCtGGI3dgr
jhAAni8d5l9WFGP6rOqLLd8ZlVi6Xrim
=k0oH
-----END PGP SIGNATURE-----


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 

Thread Tools




All times are GMT. The time now is 12:44 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org