FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian User

 
 
LinkBack Thread Tools
 
Old 12-05-2008, 06:14 PM
Martin McCormick
 
Default Can't build 2.6.5 kernel after Upgrade to Etch-and-a-Half

I upgraded this system about a week ago and this is the
first thing that doesn't work at all. I had needed to compile
the USB serial driver in to the kernel so I originally did
make menuconfig

which gave me the errors you will see below. I then did make
mrproper to start clean and then make to see what I would get.
The first error is understandable as there was now no .config
after the make mrproper. Things then go from bad to worse.

3hydrogen#make
Makefile:405: .config: No such file or directory
CHK include/linux/version.h
UPD include/linux/version.h
SYMLINK include/asm -> include/asm-i386
HOSTCC scripts/basic/fixdep
HOSTCC scripts/basic/split-include
HOSTCC scripts/basic/docproc
SHIPPED scripts/kconfig/zconf.tab.h
HOSTCC scripts/kconfig/conf.o
HOSTCC scripts/kconfig/mconf.o
scripts/kconfig/mconf.c:91: error: static declaration of 'current_menu' follows
non-static declaration
scripts/kconfig/lkc.h:63: error: previous declaration of 'current_menu' was here
make[2]: *** [scripts/kconfig/mconf.o] Error 1
make[1]: *** [silentoldconfig] Error 2
make: *** [include/linux/autoconf.h] Error 2

I am not sure what changed in the environment after the
upgrade, but this source all did compile before.

Any ideas are appreciated.

Martin McCormick WB5AGZ Stillwater, OK
Systems Engineer
OSU Information Technology Department Telecommunications Services Group


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 12-06-2008, 03:40 AM
Ron Johnson
 
Default Can't build 2.6.5 kernel after Upgrade to Etch-and-a-Half

On 12/05/08 13:14, Martin McCormick wrote:

I upgraded this system about a week ago and this is the
first thing that doesn't work at all. I had needed to compile
the USB serial driver in to the kernel so I originally did
make menuconfig


2.6.5 is (relatively) ancient. Did you mean 2.6.25?

--
Ron Johnson, Jr.
Jefferson LA USA

How does being physically handicapped make me Differently-Abled?
What different abilities do I have?


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 12-06-2008, 12:18 PM
Martin McCormick
 
Default Can't build 2.6.5 kernel after Upgrade to Etch-and-a-Half

Ron Johnson writes:
> 2.6.5 is (relatively) ancient. Did you mean 2.6.25?

I did, in fact, mean 2.6.5. It's been 3 or 4 years now
that you mention it. I'll try a newer kernel.:-)

Thanks.

Martin McCormick


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 

Thread Tools




All times are GMT. The time now is 06:40 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org