FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian User

 
 
LinkBack Thread Tools
 
Old 12-02-2008, 07:01 PM
Tommy Bongaerts
 
Default Compilation of Ardour3 fails: cannot find libsndfile

Hello list,

I'm trying to install Ardour3 on my Debian Lenny box, but configuring
fails because it cannot find the sndfile 1.8 library:

tommy@mordor:~/src/svn/ardour/3.0$ scons PREFIX=/opt
scons: Reading SConscript files ...
Checking for pkg-config version >= 0.8.0... yes
Checking for aubio... yes
Checking for ogg... yes
Checking for gthread-2.0... yes
Checking for lrdf... yes
Checking for libgnomecanvas-2.0... yes
Checking for gtk+-2.0... yes
Checking for jack... yes
Checking for flac... yes
Checking for sndfile... no
sndfile >= 1.0.18 not found.
You do not have the necessary dependencies required to build ardour
Please consult http://ardour.org/building for more information

I have however installed libsndfile 1.0.18 from source with
--prefix=/opt. I also ran ldconfig to update my libraries cache.
/opt/lib is in my ld.so.conf, so scons should be able to locate the
correct libraries, no?

tommy@mordor:~/src/svn/ardour/3.0$ cat /etc/ld.so.conf
include /etc/ld.so.conf.d/*.conf
/opt/lib

Anyone knows what could be wrong here?

--
I know not with what weapons World War III will be fought,
but World War IV will be fought with sticks and stones.
~ Albert Einstein


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 12-02-2008, 07:28 PM
Ron Johnson
 
Default Compilation of Ardour3 fails: cannot find libsndfile

On 12/02/08 14:01, Tommy Bongaerts wrote:

Hello list,

I'm trying to install Ardour3 on my Debian Lenny box, but configuring
fails because it cannot find the sndfile 1.8 library:

tommy@mordor:~/src/svn/ardour/3.0$ scons PREFIX=/opt
scons: Reading SConscript files ...
Checking for pkg-config version >= 0.8.0... yes
Checking for aubio... yes
Checking for ogg... yes
Checking for gthread-2.0... yes
Checking for lrdf... yes
Checking for libgnomecanvas-2.0... yes
Checking for gtk+-2.0... yes
Checking for jack... yes
Checking for flac... yes
Checking for sndfile... no
sndfile >= 1.0.18 not found.
You do not have the necessary dependencies required to build ardour
Please consult http://ardour.org/building for more information

I have however installed libsndfile 1.0.18 from source with
--prefix=/opt. I also ran ldconfig to update my libraries cache.
/opt/lib is in my ld.so.conf, so scons should be able to locate the
correct libraries, no?


tommy@mordor:~/src/svn/ardour/3.0$ cat /etc/ld.so.conf
include /etc/ld.so.conf.d/*.conf
/opt/lib

Anyone knows what could be wrong here?


$ apt-cache search libsndfile
libsndfile1 - Library for reading/writing audio files
libsndfile1-dev - Library for reading/writing audio files
mffm-libsndfilew-dev - wrapper for the libsndfile audio file...
moc - ncurses based console audio player
sndfile-programs - Sample programs that use libsndfile

Looks like you need to install libsndfile1-dev.

--
Ron Johnson, Jr.
Jefferson LA USA

How does being physically handicapped make me Differently-Abled?
What different abilities do I have?


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 12-02-2008, 11:21 PM
Tommy Bongaerts
 
Default Compilation of Ardour3 fails: cannot find libsndfile

On Tue, Dec 02, 2008 at 02:28:25PM -0600, Ron Johnson wrote:

> On 12/02/08 14:01, Tommy Bongaerts wrote:
>> Hello list,
>>
>> I'm trying to install Ardour3 on my Debian Lenny box, but configuring
>> fails because it cannot find the sndfile 1.8 library:

> $ apt-cache search libsndfile
> libsndfile1 - Library for reading/writing audio files
> libsndfile1-dev - Library for reading/writing audio files
> mffm-libsndfilew-dev - wrapper for the libsndfile audio file...
> moc - ncurses based console audio player
> sndfile-programs - Sample programs that use libsndfile
>
> Looks like you need to install libsndfile1-dev.

If it only were that simple...

No, ardour3 depends on sndfile 1.0.18, but Lenny carries 1.0.17.
That's why I installed 1.0.18 from source.

Mhh, I prolly need to tell the system to look for header files under
/opt... Let's see if that works.

--
Always be wary of any helpful item that weighs less than its
operating manual.
~ Terry Pratchett


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 12-03-2008, 02:21 AM
Ron Johnson
 
Default Compilation of Ardour3 fails: cannot find libsndfile

On 12/02/08 18:21, Tommy Bongaerts wrote:

On Tue, Dec 02, 2008 at 02:28:25PM -0600, Ron Johnson wrote:


On 12/02/08 14:01, Tommy Bongaerts wrote:

Hello list,

I'm trying to install Ardour3 on my Debian Lenny box, but configuring
fails because it cannot find the sndfile 1.8 library:



$ apt-cache search libsndfile
libsndfile1 - Library for reading/writing audio files
libsndfile1-dev - Library for reading/writing audio files
mffm-libsndfilew-dev - wrapper for the libsndfile audio file...
moc - ncurses based console audio player
sndfile-programs - Sample programs that use libsndfile

Looks like you need to install libsndfile1-dev.


If it only were that simple...

No, ardour3 depends on sndfile 1.0.18, but Lenny carries 1.0.17.
That's why I installed 1.0.18 from source.


And even Sid only has v1.0.17.


Mhh, I prolly need to tell the system to look for header files under
/opt... Let's see if that works.


--
Ron Johnson, Jr.
Jefferson LA USA

How does being physically handicapped make me Differently-Abled?
What different abilities do I have?


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 12-03-2008, 08:11 AM
Tommy Bongaerts
 
Default Compilation of Ardour3 fails: cannot find libsndfile

On Wed, Dec 03, 2008 at 01:21:11AM +0100, Tommy Bongaerts wrote:

> Mhh, I prolly need to tell the system to look for header files under
> /opt... Let's see if that works.

If I only knew how it should be done...

--
Duct tape is like the force. It has a light side, and a dark side, and
it holds the universe together.
~ Carl Zwanzig


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 12-03-2008, 01:34 PM
"David Fox"
 
Default Compilation of Ardour3 fails: cannot find libsndfile

On Wed, Dec 3, 2008 at 1:11 AM, Tommy Bongaerts
<tommy.bongaerts@drumscum.be> wrote:
> On Wed, Dec 03, 2008 at 01:21:11AM +0100, Tommy Bongaerts wrote:
>
>> Mhh, I prolly need to tell the system to look for header files under
>> /opt... Let's see if that works.
>
> If I only knew how it should be done...

Check with ./configure -help. There might be an includefile dir option
that you can add to the compile / configuration line like ./configure
--with-includes=/opt or some such. It's been a while since I had to
tweak like this, though.


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 

Thread Tools




All times are GMT. The time now is 09:29 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org